Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Test retrieve user : Failed

This is pretty frustrating.

Have installed Jira Core 7.4.2 on Windows Server 2016

My intention is to create and Active Directory Sync that gets all users within an AD-group. But i get stuck on an error that my sync account cannot be found.

This is what i have filled in into the Configure LDAP User Directory page:

Directory Type: Microsoft Active Directory
Hostname: domaincontroller.domain.com (also tested netbiosname only)
Port: 389
Username: SVC-Jira-Sync@domain.com (also tested FQDN, ie CN=SVC-Jira-Sync,OU=etc etc)
Password: The password for SVC-Jira-Sync
Base DN: Tested both DC=Domain,DC=com and a more specific OU FQDN
LDAP Permission: Read Only

Left the rest default

When its time for testing the connection i fill in User name and Password for SVC-Jira-Sync (tested both UPN and FQDN) i get this:

Test basic connection : Succeeded
Test retrieve user : Failed

User <SVC-Jira-Sync> does not exist
The rest of the tests are not performed.
 
if i on the Jira server open Powershell and run:
Get-ADUser "CN=SVC-Jira-Sync,OU=etcetc" -Server <server specified>
I get the user back, also verified the the UPN is correct.
 
I dont have any spaces in my FQDNs
 
Whats next?

1 answer

1 accepted

3 votes
Answer accepted

Somehow this error was only during the Save+Test phase, if i pressed Save+Test and then before testing i pressed back to directory lists and there i press synchronization. It works without errors.


Jira bug!!!

Micke, thank you!

I have faced to the same problem. Test failed, but sync is ok.

Same issue on 2 instances of JIRA.  Unable to query base of AD and all underlying objects.  HELP?

Have a look at the log file - that will be recording the errors encountered when you click test or synchronise, and they should tell you what is wrong.

Same for us (Dec 2017).  The test could not find the user.  When I went back to the Users and Groups page all the objects were there.  Don't see any issues yet.  [Atlassian Bitbucket v4.12.1]

Like Joe likes this

I'm facing same problem but objects were not there after sync successfull. I'm getting ad groups but not getting there users.

You'll need to read the log file to find out if this is a problem with the sync.  And check that the user does actually exist in LDAP as you expect it to.

Yes, User exist in LDAP and also added in AD groups. It's synced successful and
checked there was no error shown in logs.
Error logs :
synchronised [ 0 ] users in [ 0ms ]
scanning [ 0 ] users to add or update

 

There is any another reason it'snot getting the users?

They might not be being selected by the rules you have set for what to synchronise or by permissions on the LDAP side.

I'm afraid without any errors on the Jira side, you'll need to debug what LDAP is doing.  You could increase logging on the Jira side to see if you can get more detail from the connection it is trying to make (Admin -> logging and profiling, I think there's an LDAP or User directory class you can increase logging on), but this is starting to look like a problem with LDAP, not Jira.

One more thing after next try it were through sync error:

Caused by: org.springframework.ldap.UncategorizedLdapException: Uncategorized exception occured during LDAP processing; nested exception is javax.naming.NamingException: LDAP response read timed out, timeout used:120000ms.; remaining name '/'

 

So it means we are having LDAP issue here, we need to check with LDAP part

That answers it - your LDAP server is failing to respond in time.

Hi All,

When I am testing with all LDAP credentials the test connection is successfully done. But again when I click on synchronize it is full synchronize successful but in the logs, I can see none of the users are synchronized from LDAP to Jira. But on the Jira side, it is showing us as Test user failed but the user exists in the LDAP server.  And also in the logs, I can see error related to that i.e., 

nested exception is javax.naming.CommunicationException: DOMAIN.COM:636 [Root exception is javax.net.ssl.SSLHandshakeException: java.security.cert.CertificateException: No subject alternative DNS name matching DOMAIN.COM found.]=

 

Kindly help me with this.

 

Thanks and Regards

Mone Dileep Kumar 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

Bitbucket Smart Commits vs. Genius Commits - What's the difference?

If you already heard about Smart Commits in Bitbucket, know that you just stumbled upon something even better (and smarter!): Genius Commits by Better DevOps Automation for Jira Data Center (+ Server...

114 views 0 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you