Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

Recognition

  • Give kudos
  • My kudos

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

No Windows administrator rights for upgrade?

I'm trying to update my Local Jira Core to version 8.4.1., running on my Windows 10 PC. During the installation process I receive the following message: You do not have write permissions to the existing installation directory. 

I'm however the administrator (and only user) of the PC on which I want to do the upgrade. I have all the rights and Windows doesn't prompt me for my administrator password anyway.

So I don't know how to proceed now.

2 answers

1 accepted

0 votes
Answer accepted

The solution was not in the read + write permissions (that can be changed per file but not per directory, even not with all the methods suggestions), but appeared to be even easier: I had to run the installer as an administrator. Starting it as a user with administrator rights wasn't enough.

Running as an administrator (right mouse button) worked and the installation succeeded.

But thanks a lot for your support!

You need to check if you have read + write permissions on the Jira installation directory.

In a windows system, it is usually C:\Program Files\Atlassian

Many times, windows does not allow write permissions directly and you need to explicitly enable these permissions.

Just make sure that you have read + write permissions on the Jira installation directory and your issue should be resolved.

Hi Deepanshu,

Thanks for your reply and I think you touch the core of the problem here, but I cannot solve it. In Windows the read-only attribute of folders / directories cannot be switched off.

The attribute can be disabled for all files in the folder (& subfolders), which I did. That should be sufficient, but the update installer still stops with the same error message.  I'm afraid it is triggered by the read only-attribute of the Atlassian folder of Jira subfolder, although every file within these folder can be changed or deleted.

 

BR Daan

Hi Dan,

Checkout this link : https://windowsreport.com/folder-reverting-to-read-only/

This may solve your issue.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Jira Core

How to manage many similar workflows?

I have multiple projects that use variations of the same base workflow. The variations depend on the requirements of the project or issue type. The variations mostly come in the form of new statuses ...

3,998 views 11 5
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you