Jython script no longer working after update from 7.1.7 to 7.3.3

I had a jython script as a post function that would automatically set select list fields in JIRA based on information from a database. This is no longer working after updating. I get no errors or anything useful to go on. 

Is there something significant that changed between versions to cause this?

1 answer

0 vote

I suspect that I know what has changed (the field value storage is now single arrays rather than an option), but you really need to be seeing the error messages JIRA is returning when you try to push values in.

There are no errors in the logs when I try it. The ticket just gets made as normal. What should I look for in the script to change realted to the field value storage?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Sunday in Agility

You asked for it, so we delivered: images on issues have arrived

A picture tells a thousand words. And agility boards have just released their latest feature: cover images on issues – so now your board can tell a story at first glance. Upload attachmen...

172 views 1 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you