Jython script no longer working after update from 7.1.7 to 7.3.3

I had a jython script as a post function that would automatically set select list fields in JIRA based on information from a database. This is no longer working after updating. I get no errors or anything useful to go on. 

Is there something significant that changed between versions to cause this?

1 answer

0 votes

I suspect that I know what has changed (the field value storage is now single arrays rather than an option), but you really need to be seeing the error messages JIRA is returning when you try to push values in.

There are no errors in the logs when I try it. The ticket just gets made as normal. What should I look for in the script to change realted to the field value storage?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 09, 2018 in Jira Core

How to manage many similar workflows?

I have multiple projects that use variations of the same base workflow. The variations depend on the requirements of the project or issue type. The variations mostly come in the form of new statuses ...

379 views 6 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you