Jira setup wizard unable to add user (admin)

while installing JIRA on windows,

during the setup wizard, at step "SetupAdminAccount.jspa" i got a error : 

in french : " Impossible d'ajouter un utilisateur : tous les répertoires d'utilisateur sont en lecture seule."

in english : " unable to add a user : all user's directory are read-only"  or something like this.

i find no error in the logs to help me understand ...

 

can you help me ? 

 

Yann.

8 answers

Hi https://answers.atlassian.com/questions/users?username=guillerm.yann575961566

Cause is that :

LDAP is configured before first setting up JIRA.

so First setup JIRA. then go for JIRA Configuration.


Solution :

Ensure that JIRA is up and running before integrating with the LDAP repository.

Comment out the LDAP tag from <jira-home>/jira/WEB-INF/classes/atlassian-user.xml

and then restart Jira.

Thanks

1 votes

It looks like there's something wrong with your database as well as an only partial setup.  It might be that a dodgy database setup is breaking the installation, but you should be seeing lots of errors in the application logs if that is the case.

If JIRA can't create users during the installation, then there's something a bit broken somewhere, and it can leave the installation in a big mess.  Rather than try to unpick it all, it's usually easier to start a clean installation and make sure it goes through ok.

Is it possible to start again, selecting internal users in the installation, so that you don't have read/write issues with external directories?  External directories are very easy to add to new JIRA systems after installation and a clean install with local users should be a lot easier to debug.

Chris Fuller Atlassian Team May 30, 2016

During the setup, it's going to try to create an administrator account with the information that you provide.  This error message means that it failed to do that because it thinks that none of the user directories are writable.

This is a very strange thing for a fresh install to run into normally, as you don't get an opportunity to change user directory information until after you have done the setup.  I checked the code and don't see any way that this would be likely to happen "by mistake" or as "the wrong error message", which was my initial suspicion.

As Nic says, I would try again, making sure you are definitely starting from a clean database.

I faced same error JIRA 7.2.2 and PostgreSQL 9.6.

I found related issue on Confluence.

https://jira.atlassian.com/browse/CONF-44216

 

I had the same issue, not sure if the same setup though.

See my resolution here : https://answers.atlassian.com/questions/32534340

Hope it helps someone.

Hi, 

Thanks for your answer But : 

  • the <jira-home>/jira/WEB-INF/classes/atlassian-user.xml  does not exist on my computer.
  • the path <jira-home>/jira/WEB-INF/classes/ exist and is full of files.
  • the only xml file with "LDAP" is a pom file.

 

i try restart JIRA but it was the same problem.

in the log file i see thoses errors which does not seems to be related : 

 

2016-05-30 14:00:46,451 http-nio-8088-exec-18 ERROR anonymous 840x18x1 fs8or 0:0:0:0:0:0:0:1 /secure/SetupDatabase!default.jspa [c.a.j.bc.dataimport.DefaultDataImportService] Error importing data: java.lang.RuntimeException: Could not get unique fields for table 'AO_21D670_WHITELIST_RULES'
java.lang.RuntimeException: Could not get unique fields for table 'AO_21D670_WHITELIST_RULES'
at net.java.ao.schema.helper.DatabaseMetaDataReaderImpl.getUniqueFields(DatabaseMetaDataReaderImpl.java:185)

.....

Caused by: org.postgresql.util.PSQLException: ERREUR: la colonne am.amcanorder n'existe pas
Position : 407
at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2101)
at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1834)

 

Hi were you able to solve this?

I encountered the same error with AO_21D670_WHITELIST_RULES. I tried to migrate from H2 to Postgres. Postgres 9.6 lead to the error. Postgres 9.3 worked. (I did not read the list of supported databases smile - and there 9.3 is the newest supported postgres version currently.)

i have the same problem with JIRA 7.1.1.

 

Have you tried what Chris and I suggested?

dbconfig.xml (with IP 999....)

<jira-database-config>

  <name>defaultDS</name>

  <delegator-name>default</delegator-name>

  <database-type>oracle10g</database-type>

  <jdbc-datasource>

    <url>jdbc:oracle:thin:@//999.999.999.999:1521/JIRA2</url>

    <driver-class>oracle.jdbc.OracleDriver</driver-class>

    <username>JIRAPROD</username>

    <password>JIRAPROD</password>

    <pool-min-size>20</pool-min-size>

    <pool-max-size>20</pool-max-size>

    <pool-max-wait>30000</pool-max-wait>

    <validation-query>select 1 from dual</validation-query>

    <pool-max-idle>20</pool-max-idle>

    <pool-remove-abandoned>true</pool-remove-abandoned>

    <pool-remove-abandoned-timeout>300</pool-remove-abandoned-timeout>

  </jdbc-datasource>

</jira-database-config>

I have create the user JIRAPROD on this Oracle serveur just before the setup.

During the setup, all table are create but i can't create the user admin.

 

On this Oracle serveur, there is an other database for JIRA.

i solved the problem by reinstall everything , starting by the database. I work for me.

i thing that i encounter a problem because i dont wait for something to be well installed before going to the next install step.

 

Thanks for your help.

Ok, so when you're setting this up, you need to look at why you can't create the admin user. 

If it's a new clean JIRA, then this shouldn't go wrong unless the database is preventing insert/create etc, so that would tell us that your database is set up incorrectly (not the connection to it, but the database) or has a fault.

I have solved this issue by removing 'databaseconfig.xml' file from Jira's Home directory and restarting JIRA and setup again.

I experienced this same error against a postgres 9.6 database. I replaced the pre-packaged postgres driver in the lib directory with a newer version, stopped/restarted jira and that worked. 

Suggest an answer

Log in or Join to answer
Community showcase
Teodora [Botron]
Published Feb 15, 2018 in Marketplace Apps

Jira Inferno: The Nine Circles of Jira Administration Hell

If you spend enough time as a Jira admin - whether you are managing a single, mid-sized instance, a large enterprise one or juggling multiple instances at once - you will eventually find yourself in ...

1,063 views 6 19
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot