Integrity checker: internal server error

Hi All,

I have some problems running integrity checker in my JIRA (v5.2.11) and I'm getting Internal Server Error for this checks:

  • Check Issue for Relation 'ParentProject'
  • Check workflow current step entries

In the log I can't found anything related to it.

What does they do?

Can I raise the log level for this two checks?

6 answers

1 accepted

This widget could not be displayed.

Hi all,

the problem was caused by apache timeout and I solved it setting the timeout to ten minutes in the proxy_ajp module:

ProxyPass      /jira   ajp://jira-server:8009/jira         connectiontimeout=600 timeout=600 ping=1

Yes, it would be solved pointing directly to the jira server instead of point to reverse proxy. Thanks!!

This widget could not be displayed.

HI @Luca Andreatta

 

please follow the steps to find Integrity checker but for this you must have System Administrator permission then only you can do this.

 

Choose  > System. Select Troubleshooting and Support > Integrity Checker to open the Integrity Checker page.

I think you didn't read my question.

I have already run the integrity checker, but I got an internal server error and I don't understand why.

This widget could not be displayed.

Luca, Please include the stacktrace received with the internal server error, as you can see what classes and sub errors might have caused it.

I don't have any stacktrace nor in the log nor in the page. The page displays only this message:

Internal Server Error

The server encountered an internal error or
misconfiguration and was unable to complete
your request.

Please contact the server administrator,
 root@localhost and inform them of the time the error occurred,
and anything you might have done that may have
caused the error.

More information about this error may be available
in the server error log.


Apache/2.2.15 (CentOS) Server at jiratest Port 443
This widget could not be displayed.

I got a bit deeper inside the code to found that this checks are listed in com.atlassian.jira.appconsistency.integrity.IntegrityCheckManagerImpl and the two that are giving me the errors are these:

  • com.atlassian.jira.appconsistency.integrity.check.PrimaryEntityRelationDelete
  • com.atlassian.jira.appconsistency.integrity.check.WorkflowCurrentStepCheck

It is still not clear for me why I get that error.

This widget could not be displayed.

Luca, try adding some more memory to the JIRA instance.  It's possible that you're running out of memory.  In the /bin/setenv.sh file you should see a few lines:

 

JVM_MINIMUM_MEMORY="3072m"
JVM_MAXIMUM_MEMORY="3072m"

Ours are set to 3G each.  You don't have to do it this way where the Minumum and Maximum are the same, you can start with 1024m for the minimum.  However, if you have it the same, then Tomcat doesn't have to go and grab the memory - which can be a small performance hit.

 

--Jason

Thanks for the suggestion Jason, but it didn't worked.

Memory during the check didn't raise so much:

Heap Configuration:
   MinHeapFreeRatio         = 0
   MaxHeapFreeRatio         = 100
   MaxHeapSize              = 3170893824 (3024.0MB)
   NewSize                  = 44564480 (42.5MB)
   MaxNewSize               = 1056964608 (1008.0MB)
   OldSize                  = 89653248 (85.5MB)
   NewRatio                 = 2
   SurvivorRatio            = 8
   MetaspaceSize            = 21807104 (20.796875MB)
   CompressedClassSpaceSize = 1073741824 (1024.0MB)
   MaxMetaspaceSize         = 17592186044415 MB
   G1HeapRegionSize         = 0 (0.0MB)
Heap Usage:
PS Young Generation
Eden Space:
   capacity = 816316416 (778.5MB)
   used     = 189934960 (181.13609313964844MB)
   free     = 626381456 (597.3639068603516MB)
   23.267320891412773% used
From Space:
   capacity = 119013376 (113.5MB)
   used     = 16939016 (16.15430450439453MB)
   free     = 102074360 (97.34569549560547MB)
   14.232867404752891% used
To Space:
   capacity = 116916224 (111.5MB)
   used     = 0 (0.0MB)
   free     = 116916224 (111.5MB)
   0.0% used
PS Old Generation
   capacity = 472907776 (451.0MB)
   used     = 405112656 (386.3455352783203MB)
   free     = 67795120 (64.65446472167969MB)
   85.66419850960538% used
198946 interned Strings occupying 25168328 bytes.
This widget could not be displayed.

I cannot find a way out till now, but the problem is becoming critical.

 

I have some problems with workflow statuses and I think that running "" could solve my problems. Is there a way to run it in another way? Maybe from console inside the server itself?

 

The error that I have now with the workflow is this:

State of issue [MIDG_PVEND-20] has an action [id=131] which cannot be found in the workflow descriptor

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

165 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you