How to fix an exported Jira backup file with invalid unicode characters (xc)

I am attempting to import an JIRA backup file from an on-site instance to the cloud.  It fails everytime with "There was an error parsing the entities.xml file: An invalid XML character (Unicode: 0xc) was found in the CDATA section.".

I have tried using the atlassian-xml-cleaner-0.1 java tool but when I use it I receive a ".zip doesn't contain any valid import data." error. 

Can anyone help?

2 answers

This widget could not be displayed.

You haven't read the instructions for the cleaner utility.  See the bit about opening the zip file.

That's only slightly rude.  I did unzip the zip file and executed the jar on the entities.xml and saved it to entities-clean.xml.   Then I moved the old entities.xml to another file for safe keeping and renamed entities-clean.xml to entities.xml.

I also added the data folder with attachments and avatars then zipped it back up (which adding the data folder to the zip solved the .zip doesn't contain any valid import data error). The problem is not with me being unable to read and follow directions the problem is I followed the directions carefully and it still did not work.

If fact, i was finally able to get JIRA cloud to accept the zip file but I still have a problem.  It did not actually populate the cloud with the existing projects.

The error message you got is what you get if you did not follow the instructions in the documentation.  Hence the pointer to re-read it properly.  It wasn't meant to be rude, it just looked like you hadn't read it, and there's a lot of people here who read the first sentence of something and expect that to fix things without bothering to read or understand the rest of it (which is annoying because someone has taken time to give a full answer, or write a decent doc on the process )

You've now explained clearly that you have done everything right.

The next thing I would test is that you can take that fixed import file and import it on a temporary installation of the same version it came from.

 

I have the exact same issue. Thanks to thahn I was able to get past the first error. The documentation is not clear at all when migrating to the Cloud version.

In case someone will come here form google:

for `.zip doesn't contain any valid import data.` error:

Import file should also contain data folder with avatars and attachements.

This widget could not be displayed.

I was facing the same issue today. The cause of the error 

"the zip doesn't contain any valid import data" might be that you were zipping the file with the wrong tool.

I was trying this on my mac, and zipping the folder with Finder created this error. When I created the zip file via command line, the import worked correctly.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published yesterday in Marketplace Apps

The 7 hacks of highly successful automation

...there's anything I've learnt from working, it's that people are lazy! No offense to anyone reading this, but it's true and we can all admit it. The easier you make something for someone, the more...

148 views 0 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you