Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Field required validator with condition not displaying the error message

Hi

I am completely new to Jira. I added a new validition in the create transition for one of our project. Validation parameter used is 'Field Required Validator (JMWE app)'. 

I set a validation for a radio button box and attachment. 

If the radio button box value is NO, then the email attachment should be mandatory. And an error message is also appended in the err msg box if someone is trying to send the request without attachment and radio button value NO.

!!issue.customfield_17285 && issue.customfield_17285.value == "NO"

Validation.JPG

Validation is working successfully. But it is not triggering the error message which available on the box. 

When the radio button value is 'NO' and if the reporter or requestor try to send the request without an attachment, it is throwing below error on middle of the screen

"Couldn't send requestYour request could not be created. Please check the fields have been correctly filled in."

Wrong_Error_msg.JPG

But if the radio buttion value is NO and attachment is appended to request, the requestor is able to send the request.

Would be great if someone can help on this issue.

Thanks

SHIYAS

2 answers

1 accepted

0 votes
Answer accepted

This is a known Jira Cloud bug: https://jira.atlassian.com/browse/JSDCLOUD-5853

You can add a comment on that ticket to show your interest.

Thand David for the link. Let me update a comment on the same.

0 votes
John Funk Community Leader Jun 10, 2020

Hi Shiyas - Welcome to the Atlassian Community!

My suspicion is because you are creating through a Service Desk Portal. Not sure what happens between JSD and JMWE in those cases. 

Have you tried to create a test record with just the Create button for the project (outside of the JSD Portal)?

No. I havent tried outside of JSD. Let me try it out.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

Announcing the waitlist for Jira Work Management

Hey there Cloud Community members! We’re excited to give you the first glimpse of the new home for business teams on Jira — Jira Work Management. Jira Work Management is the next generation of J...

637 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you