Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups



Hi all,


I installed jira on my server and enabled HTTPS but this is the issue that I'm getting.


My setup is following:

- I have 2 different virtual machines, one is for nginx reverse proxy and other is for Jira only

- Domain is set on nginx VM with lets encrypt and proxy_pass to Jira VM with following:


server {
location / {
proxy_set_header Host $host;
proxy_redirect off;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Host $host;
proxy_set_header X-Forwarded-Server $host;
client_max_body_size 10M;
listen 443 ssl; # managed by Certbot
ssl_certificate /etc/letsencrypt/live/; # managed by Certbot
ssl_certificate_key /etc/letsencrypt/live/; # managed by Certbot
include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot
server {
if ($host = {
return 301 https://$host$request_uri;
} # managed by Certbot
listen 80;
return 404; # managed by Certbot

Jira server.xml is set with following:

<Connector port="8080" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;"
maxThreads="150" minSpareThreads="25" connectionTimeout="20000" enableLookups="false"
maxHttpHeaderSize="8192" protocol="HTTP/1.1" useBodyEncodingForURI="true" redirectPort="8443"
acceptCount="100" disableUploadTimeout="true" bindOnInit="false" secure="true" scheme="https"
proxyName="" proxyPort="443"/>


When I tried CURL from Jira VM i got Connection refused

 Does anybody have any idea or this is not gonna work?

EDIT: Just tried fresh install and i'm having same error.

1 answer

0 votes
Petter Gonçalves
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Apr 08, 2020

Hello @Milos Moravac

Welcome to the Atlassian Community!

Can you please let us know where and what steps you took to reproduce the "gadget.common.error.500" error?

Checking other users facing the same problem, it seems it usually happens in the activity stream gadget of Jira dashboards. I this is the error you are facing, I believe that an invalid or absence of a certificate can lead to such errors.

Please, check  the steps provided in the thread below to properly fix the error:

Dashboard error gadget.common.error.500 

if none of the steps provided in the thread worked for you, please let us know the results you got from it and the errors returned in the javascript console of your Jira application.

Hi Petter,


Thanks for reply. I tried everything from every article on community. 


When I try to get my certificate with openssl s_client command in order to add it to Java trusted certs I'm getting following error:

139657218523584:error:0200206F:system library:connect:Connection refused:../crypto/bio/b_sock2.c:110:

139657218523584:error:2008A067:BIO routines:BIO_connect:connect error:../crypto/bio/b_sock2.c:111:


Which means that port 443 is not listening on VM where Jira is installed. 


My nginx VM is listening on that port and it's passing connection to Jira VM on port 8080

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events