Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

error: JIRA could not attach the file as there was a missing token. Please try attaching the file again. on Google Chrome

error: JIRA could not attach the file as there was a missing token. Please try attaching the file again. It happens on Google Chrome today.

21 answers

1 accepted

14 votes
Answer accepted

This happens when there's a network error, or timeout.  The easiest way to replicate it is to leave the computer for a while and then try the action - your tokens expire. Sometimes, it can happen when you're trying to upload too large a file as well.

Have you tried it again yet?  If you did, what happened?

"leave the computer for awhile and then try"

OMG, so let's define "awhile".  A minute?  An Hour"? A day?.  Do I leave the computer and go sit in another room or do I have to leave the building?  Or can I just throw a blanket over it so it thinks I left.    Maybe I could leave it at Atlassian headquarter and they could fix it.

Priceless.

Like # people like this

No, that is clearly not what I said.

Please try reading the answer properly and thinking about it in the context of the question that was asked, instead of being silly.

Like # people like this

Hi Nic, I was wondering what you'd advise if a user has experienced the same issue in multiple browsers, using various different files and a number of different tickets? Cache has been cleared, the user has logged in and out of JIRA...nothing basic seems to work.

And she didn't leave her machine for a while either...literally fired up a new browser, logged into JIRA, tried to attach a file...and got the same error.

Like # people like this
Like # people like this

Hi Nic , 

you are right that is a timeout err , just refresh the page and perform the operation .

it worked.

Like # people like this

Thanks Nic. That helps

After refreshing the page couple of times it works for me.

Like # people like this

I too had the same issue, while uploading some very small files (< 50kb). Tried multiple times and did not get uploaded initially.

Then, I simply refreshed the page and attached it again. Worked.

I had two tabs open to JIRA. All I had to do was refresh the given tab and there was no more token error. 

2 votes
AnnWorley Atlassian Team May 10, 2017

Could it be that people have Confluence open in another tab and and it's overwriting the JIRA cookie?

Logging into another Atlassian application logs me out of Confluence

I doubt the case, because I never run Confluence. None of them listed here work. Any resolution from Atlassian?

logout from jira and login again. That's Solution

No, that is not a solution, that is a workaround.

Like Jonathan_Oberländer likes this

..only if it would work! In this case it's an "it also doesn't work around"

I read the first answers above, and refreshed the tab after writing a long defect report—and lost the whole thing. 

I despise stupid problems like this, and they seem to be all over atlassian software. 

 

Sorry, just venting. 

1 vote
Deleted user Mar 12, 2019

Any new information on this? I just encountered it while testing JIRA 7.13. In my case, this was while trying to attach a file in the "Create Issue" screen. There's no way that I know of to "refresh" that dialog - so I completed the Create process and attached it later - but my users aren't going to like having a field for attaching documents for submission and seeing that error. It's just a wee bit off-putting.

+1
We've just started getting reports of this issue happening in Chrome on version 7.13.8. No Jira updates or changes to the network stack recently.

A tab refresh seems to allow the user to complete the current operation, but they're reporting that they're seeing the issue multiple times a day and having to refresh each time to get around it.

Interestingly, users are reporting that the issue seems to go away when they use Firefox.

Almost 4 years since the first response in this thread and it still hasn't been fixed. I am currently using Chrome Version 83.0.4103.116 and can't upload a file that is 758KB without the token error. Tried the wait, logout/login/refresh..... What will it take for this to be rectified. 

This happened to me today on Firefox (50.1.0).  Earlier today, I cleared my entire Firefox history/cache/cookies/etc.  My network is fine and the file is only 392k.

Just happened in Chrome as well...

Happening in Chrome even though "Block third-party cookies..." is disabled.

this is happening when login to JIRA from Confluence space shortcut link.

this is not due large file or session time out, this could be bug.

How is this an acceptable answer? "This could be a bug"?

Someone accepted a useless and wrong answer here, so people stopped paying attention.

Have a look at where Ann and I give useful answers.

For me too "Happening in Chrome even though "Block third-party cookies..." is disabled."

This is happening to me in Chrome.  Did anyone ever find an answer?

I'm encountering the same problem today on Chrome when I try to attach an image or excel file to a bug in jira. I am not running Confluence.

Well, I might as well add my voice that I can't attach a file in Chrome while using Jira 7.2.8 (no Confluence, no one overwriting my cookies, just plain broken)

BTW, works fine in Firefox.

Refresh worked for me here as well.

 

Logout from jira and login again.

Refresh the tab works !

For me, I changed the file format. I was trying to update a png, but when I updated a jpg of the same file it worked fine. 

Suffering this constantly, very disgusting. Any open bug about it? I cannot think about restaring sessions all the time

Refresh the browser page and retry attaching the attachement.

That works!

This can also occur if you are trying to drop an attachment on an issue that has an open comment.  Simply select Add to close the comment and the attachment should work.

0 votes

I also faced the same issue, I just refreshed the page on which I am trying to upload a file(excel) and re-uploaded the file and it worked for me.

Happens again and again.

For several independent users, on several independent circumstances.

Tried with Screenshot Copy-Paste, tried with "Add attachment"

Many users write a long detail, then the token expires in between and they can not do attachments anymore. If they'd refresh: all is lost and they have to start from scratch.

I do not want to write them an instruction document how to create a ticket, like "open a word file, add all information into the word file, then create a ticket and simply attach the word file.

 

Long Story short:

Yes, the Token may expire eventually. But: is there a way to lengthen the time of expiration? Is it Chrome (Browser) or JIRA (Atlassian) to "fix" that? Any suggestion of a workaround (despite to "refresh the browser from time to time")?

Why does it take two hours to write an issue?

Owen Wallis Atlassian Team Jan 28, 2021

Hi @Christian Sprenger,

The Jira team are looking into a solution where the token is refreshed on copying and pasting.

For now the workaround would either be to download the images you need off the original ticket and then insert them via file upload. Or refresh the source ticket before copying and pasting images over.

All the best

Owen 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

326 views 9 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you