Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,665
Community Members
 
Community Events
176
Community Groups

Webhooks not posting to Slack

We have mulitple webhooks we are using to post to various slack channels.  They were all working fine, then suddenly they all stopped working.  No admin change that i can see on our JIRA Server.  When i enable Debug/Trace logging for webhooks, the post is logged, but nothing is being sent to slack.

I also tried using modifying the URL and sending to requestb.in and still nothing.  I then setup the exact same webhook in our stage environment and it worked w/out any issues.  Is there any kind of known issue with WebHooks where they just stop firing?  I see at one point there was an issue that was fixed in 6.4 (which is the version we're running).

Anyway, I would love to know if anyone else has seen this, and if so if there is any kind of known workaround.  The ONLY log i get when i enable trace logging for the webhook, is that it shows up in the log.  But i don't see any WARNs/ERRORs etc...

Thanks!

3 answers

I have the same question. The webhook posting.But not sent out to third part server. Is there a possibility that the thread pool overflows for webhook? there is some warning in log catalina.out

2019-11-18 14:45:30,183 atlassian-scheduler-quartz1.clustered_Worker-1 WARN [atlassian.webhooks.plugin.WebHookPublisherImpl] Executor rejected the web hook 'PublishTask{listenerKey=com.atlassian.webhooks.api.register.listener.WebHookListener@a90de99, uri=...,body=...

...

rejected from java.util.concurrent.ThreadPoolExecutor@5eba9abe[Running, pool size = 3, active threads = 3, queued tasks = 100, completed tasks = 18]'

We have the exactly same issue, and failing to find any fix :(

Hi Jason,

This is not an answer to your question. Our company will be using SLACK very soon and our team is researching options for integrating JIRA with Slack. JIRA is installed on a server and 6.4 is the version we use.

Could you please give us some insight on how webhook can be used to establish the integration.

Typical use case would be to post updates on Issue operations in a Slack Channel.

 

Appreciate your time. Thank you.

 

-Pavan

Hey Pavan,

Slack provides Webhook integration with JIRA out of the box.  There are also a number of bots you can use to accomplish the same thing (in some cases with more functionality).  When you add the integration from slack, it will generate the URL for you to use for the Webhook.  You can add that to JIRA via System->Webhooks and supply the JQL Filter and update events.  

The out of the box integration is limited to transition events, which you define on the slack side.  What that means is, "issue updated" events will only notify slack if the update is a transition between statuses that you have defined in your Slack configuration for the webhook.

You'll also need a webhook for each channel you want to receive notification in, and you must be a JIRA admin to add the webhook on the JIRA side.  We setup a wiki page that uses behind the scenes admin auth so users could add their own Webhooks w/out being JIRA admins.

Hope this helps!

-Jason

 

Hello Jason,

 

Thank you very much for providing valuable inputs. It definitely helps!

 

-Pavan

Jason, 

Did you ever figure out what was going on? I am having the same problem and narrowed it down to something in the JQL on the webhook. We were querying on a status change and that seems to not be working anymore. 

-Heather

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events