Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Problem in integrating github repo and JIRA

I have correctly link my github account with JIRA in DVCS

The repos are correctly shown in the DVCS page.

But there is no automatic sync available for these repos, although I have made corrected setting in it.

When I link the repo with my JIRA project page. It keeps saying "

Linked but not integrated

Your repo is now linked, but your team can get visibility of development progress in their issues when GitHub and JIRA are integrated."


When try to sync with github repo "Failed to link XXX repo with JIRA" was kept showing.


What should I do to correct this problem?



3 answers

I am use Jira cloud.  For me it turned out to be a minor case difference in the url.   I fixed it by going to Administration(gear top right)->Applications->DVCS accounts

(IIRC, you can click the little ! icon and it will take you directly there, but you need to click cancel on the dialog that pops up)

I found the Repository in question and r-click->copy url

Then go back to your Jira project (Link in top right "Back to project: xxxx")

On the left hand pane under source code (where the ! icon is), mouse over the name and click the down arrow that appears, select edit.

Under Repo link, paste the URL.

(You could also try to figure out the differences manually, but this way you are sure to get an exact match).

Success for me, the icon went away!  YMMV.

Hope that helps!

worked for me! thank you so much. very frustrating process

Like Justin Lang likes this

tried everything! nothing works

Any idea how this issue got resolved. I have a repo that is not automatically syncing with Jira, despite having all the configurations right. We have been manually doing the sync and was wondering if there was a better way to automate this. 



You can connect Bitbucket or GitHub accounts with JIRA using the free JIRA DVCS Connector plugin. This plugin comes with JIRA OnDemand. For JIRA download users, this is a system plugin that you can install. Using the DVCS connector, you can:

  • Link all or a subset of your existing repositories (both public and private to JIRA).
  • Create new repositories and have them link automatically to JIRA.
  • Reference JIRA issues from DVCS commit message and have those commits appear in the issue's Commits tab in JIRA.
  • Transition issues through a JIRA OnDemand workflow (for example, Close, Reopen, and so forth) using smart commit messages.


I am now using JIRA cloud.

I guess it is JIRA software with JIRA DVCS connector integrated already.

But the integration is not working after I link my JIRA account to the github.

What further details do I need to provide in order to find out the solution for this?

I'm having the same issue. JIRA on the cloud... Github... linked.. but nothing syncs. 

I'm having this same issue - should I raise a ticket to have this sorted out?

We are having the same issue too

Same here, it keeps showing "Linked but not integrated" even after going over the authorize process.

I'm trying to link to a GitHub repro using Jira Cloud, and it doesn't show the DVCS accounts selection at all.  There's nothing to pick at all!

Same issue here. Any resolution information? 

I had the wrong Jira instance.  There's "Jira Core" and "Jira Software Cloud".  Both look identical except for one small difference (guess what?).  Jira Core doesn't have DVCS whereas Jira Software does.   Once I got this worked out the DVCS connection worked as advertised.  

Go to:

Administration (gear icon) > Billing > Manage Applications. 

That's where I found out I had Jira Core.   Good luck. 

I checked that and I have Jira Software and it is still not working. Thanks though, but still have the same issue. Does anyone know if it just does not work with private github repositories? 

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events