Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

On a PUT request I recieve a customfield cannot be set error

I use Postman to test a PUT request in my JIRA sandbox. 

My JSON body:

{    "update": {"customfield_15315": [{"set":"11111011112"}]}}

 but keep on getting the following response:

{    "errorMessages": [],    "errors": {        "customfield_15315": "Field 'customfield_15315' cannot be set. It is not on the appropriate screen, or unknown."    }}

 

I essentially just want to edit one field on the issue. I get this error on all the field, custom and standard.

I have admin rights and the field is visible the create/view/edit screens of this project.

This is my path rest/api/2/issue/464382 with no parameters set

1 answer

0 votes

@David van Staden


That syntax is correct. When you say it's visible, can you please confirm that if you try to create/edit an issue through the UI, you can actually see the field you want to populate?

Thanks,

Kian

Hi Kian,

Thanks for the reply.

 

I can see the field on my create & view screen.

What bothers me is if I run the following GET request https://jira.stage.eu-west-1.aws.clickatell.com/rest/api/2/issue/464382/editmeta

I only get this response: {    "fields": {}}

I was under the impression that the response should list all fields available.

When I run this GET request https://jira.stage.eu-west-1.aws.clickatell.com/rest/api/2/issue/464382/?

I get a response with all fields on that issue, even the fields that are not visible on the screen.

@Kian Stack Mumo Systems 

Any other ideas in regards to what I can look out for?

@David van Staden

That is odd, as that URL works for me if I want to look at the edit meta in my instance. Are you having problems with other API's, or just these ones?

Thanks,

Kian

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

Introducing External Collaboration for Confluence

We’re excited to introduce external collaboration for Confluence, now available in early access. It is available to preview for Confluence Cloud Premium and Enterprise customers. (If you're not on ...

214 views 0 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you