Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,494
Community Members
 
Community Events
168
Community Groups

Jira programatical clone is clonning Time Spent field value

Edited

If you try to clone an issue using *cloneIssueWithAllFields* is clonning the Time Spent cf, but not full worklogs

According to the inteface clone it should not copy any Time Tracking values

Example to reproduce the bug:

 

def task= issueManager.getIssueObject("FFS-1506")
def subtask = issueManager.getIssueObject("FFS-2851")
 
def toClone = issueFactory.cloneIssueWithAllFields(subtask)
Issue cloned = issueManager.createIssueObject(adminUser, toClone)
subTaskManager.createSubTaskIssueLink(task, cloned, adminUser)


The original Issue got  2h logged with my workLog

image.png

 

Cloned Issue got the 2h on Time Spent but not worklog

image.png

I tried to delete de workLog on the clonned issue using:

worklogManager.deleteWorklogsForIssue(cloned)

But it didnt work,

Do you know any way to reset that Spent Time value after the clone?

 

Thanks in advice

1 answer

1 accepted

0 votes
Answer accepted

There is a bug about this funcionality

https://jira.atlassian.com/browse/JRASERVER-60361

 

The way to solved it its adding the line toClone .setTimeSpent(null) just after use the  cloneIssueWithAllFields

def toClone = issueFactory.cloneIssueWithAllFields(subtask)
toClone .setTimeSpent(null); // <<<<<<<< CHANGE HERE >>>>>>>>

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events