Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,201
Community Members
 
Community Events
176
Community Groups

Jira doesn't start after HTTPS configuration

After configuring Jira to use SSL/HTTPS via server.xml, restarted Jira and it does not come up. Error in the catalina.out file.

JIRA-Bootstrap INFO [c.a.jira.startup.JiraStartupLogger] Running JIRA startup checks.
JIRA-Bootstrap FATAL [c.a.jira.startup.JiraStartupLogger] Startup check failed. JIRA will be locked.

Even though server.xml was rolled back i,e to HTTP only, Jira still cannot start and throwing same error as above.

If manual editing of server.xml might have caused this issue, so after roll-back tried via Jira config tool but still getting same issue.

Below is the tag manually added the first time.

<Connector SSLEnabled="true" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^&#x5c;&#x60;&quot;&lt;&gt;" acceptCount="100" clientAuth="false" connectionTimeout="20000" disableUploadTimeout="true" enableLookups="false" keyAlias="jira" keystoreFile="/opt/atlassian/jira/ssl/jira.jks" keystorePass="********" keystoreType="JKS" maxHttpHeaderSize="8192" maxSpareThreads="75" maxThreads="150" minSpareThreads="25" port="8443" protocol="org.apache.coyote.http11.Http11NioProtocol" scheme="https" secure="true" sslProtocol="TLS" useBodyEncodingForURI="true"/></Service>

 

Any insights in resolving this issue is very much appreciated.

2 answers

1 accepted

0 votes
Answer accepted

Issue was fixed.

Due to misconfiguration in the db url, jira was unable to connect to db.

0 votes

What does the rest of the errors say the problem is?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events