Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Jira Dashboard Gadget An internal server error occurred when requesting resource ; Stream closed


I have following error. When I try to add the 'Recently Created Chart' gadget to the dashboard, I receive the 'An internal server error occurred when requesting resource.' error message. The atlassian-jira.log prints following error (I masked the IP with

Additional information:

  • I have already tried to reindex the whole instance, but nothing changes.
  • Some other gadgets doesn't work neither (e.g. Workload Pi Chart).
  • Others work (Bubble Chart), so it's not a problem with gadgets or charts in general.
  • The filter is ok (it only points to a project) and I have tried several other filters and projects, too.
  • The gadgets are locale ones.
  • The system health check is completely green
  • It's a clients system, so I can't easily reboot Jira
2020-09-11 10:35:25,604 http-nio- ERROR admin 635x3985282x109 16d0xch, /rest/gadget/1.0/recentlyCreated/generate [c.a.p.r.c.error.jersey.ThrowableExceptionMapper] Uncaught exception thrown by REST service: Stream Stream closed    at sun.util.locale.provider.BreakIteratorProviderImpl.getBreakInstance(    at sun.util.locale.provider.BreakIteratorProviderImpl.getLineInstance(    at java.text.BreakIterator.createBreakInstance(    at java.text.BreakIterator.createBreakInstance(    at java.text.BreakIterator.getBreakInstance(    at java.text.BreakIterator.getLineInstance(    at java.text.BreakIterator.getLineInstance(    at org.jfree.text.TextUtilities.createTextBlock(    at org.jfree.chart.axis.CategoryAxis.createLabel(    at org.jfree.chart.axis.CategoryAxis.refreshTicks(    at org.jfree.chart.axis.CategoryAxis.reserveSpace(    at org.jfree.chart.plot.CategoryPlot.calculateDomainAxisSpace(    at org.jfree.chart.plot.CategoryPlot.calculateAxisSpace(    at org.jfree.chart.plot.CategoryPlot.draw(    at org.jfree.chart.JFreeChart.draw(    at org.jfree.chart.JFreeChart.createBufferedImage(    at org.jfree.chart.JFreeChart.createBufferedImage(    at com.atlassian.jira.charts.jfreechart.ChartHelper.createChartImageInline(    at com.atlassian.jira.charts.jfreechart.ChartHelper.generateInline(    at com.atlassian.jira.charts.RecentlyCreatedChart.generateChartInternal(    at com.atlassian.jira.charts.RecentlyCreatedChart.generateInlineChart(    at com.atlassian.jira.charts.DefaultChartFactory.generateRecentlyCreated(    ... 2 filtered    at java.lang.reflect.Method.invoke(    at com.atlassian.plugin.util.ContextClassLoaderSettingInvocationHandler.invoke(    at com.sun.proxy.$Proxy29.generateRecentlyCreated(Unknown Source)    ... 2 filtered    at java.lang.reflect.Method.invoke(    at    at    at    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(    at    at    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(    at org.eclipse.gemini.blueprint.service.util.internal.aop.ServiceTCCLInterceptor.invokeUnprivileged(    at org.eclipse.gemini.blueprint.service.util.internal.aop.ServiceTCCLInterceptor.invoke(    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(    at    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(    at    at    at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(    at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(    at com.sun.proxy.$Proxy3140.generateRecentlyCreated(Unknown Source)    at com.atlassian.jira.gadgets.system.RecentlyCreatedChartResource.generateChart(    ... 2 filtered    at java.lang.reflect.Method.invoke(    ... 19 filtered    at$JerseyOsgiServletContainer.doFilter(    ... 1 filtered    at    ... 36 filtered    at    ... 4 filtered    at    ... 3 filtered    at com.atlassian.diagnostics.internal.platform.monitor.http.HttpRequestMonitoringFilter.doFilter(    ... 8 filtered    at com.atlassian.web.servlet.plugin.request.RedirectInterceptingFilter.doFilter(    ... 61 filtered    at$doFilter$0(    ... 1 filtered    at    ... 16 filtered    at    ... 19 filtered    at com.atlassian.jira.servermetrics.CorrelationIdPopulatorFilter.doFilter(    ... 10 filtered    at com.atlassian.web.servlet.plugin.request.RedirectInterceptingFilter.doFilter(    ... 4 filtered    at com.atlassian.web.servlet.plugin.LocationCleanerFilter.doFilter(    ... 7 filtered    at net.bull.javamelody.MonitoringFilter.doFilter(    at net.bull.javamelody.MonitoringFilter.doFilter(    at net.bull.javamelody.PluginMonitoringFilter.doFilter(    at net.bull.javamelody.JiraMonitoringFilter.doFilter(    ... 22 filtered    at com.atlassian.jira.servermetrics.MetricsCollectorFilter.doFilter(    ... 25 filtered    at java.util.concurrent.ThreadPoolExecutor.runWorker(    at java.util.concurrent.ThreadPoolExecutor$    at org.apache.tomcat.util.threads.TaskThread$    at by: Stream closed    at    at    at    at    at    at sun.util.locale.provider.RuleBasedBreakIterator.readTables(    at sun.util.locale.provider.RuleBasedBreakIterator.<init>(    at sun.util.locale.provider.BreakIteratorProviderImpl.getBreakInstance(    ... 307 more


1 answer

1 accepted

Update: 05.10.2020: A restart of Jira solved the problem.


tl;dr: The Atlassian support think that this error is because of an issue with Java. So rebooting Jira should/could resolve the issue. I haven't verified this solution yet.


I opened a ticket for this question at the Atlassian support and received the following answer. Keep in mind that until now I wasn't able to prove if the solution works:


Hello Nico

 Thank you for contacting Atlassian support. This is **** and I will be glad to assist you further. As per your above query, I understand that when you are trying to create gadgets you are getting the below error:"

2020-09-16 10:00:50,876 http-nio- ERROR admin 600x4105728x109 w9wstd, /rest/gadget/1.0/recentlyCreated/generate [c.a.p.r.c.error.jersey.ThrowableExceptionMapper] Uncaught exception thrown by REST service: Stream closedjava.lang.InternalError: Stream closed        at sun.util.locale.provider.BreakIteratorProviderImpl.getBreakInstance(        at sun.util.locale.provider.BreakIteratorProviderImpl.getLineInstance(        at java.text.BreakIterator.createBreakInstance(        at java.text.BreakIterator.createBreakInstance(        at java.text.BreakIterator.getBreakInstance(        at java.text.BreakIterator.getLineInstance(        at java.text.BreakIterator.getLineInstance(        at org.jfree.text.TextUtilities.createTextBlock(        at org.jfree.chart.axis.CategoryAxis.createLabel(        at org.jfree.chart.axis.CategoryAxis.refreshTicks(        at org.jfree.chart.axis.CategoryAxis.reserveSpace(        at org.jfree.chart.plot.CategoryPlot.calculateDomainAxisSpace(        at org.jfree.chart.plot.CategoryPlot.calculateAxisSpace(        at org.jfree.chart.plot.CategoryPlot.draw(

It could be related to the JDK issue, as we have seen in the past the error " Stream closed" being related to JDK issues. I have also done some case studies and see some examples of cases that were experienced by different users.

Restarting the Jira server seems to fix this issue. Could you please restart the Jira server and let me know how it goes.

Also, if the issue persists, we will need a HAR File while reproducing the issue, and a complete support zip once again.

I hope this helps !!

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events