Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,372
Community Members
 
Community Events
176
Community Groups

Jira CLI RunFromCsv won't recognize board parameter

Edited

I have a script that I run periodically to load new sprints in bulk. Recently the parameter names have changed, and I've updated them, but now runFromCsv just doesn't recognize the board parameter (formerly id). When I use the same board parameter in a createSprint action without runFromCsv it works fine.

What is wrong with "board"?


command:

acli -a runFromCsv --file "working.csv" --common "-a createSprint" --continue

csv format:

board,name
72,Team 1 - 22.2.1
70,Team 2 - 22.2.1

sample output:


Run: --name "Team 1 - 22.2.1" -a createSprint
Parameter error: This function requires a non-blank value for parameter board.
 

I tried a different command and reordered the columns, same error:

acli -a runFromCsv --common "-a addQuickFilter" --file "test.csv" --continue

csv:

filter,board,jql
test2,487,type=Bug
test3,487,type=Sub-task

 output:

Run: --filter "test2" --jql "type=Bug" -a addQuickFilter
Parameter error: This function requires a non-blank value for parameter board.

 

2 answers

1 accepted

After working with Appfire suport:

The problem was in my acli.properties file. (I think this is something that changed in an update, because it used to work.) Editing boards is now an "agile" feature, not a "jira" feature. I have it set up to do environment switching, so I added a new "environment" where I call agile instead of jira.


Instead of calling

prod = jira -s https://jira.myinstance.com ${credentials.prod}

it needed to call

agile_prod = agile -s https://jira.myinstance.com ${credentials.prod}

 

Hi @Jennifer D. Smith

Thanks for reaching out!

We have created a support ticket https://bobswift.atlassian.net/servicedesk/customer/portal/1/SUPPORT-10113 in our portal for this issue. Request you to signup to the portal and let us know the username so that we can mark you as the reporter so that you will be able to access the ticket.

Please find the below link to signup to the portal: https://bobswift.atlassian.net/servicedesk/customer/portals/1

Looking forward to hearing from you!

Thanks,
Naveen

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events