Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,256,600
Community Members
 
Community Events
164
Community Groups

Jira 8.22.2 | HTTP 503 & Plugin Failure Errors

Edited

Hi. I have just installed a new fresh copy of Jira 8.22.2 and after installing, I can load up Jira in my browser and click on "I'll set up myself". However, after using the built-in H2 database option to quickly test everything, Jira gets stuck on "Please wait while the database is setup..." and I cannot do anything. Refreshing the page leads to a HTTP 503 error (indicating to me that the service has completely failed).

After about 10 minutes, it comes back however and says that all the plugins have failed to start (as seen below).

 


System plugins failed to start: We haven't been able to start all the required system plugins

We couldn't start the following plugins:

  • Jira Projects Plugin (com.atlassian.jira.jira-projects-plugin)
  • Atlassian Navigation Links Plugin (com.atlassian.plugins.atlassian-nav-links-plugin)
  • Atlassian Jira - Plugins - Project Config Plugin (com.atlassian.jira.jira-project-config-plugin)
  • Applinks - Plugin - Core (com.atlassian.applinks.applinks-plugin)
  • Embedded Gadgets Plugin (com.atlassian.gadgets.embedded)
  • Gadget Directory Plugin (com.atlassian.gadgets.directory)
  • Atlassian Jira - Plugins - Gadgets Plugin (com.atlassian.jira.gadgets)
  • Atlassian Jira - Plugins - Global Issue Navigator (com.atlassian.jira.jira-issue-nav-plugin)
  • Atlassian JIRA - Plugins - Quick Edit Plugin (com.atlassian.jira.jira-quick-edit-plugin)
  • Atlassian REST - Module Types (com.atlassian.plugins.rest.atlassian-rest-module)
  • Atlassian Jira - Plugins - REST Plugin (com.atlassian.jira.rest)
  • Opensocial Plugin (com.atlassian.gadgets.opensocial)
  • Gadget Dashboard Plugin (com.atlassian.gadgets.dashboard)

 

When stopping the Windows service, waiting for it to shutdown and then restarting Jira again, it takes another 10 minutes trying to startup where I'm stuck on this loading page for that time.

startup.png

Eventually it then shows the failed plugin screen again (same info in the list above).

I have tried deleting .bundled-plugins and .osgi-plugins as other users have mentioned the plugins can become corrupted (even though this is literally a fresh installation) but the same issue persists.

I have restarted my Windows Server and I am running the latest updates from Microsoft. The server is Windows Server 2019. Windows Defender is disabled and I have the Atlassian directory from Program Files added as an exclusion.

I am very lost as per what's going on. I of course have the logs but they are extremely confusing and I have no idea what is going on. Any help at all would be greatly appreciated as I have been at this for nearly 13 hours now and it's driving me nuts.

The logs can be downloaded from here Jira Logs (right click -> 'Save As').

More information:

  • Windows Server 2019 (latest build and updates as of 14/MAY/2022).
  • My server has 48 GB of RAM.
  • The server is running SSD's.
  • I have set the Jira Initial Memory Pool to 512 (MB).
  • I have set the Jira Maximum Memory Pool to 4096 (MB).
  • My permissions all seem to be correct.
  • As priorly mentioned, I have no anti-virus running.

Jira was working fine on my system and I had 8.15.0 working perfectly fine without any issues. As mentioned, I uninstalled that and started with a fresh copy of 8.22.2 so this is very, very strange because everything is clean and new. It should work and fire right up without any issues.

Here is someone who has a very, very similar issue to me as well with no resolution: https://stackoverflow.com/questions/70441672/problem-installing-jira-for-the-first-time-via-zip

I should mention I have also tried versions 8.22.0, 8.21.1 and 8.20.8 and they all behaved the same.

Thanks.

3 answers

1 accepted

1 vote
Answer accepted

Workaround

Use Java 8.

Delete "atlassian-authentication-plugin-4.2.6-fork-1.1.0.jar" from "../WEB-INF/atlassian-bundled-plugins/".

Bug reported to Atlassian from ticket PSSRV-40683 for further review
https://jira.atlassian.com/browse/MIG-740

0 votes

Hi @Matt ,

welcome to the Atlassian community!

Try to review RAM for your JIRA instance (https://confluence.atlassian.com/adminjiraserver/increasing-jira-application-memory-938847654.html) and try again.

Hope this helps,

Fabio

As mentioned, I don't believe it's a RAM issue as I already expanded it from the default Atlassian values. Are you suggesting I expand it even more?

Maybe something like:

  • Initial Memory Pool 4096 MB
  • Maximum Memory Pool 8192 MB

 

UPDATE

I tried making the memory sizes IMP 4096 and MMP 8193 but it still failed. I even tried IMP 8192 and MMP 12288 (which is 12 GB) and it still failed to load the plugins.

I also tried deleting the 4 folders in the plugin directory (as mentioned in my initial post) to reset any potential corruption from the previous launch and tried adding 

-Datlassian.plugins.enable.wait=300

to the service start-up but that didn't help either. I am still getting a large list of plugin errors when launching a fresh install of Jira 8.22.2.

plugin_errors.png

Try to clean plugin cache :

  • Shut down JIRA.
  • Delete the following hidden plugin cache directories: JIRA_HOME/plugins/.bundled-plugins JIRA_HOME/plugins/.osgi-plugins.
  • Restart JIRA (These directories will be recreated on JIRA reboot with new plugin cache)

As mentioned twice, that is not the issue.

I am now trying to change Java versions from the built-in version included with 8.22.2 to "Java SE Development Kit 8u202" (64-bit) which I have manually installed.

https://jira.atlassian.com/browse/JRASERVER-73257

Small update. I uninstalled everything and tried installing 15.0 again. That also produced a 503 error when making a new H2 database as a test. However, after about 2 minutes the system came back and I was able to continue with the Jira setup. No plugin errors or anything, so I believe the newer versions of Jira are in fact broken.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

#JiraHeroes May '22 Spotlight: Daniel Cave

At Atlassian, we take great pride in the software we ship, and even greater pride in the success our customers achieve when they use our products. #JiraHeroes is our new monthly spotlight series&nbsp...

789 views 0 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you