Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,361,330
Community Members
 
Community Events
168
Community Groups

JIRA project doesn't exist or you don't have permission to view it when reordering issues

I insert a JIRA filter list view and can see all the issues. 

However if I click on one of the column headers to re-order the data I get the above error message.

JIRA project doesn't exist or you don't have permission to view it.

Does anyone know why this is happening and how I can solve this?

3 answers

1 accepted

1 vote
Answer accepted

Hi Ellen,

Are you facing this issue on a filter in Jira or using a Jira filter on Confluence?
Would it be possible to send us a screenshot showing where this error is appearing?

Regards,
Angélica

Seems to be solved now. Thanks!

Like Angélica Luz likes this

Hi, please provide also a solution. It would be very helpful for other people who encounter the same problem.

Thank you.

Like Marcelo Lopez likes this

Hi, Same issue here. For me it happens while using the jira filter on Confluence.

I tried filtering on one project only (I can create tasks on this project in jira)

I'm interested in a solution too :)

Best,

Laurie

Hi Laurie,

Can you please confirm with the administrator if you have access to see all the tickets in the project? Maybe the project has Issue security and the tickets are not available for everyone to see.
Also, I would like to confirm if the message is happening when you try to filter one of the columns. I found a bug but it only happens when trying to filter by Organization:
- https://jira.atlassian.com/browse/CONFCLOUD-65463
If it's not this bug, can you please let us know all the steps you are following until the message appears?

Regards,
Angélica

Hi @Angélica Luz

Thanks for answering :)

The error message appears only when I try to sort by clicking a column (any column). So I guess it's the same as https://jira.atlassian.com/browse/CONFCLOUD-65463.

Like Ellen I inserted a filter list view, and it seems to work (see my 1st screenshot), but if I try to sort the issue I get the error message in my second screenshot.

So is it the known bug you mentionned or is it worth that I ask my administrator? I'm not sure there can be an access issue if I can see the tickets (displaying the list works fine) and not sort it.

Regards,

Laurie

Hi Laurie, I just tested and confirmed that the bug only happens when filtering the column "Organization", it should not happen when filtering, for example, reporter, created or summary.
If you click on "View these issues in Jira" and you are able to see all the tickets, we can confirm that is not related to permission.
Have you tried to create a new page and add the filter to test?
Is there any other user with the same level of access that you have, facing this issue?

Hi  @Angélica Luz ,

I confirm clicking on "view these issues in Jira" works properly :

 

Also, I don't have the "Organization" field in my list :I also confirm that users use the same profile type encounter the same issue.

I tried inserting the same filter on the different page. Same result : I can see the issues list but when I click on a column to sort I get the error message.

Regards,

Laurie

Laurie, we tried to replicate this issue on two different instances but we couldn't replicate.
We will need to further investigate what is happening, so I created a ticket with our support. so if you allow, they can access the instance and check the details in order to find what is causing this.
You should have received an email and soon someone will contact you.
Once the ticket is resolved, feel free to share the resolution here to help other community members that may face the same issue.
Hope you have a great weekend!

Why is this the accepted answer? Issue is not resolved

Like DKK98 likes this

I have the same bug appearing, and this is not a solution.  angelica is there anything we can do?

Hey all.

Not sure if this is the same issue that you're all experiencing but it might be... sounds at least similar... so here are my findings:

My problem:

I took an old project in JIRA that needed a do-over, renamed it, gave it a new key and also created a new filter that I based my project on. Then I went to the board I created and I saw all the tasks, but I had this notification on the bottom of the board. So far so good.

JIRA project not found.png

My colleagues then tried to open the board and couldn't see anything other than this warning:

Alt text:
board not accessible.
It seems this board doesn't have an assigned location. You can ask your board administrator to assing it to a project or user.

JIRA board not accessible.png

Then I found this thread here and saw that filters might play a role to be able to view the board - most likely because the board is based on the filters. So I looked at my newly created filter for the already previously existing board. In the filter I had only changed the project key, but in the end it was a completely new filter that I used. And I had not given any permissions for it to anyone. 

So I went into my filter, I gave the whole organization permission to see the filter (but could probably also be done on an individual level) and everybody was able to see the board.

JIRA filter permission.png

Referring to this ticket https://jira.atlassian.com/browse/CONFCLOUD-53559

I was able to resolve this by removing the order by clause in the JQL.

FYI this worked on a data center instance so it probably isn't just cloud related.

 

This will not be an acceptable solution if sorting by is important to the content you want to display.

Thank you for this. this is the solution that I was looking for.

This was the solution in my case as well, thank you. 

It looks like the bug has to do with ordered fields that consist of more than one word.  You can get around this by referencing the field ID instead of the name, like this:

 

ORDER BY cf[11800] ASC

 

You can find the field ID by browsing to the custom field in Jira admin settings, click the cog icon, choose "configure", then look for the string of numbers at the end of the URL on the configure page. 

Like Greg Johnson likes this

Still doesn't work....I'm using 2 sorting orders..

 

statuscategory DESC, cf[10014] asc

 

and when I apply that JQL in the JQL macro, I still the error mentioned in OP above.

Hi,

I am facing the same issue.

However I noticed that it seems to be related to the language of the header.

By defaut it is set as English while the content of the ticket is in another language (FR) for me.

For some reason (that I can't replicate), the headers switch to French and suddenly I could sort with no issue. Unfortunately, after refreshing it switched back to EN and it doesn't work anymore...

Could you maybe try to fix this?

Thanks!

Lucas

Fix found... Simply change confluence default language to match Jira's. 

Suddenly all works fine.

How does that happen?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

Online AMA this week: Your project management questions answered by Jira Design Lead James Rotanson

We know that great teams require amazing project management chops. It's no surprise that great teams who use Jira have strong project managers, effective workflows, and secrets that bring planning ...

207 views 1 6
Read article

Atlassian Community Events