Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


I can't enable the Jira cloud migration plugin

I can't enable the Jira cloud migration plugin. In the log, it prints an error like this:

ClassNotFoundException: com.atlassian.servicedesk.api.ServiceDesk not found by com.atlassian.jira.migration.jira-migration-plugin

It seems like some Jira Service Desk component is missing.

We're using Atlassian Jira Project Management Software (v8.5.7). We are not using Jira Service Desk or anything related to it.

How can I manage to enable the Jira cloud migration plugin?

4 answers

0 votes
Filipi Lima
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Jun 02, 2023

I've seen this happen a couple times with our customer where they have an incompatible version of Jira Service Management (formerly Jira Service Desk) or even they have the compatible version but they still have the old one on <installed_plugins>.

  1. On Jira, go to Administration (⚙ icon) > Applications > Versions & licenses.
  2. See if your versions are compatible. You can see compatible version here, too:
  3. If you do not have the compatible version you may find the correct version here:
  4. Click on "Upload an application", then provide the following URL for Jira Service Management version that is compatible.
  5. Click on "Upload". It can take a few minutes to upload and install the new version of this app.
  6. After this process finishes, please go to Administration (⚙ icon) > Manage apps, then click on "Manage apps" again in the left menu.
  7. Find the Cloud Migration Assistant app and try enabling it again.
  8. If it still fails to enable, you may need to restart your instance (rolling restart will do on Data Center) so you get a clean start.

For what it is worth, I managed to enable the plugin.

I removed the .jar files of Jira servicedesk plugins that failed to start. You can find that information in the logs.

First I stopped Jira, then removed the respective .jar files and after starting Jira again the Jira cloud migration plugin was enabled.

I am facing the same issue with the same error. Tried re-installing the plugin as well to no avail. (Jira Server v8.13.13, Jira Cloud Migration Assistant v1.6.8)

0 votes
Kristin Lyons
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Jan 28, 2022

Is the migration plugin up to date? If so have you tried to uninstall it and re-install it?

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events