Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,461,674
Community Members
 
Community Events
176
Community Groups

How to search for a string in X-Ray test steps?

Edited

My team needs to find all X-ray tests that have a specific string in a test step. What is the JQL to search for that?

A simple "type = test and text ~ blah" returns nothing.

2 answers

Check the end of this link: https://docs.getxray.app/display/XRAY/Enhanced+querying+with+JQL


issuetype = 'Test' and "Manual Test Steps" ~ "Login with user administrator"

 

Works best in "Flat View". Just replace the text "Login with user administrator".

Hi Michael, we have tried but it does not work for us.

image.png
FYI I'm administrator and we have also tried with other administrator accounts.
I assume Flat view refer to List view?
Any other suggestions?

Hi Yvonne,

You don't need to have an administrator account to search.

I just went under the "Xray Test Repository" from the menu on the left in Jira, selected the folder I wanted to search under, then clicked "Filter" top right, then "ADVANCED", then entered my JQL Search query:

issuetype = 'Test' and "Manual Test Steps" ~ "<Text to search for>"

I click Apply and to search all child folders rather than just the selected one, I clicked "Switch to Flat View" top right. After clicking the text changes to "Switch to Folders View". In Flat View though I can see all the results in all the sub-folders too.

It could be though that this field is a custom field (although I doubt it as it's listed in the documentation I linked to above) or the field has a slightly different name or is in a different language if you're not using English. Try deleting the text "Manual Test Steps" and then a list of available fields will appear - have a look through the list for something similar.

Works with: image.png

Thanks ;-) 

Jeff, did you ever find a solution?

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events