Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to hide Epics from Kanban view?

I switched from Scrum to Kanban view and already had some Epics. They're now displayed in the To-Do lane as moveable blocks and don't want Epics to be displayed on the board. The stories are already displaying in which Epic they are by the displayed label and I want to keep that.

How do I hide those Epics from being on my Kanban board?

8 answers

What you're looking for is the type field in JQL

To filter out epics: 

project = PROJECTNAME AND type != Epic ORDER BY Rank ASC 

You can enable the Epics panel in your board configuration. This will allow the epics to be displayed, but not as a card (ticket) on the board.

And in order for this option to show up, you need to enable the Kanban backlog, and this is done by moving a status to the backlog (in the example below, I added "Requirements needed" to the backlog, since I don't need to show those tickets in the board.

 

Screen Shot 2020-08-21 at 2.32.42 PM.png

This option, for some reason is not available for our instance of JIRA. Is this something that has to be enabled somewhere else?

Erick, I was unable to see the option as well. I took an item from the Backlog column and dragged it into the Kanban Backlog. When I did this the button for "Epics Panel" became enabled.

I found the directions here: https://support.atlassian.com/jira-software-cloud/docs/configure-columns/#Enabling-the-Kanban-backlog

The problem of using the Filter (!=Epic) is when you need to base the Swimlanes on Epics, .....

no information ......

When i do this by changing the filter , i am not able to see the epics in the backlog too , is there a way to find them

me too! were you able to find a workaround for this @Niranjan ?

No - I believe the backlog you are looking at is viewed through the same filter as your board. If you filter out epics in the board, you filter them out of the backlog too.

To the best of my knowledge you need to amend the filter, or create a separate board.

But I note in our Jira Cloud account, in Board Settings >> Columns there is a toggle as follows:

 

Epics panel

Display epics in a panel in the backlog, and not as cards on the board

 

So a way to handle this is don't filter out epics from your board, and then do enable that toggle so your epics are in your sidebar rather than listed in your backlog.

Is this toggle a feature on a specific version of Jira Cloud? 

But like this i still need the filter for the Kanban view right? 

You can always create a quick filter which basically adds a button to the Kanban view:

  • Go to board settings
  • Go to quick filter
  • In the 'add' row do the following
    • Name the Filter Name
    • Add 'type != Epic' to the JQL field
    • Add a description
    • Add the filter

This should add a button the board like so:

Screenshot 2021-04-26 155455.jpg

This is a good work around to hide Epic on Kanban but have them still viewable in the backlog. Thanks @ALEX DUTHIE 

You can modify the board's filter to exclude Epics. What appears on the board is determined by the filter.

Could you be more specific where to find that filter or steps to apply that filter?

When you go to Boards / Configure, under the General tab, you'll see the filter. Changing and editing the filter is all covered in the doc: https://confluence.atlassian.com/agile/jira-agile-user-s-guide/configuring-a-board/configuring-filters

Great! That's all I wanted to do.

Thx it's been bothering me for a while and this fixed it.

Here is the JQL filter I used

project = <my project> AND ((issuetype = Epic AND status != Done) OR (issuetype != Epic)) ORDER BY Rank ASC

Had this same problem. Edit filter for board and add issuetype != Epic :) 

You should be able to turn on Epic Panel switch on Board Settings / Columns, that will not only enable Epic Panel on side of Backlog but hide Epics at all on Board view.

 

Screen Shot 2020-05-25 at 10.18.00 AM.png

Hmm... there is no such switch in my JIRA Cloud? Maybe part of a beta programme?

Like Nick Heath likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

☕️ Monday coffee with Jexo: Weekly Atlassian news roundup | 21st June 2021

Hi community 👋, as every Monday we're bringing you a quick update on what happened in the Atlassian ecosystem last week. There were a few interesting events like for example the announcement of th...

55 views 0 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you