Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How can I solve this error : "Unknown function: 'JIRA'. "

Google Sheets Jira adds-on started to give errors today, with the error code "Unknown function: 'JIRA'." Normally, it was working properly but today it gave this error and is fixed after an hour. Right now, it gives the same error, could you help me to find a solution for this ?

6 answers

1 accepted

0 votes
Answer accepted
Fadoua Community Leader Oct 15, 2019

@Ali Basar Demir 

I see that you are a Cloud User, it could be that Atlassian was performing some tests or making changes. Or it could be a glitch happened in Jira.

You mentioned that it resolved by itself but started again. If by tomorrow it is not fixed I can share the link with you so that you can open a support ticket with Atlassian.

Best,

Fadoua

@Fadoua 

It is fixed today, thank you so much for your support :)

Best,

Ali

Like Fadoua likes this
Fadoua Community Leader Oct 16, 2019

@Ali Basar Demir Thank you for accepting my answer! Glad it is working fine today.

Please don't hesitate to reach out if it starts acting up again 🙂

Best,

Fadoua

This is a recurring problem.

In my case, it happens sometimes when I make a copy of a spreadsheet that uses JIRA plugin.

When I make a copy and then activate the plugin for the new copy, sometimes it doesn't recognise the JIRA function. 

I've tried to refresh, rewrite the function in the cell, closing and reopening the spreadsheet and nothing works. I had to delete the spreadsheet, make a new copy and pray so the new copy doesn't have the same problem, because it only happens sometimes.

 

Best, 

Alberto.

@Alberto García Ramos

Are you a Cloud or Server User? 

If server what do you see or your Jira Admin sees on the Application log? Can you please copy and paste the line with the error after hiding any confidential information?

Best,

Fadoua

Getting same problem as reported by Alberto here. I'm using the Cloud version. I tried to refresh many time and it does not work.

Unknown function JIRA.png

I checked on the console, and there is a recurrent warning. More lines appear when clicking in enter button when the cursor is in that cell.

empty string unknown function JIRA.png

I created a new Excel file from a previous one and this time I activated first the JIRA function (before modify anything) and everything works smoothly. In the previous one, firstly I modified the file and then activated the JIRA function, and even clearing the cell and writing it back it didn't work anymore. @Fadoua I hope it would help to solve the problem.

Hi @Fadoua, sorry for the delay.

I'm working with the cloud version. 

 

Thank you!

@Carmen Rosa Ussi  Did you check the google sheets add-on page to see if there are any known issues?

I promise to spend some time either today or tomorrow to get more information about your issue guys.

Same goes with you @Alberto García Ramos

I will get back to both of you.

Best,

Fadoua

Like Carmen Rosa Ussi likes this

Hello. I'm having the same issue, but I am just now starting to learn how to use JQL in my Google Sheet. Everything is hooked up, but the =JIRA command isn't working. I used the "Refresh Data" and it detected it, but Google Sheets still rejects it.

 

Will keep trying.

Like KP likes this

Remember to enable JIRA function.

enabled.PNG

This helped in my case:

  1. delete all JIRA functions from the current file. Deleted "=" at the beginning of the formulas
  2. File > Make a Copy
  3. Go to Jira Addon and > Get issues from Jira > Import type = Jira()
  4. Enable Jira function via add-on
  5. Restore my Jira() function in the sheet, from step 1.

You must be the document owner to enable the =JIRA function.

Having edit permission does not work.

Thanks for your answers, I have to copy the sheet and become the owner to get this working.

@Alberto García Ramos @Carmen Rosa Ussi  I'm seeing the same issue when copying a Sheet (Jira Cloud). Have you found a workaround? I do not see the error when creating a "new" Sheet and using Jira function(). I get the error only when I copy a Sheet, clear function, enable function, then re-add function..still get error.

Hi @Phil_Parker , 

Yes, the workaround is just deleting your copy, making another copy of the spreadsheet and hoping it doesn't fail. The error usually doesn't show up if you don't modify the name of the copy of the spreadsheet until you have refreshed the Jira() function.

Since I posted the comment about the problem, there has been an update in the plugin, but the issue is still happening.

 

I hope this helps.

Like Max Makhrov likes this

Hello

The add-on tab works, with JQL issues. But I still got the Error: Unknown function: 'JIRA' as a cloud user. And I would like to use this method.

1) I am the owner of the Sheets file.

2) It is inside one of ours shared drives in our organization.

3) And it is a must use, so I can not copy, move etc it.

4) I am an admin on our JIRA instance.

 

Thanks for your thoughts

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase

The benefits of using Jira in different departments

Jira is a great tool to use across different departments. Forget that paperwork – switch to Jira and get that tasks done smoothly. Marketing Jira allows for a complete digital transformation of you...

132 views 0 8
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you