Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,281
Community Members
 
Community Events
177
Community Groups

Get active sprint in automation

Edited

Hi,

 

I want to get the name of the active sprint of an issue because with this name I'm changing a custom field in this issue.

 

In the beginning, I tried 

{{issue.Sprint.last.name}}

But then I found out that the active sprint (the last sprint that the issue was added to) is not the last in the list, nor the first, I've already seen active sprint as first in the list, last, and middle.

 

so I tried something like this:

{{#issue.sprint}}{{#=}}IF({{isClosed}},,{{name}}){{/}}{{/}}

 so I will get only the name of an active sprint. but for some reason, math expression does not work inside a list iteration.

I tried to run the expression outside of the iteration and it worked:

 {{#=}}IF({{issue.sprint.last.isClosed}},,{{name}}){{/}}

and I tried to run a simple expression inside the iteration:

 {{#issue.sprint}}{{#increment}}4{{/}}{{/}}

 and it didn't work as well. (the log was empty)

 

And I could not find any suitable solution with JQL, I looked at openSprint()/closedSprint() but this does not help me, those functions says if the issue is inside an active sprint or, but does not says which sprint

 

small note:

this automation is triggered on sprint changed, that's mean every time an issue is added to a sprint, but I could not find how to get the new sprint variable, only a list of all sprints

 

 

 

edit:

I've put it in jira core by mistake, I think it needs to be in jira/jria software

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events