Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,572
Community Members
 
Community Events
168
Community Groups

Cannot install jira 8.20.1 on mysql 8.0.26

Hello, I working on to install Jira 8.20.1 and Mysql 8.0.26 but I have always the same error:

You have specified a database that is not empty, please specify an empty database. If you want to upgrade an existing installation, please follow these instructions instead.

I have make an new empty database but constants the same error what do I wrong?

3 answers

1 vote
Dirk Ronsmans Community Leader Dec 02, 2021

Did you maybe after the upgrade copy over your dbconfig.xml ? It looks like your config file is pointing to a previously created db.

Have you checked the DB you are pointing to to see if it really is empty?

No this is a new installation

Dirk Ronsmans Community Leader Dec 02, 2021

On a new installation you should be able to point it to the correct DB during the initialization. 

I assume that is where you get the error? 

Are you sure you are point to the correct DB then? I'd say just verify the DB you are trying to connect to first..

Since it says it's not empty it can connect..

The Mysql server is on the same Linux server as Jira is installed.

Dirk Ronsmans Community Leader Dec 02, 2021

Well only thing I can suggest is to really use something like a Mysql workbench and truely check if any tables exist already. 

If so, drop them.

I have in mysql : drop database jiradb; and then I create database jiradb.

CREATE DATABASE jiradb CHARACTER SET utf8mb4 COLLATE utf8mb4_bin;

 

GRANT SELECT,INSERT,UPDATE,DELETE,CREATE,DROP,REFERENCES,ALTER,INDEX on <JIRADB>.* TO '<USERNAME>'@'<JIRA_SERVER_HOSTNAME>';

mysql> show databases;
+--------------------+
| Database |
+--------------------+
| information_schema |
| jiradb |
| mysql |
| performance_schema |
| sys |
+--------------------+
5 rows in set (0.00 sec)

mysql> use jiradb;
Database changed
mysql> show tables;
Empty set (0.00 sec)

mysql>

Is there progress on this?

Dirk Ronsmans Community Leader Dec 03, 2021

Not really sure what this could be since you don't have any tables.

I'd say open a ticket with Atlassian directly (https://support.atlassian.com/contact) and see if this is a known bug?

When I set the credentials for the database and click op "Test Connection" then...

Oh, I have copyed the mysql-connector-java-8.0.26.jar driver to /opt/atlassian/jira/lib/

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events