Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Cannot edit users in the Jira Internal Directory after a system import

I'm working on a migration where I am using exported data from Jira Cloud (generated for server) to restore a Jira server instance. I then enabled the recovery_admin to be able to edit the users despite not having a login in any of the migrated user accounts. 


The only problem is I can't edit the Jira Internal Directory at all. I cannot add users. I cannot edit existing users. It's behaving like a read-only directory, but I don't understand how that can be the case. In performing the restore Jira had no issue writing the users into the database in the first place. Just in case, I updated the jdbc driver as suggested in similar articles, but with no luck. The FS permissions were verified to be owned by the user that runs the application. The dbconfig.xml has the correct schema for the database. I have never seen this issue before and cannot find anything about it online either.

2 answers

1 accepted

Actually, I found the root cause and was able to resolve this issue for me. The table "cwd_directory_operation" was blank after Cloud import. I've added the needed entries and now I can create/update users and groups. This KB article helped a lot: 

that one is for confluence, but Jira has the same table. I only needed to add the entries listed here:


Jira needs to be restarted and it worked afterwards.

Like Karl Todd Jr likes this

Good find! This worked perfectly for me.

Had the same issue as you describe there and also searching for a solution. Have you found any in the mean time, @Karl Todd Jr?

I ended up working around the issue, which I do not recommend.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events