Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,430
Community Members
 
Community Events
176
Community Groups

Bug report: import from Trello into JIRA Core: Cannot persist a workflow where mapping of project co

I want to import my Trello dashboards in my new Jira Core (cloud). This was working fine when I had the JIRA software installed as product. A new board was created with my cards.

Now I dropped JIRA software, so I only have Jire Core/Business.

When I import one Trello board as admin, I get this error message

Cannot persist a workflow where mapping of project configurations is inconsistent. See logs for more details.

The list of users to import is empty. Funny, as my user in Trello and JIRA is the same, the same Atlassian account.

I am stuck in this step. Of course, as this is Cloud, I have no access to the log files. That's stupid. I gave access from Trello to JIRA.

Thanks for any help.

Didier.

 

trello.png

1 answer

0 votes

Hello @Didier Debbaut,

Welcome to Atlassian Community!

Searching for similar cases related to this error, the most common cause for is that the statuses are different in Trello and Jira. So, for example, if a status is called "Finished" in Trello and in Jira is "Done", the import will fail.

With this said, make sure the statuses of each column in Trello and Jira are exactly the same and then, import it again.

Please, take your time to test and let us know if you face any other issues.

Kind regards,
Angélica

Hi,

Thanks for answering.

Now I am lost. When importing, a new project will be created right in JIRA Core with it's own workflow right?

I expect that the import would create the statuses as used by Trello, or that the tool asks me what mapping I would like to do. I can understand that the import tool is not so smart to do all the guessing.

What default workflow will be used for the new project?

Aynway, I will check that point.

Thanks,

Didier.

Nop..not working.

My 3 lists of one Trello Board are: Open, In Progress, Closed.

The lists of my statuses in JIRA Core is quite big, but I have this ones listed: Open, In Progress, Reopened, Resolved, Closed, ...

So the statuses from Trello are now matching. I still have the same error when importing this board in JIRA Core

Cannot persist a workflow where mapping of project configurations is inconsistent. See logs for more details. Cannot persist a workflow where mapping of project configurations is inconsistent. See logs for more details.

Where can I see the import logs?

Didier.

Thank you for the details and for testing, @Didier Debbaut.

I tried to replicate the issue here by creating about 10 columns on Trello with different names and it imported correctly to Jira. I also tested on a brand new Jira Core free site and it worked. 

Can you please let us know the exact date and time that you last tried to import the Trello board to Jira? Also, please, let us know your timezone so we can filter the logs here to check what is causing this. 

I searched for other similar cases and all of them are related to workflow statuses, but as I mentioned, I tested importing a Board with different statuses, and the new statuses were created in Jira.

Hi Angélica,

I will do it again today and note the exact timestamp and timezone.

As said, this import was working fine when I had Jira Software and JIRA Service installed. But as I dropped both products after testing, I only have Jira Core now.

Maybe this has an impact, I see some old stuff from the other products in my instance (like statuses and workflows). Bad cleanup when I dropped both products?

I reply back today.

Didier

timezone: europe/Zurich (Switzerland)

Starttime: 03-Feb 21h30

-> first error pops up: Cannot persist a workflow where mapping of project configurations is inconsistent. See logs for more details.

2. I click on button "begin import": 03-Feb 21h31

-> second error: Cannot persist a workflow where mapping of project configurations is inconsistent. See logs for more details.

Please see in the log what is causing this problem.

Didier.

Thank you for providing the details, @Didier Debbaut.

We were able to find the error logs and it's related to statuses that already exists, but on next-gen projects:

2021-02-03 21:30:48.924 ERROR com.atlassian.jira.workflow.OSWorkflowManager Cannot persist a workflow where the mapping of project configurations is inconsistent.

workflow: Trello Workflow for debbaut.solutions - website

statusIds: [10037, 1, 10000, 3, 3, 6]

projectConfigurationId: null

We don't have access to your database, so we can't confirm which are the statuses. 

Are there any remaining Software or Service projects on your site? 

Can you go to Cog icon > Projects and check if there are any projects on the Trash and Archive?

If there are no Software and Service projects, then since you removed both products, the data may still be in the database, so my suggestion would be to rename all columns on Trello, for example, add one more letter or other information just for it to be different from the ones that already exist and then, try to import again. After the import, you can rename it.

Please, take your time to test and let us know if you face any issues.

If it shows an error, let us know the time you started the import, so we can filter the logs here. 

Hello,

aha..interesting. I was suspecting some crap with these obsolete products. These are the JIRA statuses for the IDs that are marked in the log (I hope this makes sense)

10037: Archived

1: Open

10000: does not exist!

3: In Progress

6: Closed

 

My answers:

1. I have total 4 active business projects

2. Trash folder: 4 next-gen projects

3. Archive folder: 0 projects

4. I renamed my 3 columns for my dashboard so that they are unique (like x_open). The import still fails with the same error.

5. BUT the 3 new statutes "x_" are now created in JIRA, so the status creation is better (IDs 10044 - 10045 - 10046).

But there is still another problem.

Timestamp: 04-Feb Europe/Zurich 19h00

Thanks for the troubleshooting.

Didier.

 

PS: see my list of statuses

status.png

Thank you for testing, Didier.

The next-gen project might be causing the issue. 

Is it possible to delete the next-gen projects?

If you need to keep the data, please create a backup before doing that. 

After deleting them, please, try to import the Trello board again.

YESSS...

After deleting all the trash next-gen projects, I can now import my Trello board with no problem.

This is a serious bug, as trash projects should not prevent importing Trello. A bug to raise to R&D to get this fixed.

Many thanks for your support!

You can close this ticket.

Didier.

Like Angélica Luz likes this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events