Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,204
Community Members
 
Community Events
176
Community Groups

Attachment upload issue - Internal error

Hi

We have been having the following problem on our jira installation:

When uploading attachments to some issues, an internal error shows up.

Following some of the questions I found online, I created a HAR of the issue and was able to reveal that the POST data was incomplete and the server response code was "0". The size of the body also was 0 bytes.

Further than that, I don't know how to find out more about this issue or how to even attempt to solve it.

1 answer

0 votes

Hi @Sandro Leone ,

welcome to the Atlassian community!

Please could you extract error in the JIRA-HOME/log/atlassian-jira.log file so that we can support you on that?

Fabio

Hi @Fabio Racobaldo _Herzum_ 

 

Under program files/atlassian/jira/logs was no atlassian-jira.log file. But I found a atlassian-jira-gc-(date).log file. Can this file help aswell? It's approx 8'000 KB, so I'm not sure how to get that to you.

Edit: CTRL+F "error" brings up nothing in that file.

 

BR

Sandro

Hey @Sandro Leone , you are on the inst folder. Please go in the JIRA-HOME folder /logs/ try to upload a file and then copy just portion of log files with the error.

Hi @Fabio Racobaldo _Herzum_ 

 

For example this is one of the errors. There were a couple but I also tried a couple times. Maybe I can somehow send you the whole file.

I also saw that there was now an issue seeing annotations in pdf's while viewing them in the jira preview, which worked fine before. could this be connected?

 

2022-12-16 11:12:07,615+0100 https-openssl-nio-443-exec-22 ERROR [o.a.c.c.C.[.[localhost].[/].[viewattachment]] Servlet.service() for servlet [viewattachment] in context with path [] threw exception [com.atlassian.jira.issue.attachment.AttachmentReadException: com.atlassian.jira.exception.DataAccessException: org.apache.catalina.connector.ClientAbortException: java.io.IOException: An established connection was aborted by the software in your host machine] with root cause
java.io.IOException: An established connection was aborted by the software in your host machine
at java.base/sun.nio.ch.SocketDispatcher.write0(Native Method)
at java.base/sun.nio.ch.SocketDispatcher.write(Unknown Source)
at java.base/sun.nio.ch.IOUtil.writeFromNativeBuffer(Unknown Source)
at java.base/sun.nio.ch.IOUtil.write(Unknown Source)
at java.base/sun.nio.ch.IOUtil.write(Unknown Source)
at java.base/sun.nio.ch.SocketChannelImpl.write(Unknown Source)
... 16 filtered
at com.atlassian.gzipfilter.RoutableServletOutputStream.write(RoutableServletOutputStream.java:134)
at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1159)
at org.apache.commons.io.IOUtils.copy(IOUtils.java:878)
at org.apache.commons.io.IOUtils.copyLarge(IOUtils.java:1135)
at org.apache.commons.io.IOUtils.copy(IOUtils.java:854)
at com.atlassian.jira.web.servlet.viewfile.AbstractViewFileServlet.copyAll(AbstractViewFileServlet.java:263)
at com.atlassian.jira.web.servlet.viewfile.AbstractViewFileServlet.copyStream(AbstractViewFileServlet.java:187)
at com.atlassian.jira.web.servlet.viewfile.AbstractViewFileServlet.lambda$streamFileData$2(AbstractViewFileServlet.java:149)
at com.atlassian.jira.issue.managers.DefaultAttachmentManager$7.apply(DefaultAttachmentManager.java:731)
at com.atlassian.jira.issue.managers.DefaultAttachmentManager$7.apply(DefaultAttachmentManager.java:727)
at com.atlassian.jira.issue.attachment.store.DefaultFileSystemAttachmentStore$2.apply(DefaultFileSystemAttachmentStore.java:127)
at com.atlassian.jira.issue.attachment.store.DefaultFileSystemAttachmentStore$2.apply(DefaultFileSystemAttachmentStore.java:124)
at com.atlassian.jira.issue.attachment.store.DefaultFileSystemAttachmentStore$3.call(DefaultFileSystemAttachmentStore.java:150)
at io.atlassian.util.concurrent.Executors$DefaultSubmitter$CallableRunner.run(Executors.java:85)
at io.atlassian.util.concurrent.LimitedExecutor$Runner.run(LimitedExecutor.java:94)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.base/java.lang.Thread.run(Unknown Source)

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events