It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I cannot edit a Confluence page I am an admin for Edited

Hi,

I setup a new Confluence page.  Now when I hit the pencil button to edit it, it goes to the edit screen but I cannot edit anything.  Any ideas how to fix this?  The permission in settings look right to me...

Thanks.
-Brian

1 answer

1 accepted

0 votes
Answer accepted
Dominic Lagger Community Leader Dec 11, 2019

Hi @Brian_Horwitz 

What do you mean by "it goes to the edit screen, but I cannot edit anything"?

  • Does the save button or the close button appear?
  • Can you write, can you delete text?
  • Is the page totally empty or does it have any text?
  • And is that page the only page with this behaviour? What happens, when you create another page?

Could you provide a screenshot from the edit mode? 

Thanks for sharing the information

Regards, Dominic

This is what I see when I click on the pencil to go into edit mode (mind you I created the page 2 days ago).  None of the text is editable...when I try to type over some of the text it simply does nothing at all:

 

Confluence Error.jpg

I can add/edit pages under this main page.

 

Thanks for your help!

-Brian

Dominic Lagger Community Leader Dec 11, 2019

So I tried a bit and for one space, I could reproduce it. 

After some research, there are several users, who have this issue. I found this issue for confluence cloud: https://jira.atlassian.com/browse/CONFCLOUD-68168

Also there are a lot of users who asked the community with differen answers:

I personally tried microsoft edge, and there it worked. 

Can you try another browser? 

Dominic Lagger Community Leader Dec 12, 2019

Here is the best community article in my opinion. 

https://community.atlassian.com/t5/Confluence-questions/I-can-add-pages-but-when-i-try-to-edit-it-the-controls-are/qaq-p/1227991

Steps which are recommended in this thread: 

  • Check WSS (WebSockets) 
  • Check newest Chrome version
  • Try in incognito or private browsing
  • Try from another network / PC

I tried in Chrome, Edge and Firefox to no avail.  Let me try your other suggestions.

It seems to be a proxy issue.  I tried everything mentioned above, and the only thing that worked was when I used our less secure "guest" wifi account.  It's very strange that this is the only site giving me this issue...I am able to modify several other Confluence pages.

Dominic Lagger Community Leader Dec 12, 2019

Yes, same for me. I can edit some pages, and some I can't edit. But I think the difference is the new editor style. Confluence cloud released the new editor feature some time ago. All new pages coming with this editor. And all pages with this editor, I can't edit. 

All old pages, coming with the old editor, I can easily edit. Maybe you can observe the same.

We've been having this issue for months now. We're reviewing alternate platforms. Very frustrating.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

How To: get the most out of the new Confluence navigation and Home

Hi Community, Elaine again from Confluence Cloud Product Management. Most of you have used the new Confluence navigation and Home for some time by now. Not sure what changed or just want to lear...

480 views 3 10
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you