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Outgoing email returns error

asish lamichhane
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May 31, 2019

I have set SMTP outgoing email. the configuration connection is successful. But when I try to send the test email, i get following error:

An error has occurred with sending the test email:
com.atlassian.mail.MailException: com.sun.mail.smtp.SMTPSendFailedException: 530 5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM [MWHPR2201CA0076.namprd22.prod.outlook.com]

at com.atlassian.mail.server.impl.SMTPMailServerImpl.sendWithMessageId(SMTPMailServerImpl.java:222)
at com.atlassian.mail.server.impl.SMTPMailServerImpl.send(SMTPMailServerImpl.java:159)
at com.atlassian.jira.plugins.mail.webwork.SendTestMail.doExecute(SendTestMail.java:95)
at webwork.action.ActionSupport.execute(ActionSupport.java:165)
at com.atlassian.jira.action.JiraActionSupport.execute(JiraActionSupport.java:63)
at webwork.interceptor.DefaultInterceptorChain.proceed(DefaultInterceptorChain.java:39)
at webwork.interceptor.NestedInterceptorChain.proceed(NestedInterceptorChain.java:31)
at webwork.interceptor.ChainedInterceptor.intercept(ChainedInterceptor.java:16)
at webwork.interceptor.DefaultInterceptorChain.proceed(DefaultInterceptorChain.java:35)
at webwork.dispatcher.GenericDispatcher.executeAction(GenericDispatcher.java:225)
at webwork.dispatcher.GenericDispatcher.executeAction(GenericDispatcher.java:154)
at .......

1 answer

0 votes
Andy Heinzer
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
June 3, 2019

Hi Asish,

We have encountered that specific SMTP error code (530 5.7.57) a number of times in relation to Jira.  Please see our KB about this in Test Email is failing due to "530 5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM" error.

From that KB:

Cause

The error that is being shown at the Test Email page is not accurate enough for troubleshooting. The exact cause is the timeout is too short for the SMTP server connection and authentication.

Resolution

Increasing the value in increments of 10000 (10 seconds) is suggested until the errors are resolved. We also recommend contacting the network administrator to isolate any causes of network traffic slowness. For example, an Anti-virus application scanning all outbound traffic may contribute to this behavior. For more information, please refer to Read timed out error when sending outbound mail from JIRA applications. 

As such, you should be able to extend this timeout value as a means to get past this particular error.

I hope this helps.

Andy

Michael Goerner
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July 31, 2019

There seems to be more to this than the timeout. Our server is set to 10000 and we get the same error message.

 

Out log files show that the FROM email address is actually NULL, which is more in line with the error being reported:


Sending mailitem To='***' Subject='(LB-100) ***' From='null' FromName='***' Cc='null' Bcc='null' ReplyTo='null' InReplyTo='<JIRA.10746.1564527188000@Atlassian.JIRA>'


Every account has an email address associated with it. Why would the FROM email address be NULL in this case?

Andy Heinzer
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
August 5, 2019

Hi @Michael Goerner 

Thanks for adding in that detail here.  Something that I just learned (or re-learned) was that it is possible that each notification scheme in Jira could be using its own unique From email address.  Details about this are in Configuring email notifications: Configuring a project's email address - Atlassian Documentation.

And since each project can have its own notification scheme, I'd be curious to learn if the scheme applied to the LB project here has an unexpected value for that email address here.   Also, Jira typically is not sending mail as each possible user logged into Jira, but rather there tends to be a service account used to send outgoing mail.   IIRC, Jira will make the From of outbound messages the value in that notification scheme if it exists, if it has not been customized, then I believe it defaults back to the global stmp outbound settings of that Jira site.  

Jira will try to change the email to display the message to appear as if it came from the Display Name or Full Name of the user that triggered the event that caused the notification, but even in that case, it doesn't display that users email address in the from field.   But back to your example, I agree it should not be null, but to better understand what exact value should appear there (if successful) is also dependent upon Jira being able to login to that SMTP server with the credentials supplied and send the message with the account defined in (project notifications scheme if applicable, OR) the global outbound mail settings in Jira.

Are you seeing a SMTP error code (530 5.7.57) here as well?  Are you also using outlook for your SMTP provider?   If so, I came across another post with this same error in https://answers.microsoft.com/en-us/msoffice/forum/msoffice_outlook-mso_winother/client-was-not-authenticated-to-send-anonymous/d405bcb0-f40c-42fa-b1b2-477597100123

The response there appears to be related to the smtp address used to send that mail and the DNS records that could be required send mail here.

I hope this helps.

Andy

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