The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Asset management APIs are not returning "RETRY-AFTER" header in throttling 429 error scenarios

Nijas Rawther
March 11, 2024

As per Atlassian documentation, APIs should be sending "Retry-After" header during 429 Error throttling scenarios.

However, upon testing we have figured that, asset endpoints like say https://api.atlassian.com/jsm/assets/workspace/<workspaceId>/v1/objectconnectedtickets/<objectId>/tickets etc. are not returning "Retry-After" header during 429 Error throttling scenarios.

Any idea why ?

1 answer

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

0 votes
Marc -Devoteam-
Community Champion
March 11, 2024

Hi @Nijas Rawther 

I would address this issue with Atlassian Support.

But it also could be that this doesn't apply on this API part as assets (formerly Insight), is not completely integrated.

DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
TAGS
AUG Leaders

Atlassian Community Events