The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Is there any way to see detailed logs in the cloud, to solve my SSO problems

Charlie Cramm
June 26, 2024

Hello everyone,

I have added SAML SSO and activated an auth policy to enable and use SSO. I use keycloak and when I try to log in it redirects me to keycloak and I log in and it redirects me back. But then I get the following error:Screenshot from 2024-06-26 15-49-38.png

Is there any way to get a more detailed error message that tells me exactly why it's having trouble? I remember vaguely that back in the on-prem datacenter edition days you could log in to you server and use a string like this:

a9bd4595-599f-4ead-b831-46ecd388cb1c

to search in the logs and get a more detailed view of the problem.

Is there any way to do the same in cloud cause the only thing I see are the audit logs and they are not helpful.

Ill also share my mappers in keycloak in case my mistake is there.Screenshot from 2024-06-26 15-59-41.png Thanks in advance!

1 answer

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

2 votes
Answer accepted
Hector Menchaca
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
June 26, 2024

Hello @Charlie Cramm ,

Welcome to Atlassian Community!

Can you please attach a screenshot of the error with the browser URL included?

If you can do that for us I will be able to help or identify the problem.

Best Regards,

Thanks!

Hector Menchaca
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
June 26, 2024

@Charlie Cramm 

Thanks for your reply!

That error tells us that the certificate is expired, to renew it please follow the next steps:

  • 1. Go to admin.atlassian.com<http://admin.atlassian.com/> and select your organization.
  • 2. Go to Identity Providers and open your SAML configuration
  • 3. Go to your IdP Dashboard and download a new x64 certificate.
  • 4. Go to your SAML Configuration and update the x509 certificate field with the new certificate.

 

Like • # people like this
Charlie Cramm
June 26, 2024

Hey @Hector Menchaca

Yes thank you it works now.

And I'll thank you once more for your speedy responses.

TAGS
AUG Leaders

Atlassian Community Events