Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why can't I download an attachment any more?

I've used Trello for 3 years.  Yesterday, when I click Download on an attachment in a trello card, it no longer downloads to my download folder - it just displays on the screen.  What happened?  I've rebooted twice.  Didn't solve it.

11 answers

Just to add that the download button does not appear in Safari. Hugely effecting our workflow efficiency, would appreciate a fix soon. Thanks!

2 votes
Daniel Eads Atlassian Team Oct 01, 2018

Hey all,

At this point you'll need to right-click on the preview or "open in new tab" links and use the download option from your browser. Details on the why are in the link.

image.png

Cheers,
Daniel

Thank you, Daniel. This was helpful, as was your explanation of why this has become an issue in the link. I will forward this information on to our team.

But I use the Trello desktop-app, and it does not give me a context-meny on right-click. I need to "open in browser", and then do file "save as"...  It should be easier to download it...

There is no "save link as" function in my case, save as only tries to save an HTML link rather than the original file format (as does opening the file and trying to save from a  new window), basically after 20 minutes of digging I still have no idea how to download the original file format (in this case SVG but it happens on several different formats) and will need to go back to the designed to get the original file directly. This now happens several times a week and it should not be this difficult to download an attachment from trello. 

Like Erin likes this
Daniel Eads Atlassian Team Mar 04, 2020

Hey Kaitlin,

Happy to help track this down! What operating system and browser are you using to try and download the SVG file?

I've attempted an SVG file on my Mac with Chrome and it seems to be working as expected:

svg_download.gif

With the additional information (your operation system, browser, and preferably browser version), I'll be able to try with this file again and see if we can't track down a way for you to download files easily.

Thanks!
Daniel | Atlassian Support

Christopher, Can you let us know when this is resolved? We noticed that the "download" option doesn't appear in Chrome, Edge or Microsoft Explorer. (We have not tried Safari or Firefox.) We are using the workaround, but do miss the ease of simply clicking "Download". Thank you for working on this!

Still not working. Why are you guys wrecking Trello? Oh yeah, you're Atlassian.

Deleted user Nov 01, 2018

Yep, still broken - time to move 

Its still broken in 2019 as well

Try clicking the little -> that is at an angle just to the right of the attachment text. That opened it in a new tab saving the file for me. 

0 votes
Teddy Atlassian Team Apr 02, 2018

Hi LuNell,

The issue you refer to is a known issue with the current version of Trello and something we're looking to fix very soon. It was caused by a recent Chrome update.

A workaround for now is to right click on the image in the new tab and then save from there.

So you're stating it's a Chrome issue? Then why does the issue appear in Firefox and Safari as well?

@Teddy - Any update on this?  We really miss our download button and to echo the others, we are really slowed down by this glitch.  Appreciate any update or ETA so I can the keep the team from storming the castle. :)

Deleted user Nov 01, 2018

Ahh no, lots of other apps can download from Chrome - it's a Trello decision or lack of bug fix that's costing us 10+ hrs a week now 

@Teddy I also encouter the same problem (see my own question). Today  I accepted the dekstop Chrome update and now I cann't attach my Google drive files. Do you know if there's a issue right now?

 

Thx Ellen

This also isn't working for me, and I'm using the desktop app. Please address as soon as you can. My less Trello-literate colleagues are having a hard time with the work-around and it's affecting our workflow. Thank you!

Are there any updates here? This is causing major issues internally for my team and slowing us down significantly.

Considering this has been an issue for as long as it has with no apparent fix in process, it's time for us to look into an alternative. Trello is out of touch and there are better options it seems. Bye!

I've found you have to have Google Drive power up enabled for the download button to appear. Working as a hack for now.

I have Google Drive poer up enabled, and still no download button...

Open a free Google Drive account, upload your assets there, then inside Trello attach via the Google Drive option. Then when your team members click on an attached asset it'll open in Google Drive accompanied by clear and visible download button. Job done, no?

I can't tell if ur serious or not

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Trello

📹 What is Trello?

Hello Community!  My name is Brittany Joiner and I am a Trello enthusiast and Atlassian Community Leader. I'll be sharing with you a series of videos with my top tips on how to best use Trello...

314 views 10 21
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you