Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,996
Community Members
 
Community Events
176
Community Groups

Jira Power-Up Authentication Loop

I recently added the Jira Power-up to Trello. There were not any issues setting it up and the Jira site shows up under the Jira Power-Up. The issue occurs when I try to use the power-up to create an issue from this card. I'm able to select the Jira site, then a pop-up window appears that says "Jira needs authorization to access Trello on your behalf" 
When I click the "Authorize" link, the page refreshes and returns to the "Jira needs authorization..." page. I don't get an error message, just the loop. 


I've tried removing and re-adding the Jira site from the Jira Power-up. 

I've tried removing and re-adding the Jira Power-up from the Trello board. 

Neither of these options had any change. 

 

Thank you in advance for any suggestions or support. 

5 answers

Same problem

2 votes

Hi all, thanks for reporting this issue.

I've reproduced on my side and I can see where the loop happens. However, once I've completed one "loop" (i.e. I've clicked on "Authorize", and the window reappears asking me to authorize again"), I can safely close the window to end the loop, and see that the authorization has completed successfully.

Are you able to still authorize despite the looping?

And while we continue to look into this issue, could you please try deleting your browser's local storage, session storage, and cookies for the domain

https://jira-trello-integration--cdn.us-east-1.prod.public.atl-paas.net

Doing this depends on your browser, but for Chrome you can do this by accessing the developer console and navigating to the "Application" tab. https://developer.chrome.com/docs/devtools/storage/cookies/

After doing that, please authorizing the Power-Up again.

Another note, is everyone able to authorize normally via the Jira Power-Up board button? I tested this on my side and it works as expected. This could work as a workaround for those having issues authorizing your Jira instance with the Power-Up.

Screen Shot 2022-07-05 at 5.51.59 PM.png

Pressing "Remove Personal Settings" from the Power-Up's settings also resets your authorization with a Jira site, so please try that as well before attempting to re-authorize.

1 vote
Erick Doerre Atlassian Team Jul 05, 2022

Hi there,

Erick here from the Trello team.

I would like to inform you that we are aware of this issue this has been identified as a Bug and our engineering teams are actively working to fix this. While I don't have an ETA on when a fix for the issue will be pushed, as soon as one is available, we will deploy it.

I apologize for any inconvenience this has caused.


+1, the same

+1, the same

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events