Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

GitHub Power Up not working (does not initialize?)

Edited

Similar to this issue from Fabrice Benhamouda the Trello boards in my organization have had all of their GitHub Power Ups cease functioning in the middle of last week. Unlike him, the situation has not solved itself.

In some instances, the button where the Power Up would normally be exists will load, but is blank. In other situations the buttons in the Power Up region do not appear to load at all in a card. In both situations I see the following error in the browser's JS console:

GET https://github.trello.services/github.e819f7fc.js net::ERR_ABORTED 404
This references "index.html:1"

Followed much later by

Error, timeout while initializing index iframe for https://github.trello.services/index.html?ver=06487f4b1cd0. Timeout=30000ms
This message references "instrument.js:110".

Here is a screenshot showing the GitHub Power Up missing, and there being an a blank button where it normally would be.

github-powerup-missing.png

This has been checked on the most recent two versions of Mozilla Firefox and Google Chrome. Plugins were disabled, caches were cleared, log-outs-and-log-ins were performed. None of these actions have resolved the issue.

Even stranger: when I navigate to the Power Up setting itself, two issues arise which seem similar. Selecting "Edit Power-Up Settings" under GitHub from the Board Menu does nothing (was patient, many attempts made). I can navigate to the Power Up info, i.e. "Board Menu > GitHub > View Power-Up", and the GitHub plugin appears with the basic introductory information about the Power Up. However, clicking on the "Settings" button (right below "GitHub - Trello Inc"), no options in the resulting menu perform any actions.

My team has made extensive use of this Power Up since its inception, and I have not seen an issue of this nature before, to say nothing one stretching on for many days.

Other Trello users: Is anyone else experiencing this issue? I do not seem to be alone. As two other people here seem to share the situation through the moment of writing. It would be useful to learn who else is having similar issues.

Atlassian and/or Trello teams: Please advise.

Regards,
Paul

4 answers

1 accepted

2 votes
Answer accepted
Jireh Atlassian Team Oct 28, 2020

Hi everyone,

After some investigation I believe we have fixed the problem. No action is needed on your part.

Unfortunately there was an error in providing proper versioning to some browsers, so some browsers would receive the correct version of the Power-Up, and others would receive an outdated version.

Please comment here if the issue is NOT fixed for you, and we will work from there.

Good news: the option to add an authorization is back!

Bad news: when I try to use it, the "Authorize" button does nothing, and the console for the window says

instrument.ts:129 Power-Up unable to parse url hash, perhaps you needed a t.signUrl(url)?
(anonymous) @ instrument.ts:129

instrument.ts:129 Power-Up iframe initialized without a secret. Requests to Trello will not work.
(anonymous) @ instrument.ts:129

instrument.ts:129 If this is an attachment-section or card-back-section make sure you call t.signUrl on the urls you provide.
(anonymous) @ instrument.ts:129

/favicon.ico:1 Failed to load resource: the server responded with a status of 404 ()

helpers.ts:111 Uncaught DOMException: Failed to execute 'setItem' on 'Storage': Setting the value of 'set-token-endpoint' exceeded the quota.
at HTMLButtonElement.<anonymous> (https://github.trello.services/personal-access-token.ce3fd53b.js:4:1146)
at HTMLButtonElement.s (https://github.trello.services/sentry.adca52b4.js:107:696)
s @ helpers.ts:111

instrument.ts:158 POST https://api.atlassian.com/sentry/api/1147/store/?sentry_key=[redacted]&sentry_version=7 429
(anonymous) @ instrument.ts:158
(anonymous) @ fetch.ts:49
n @ syncpromise.ts:34
o.sendEvent @ fetch.ts:47
n.sendEvent @ basebackend.ts:91
i._sendEvent @ baseclient.ts:392
a._sendEvent @ client.ts:78
(anonymous) @ baseclient.ts:458
onfulfilled @ syncpromise.ts:102
(anonymous) @ syncpromise.ts:228
_executeHandlers @ syncpromise.ts:220
_attachHandler @ syncpromise.ts:208
(anonymous) @ syncpromise.ts:92
n @ syncpromise.ts:34
n.then @ syncpromise.ts:91
(anonymous) @ baseclient.ts:426
n @ syncpromise.ts:34
i._processEvent @ baseclient.ts:424
i.captureEvent @ baseclient.ts:130
(anonymous) @ baseclient.ts:98
onfulfilled @ syncpromise.ts:102
(anonymous) @ syncpromise.ts:228
_executeHandlers @ syncpromise.ts:220
_attachHandler @ syncpromise.ts:208
(anonymous) @ syncpromise.ts:92
n @ syncpromise.ts:34
n.then @ syncpromise.ts:91
i.captureException @ baseclient.ts:97
s._invokeClient @ hub.ts:395
s.captureException @ hub.ts:170
r @ index.ts:25
n @ index.ts:44
(anonymous) @ helpers.ts:108
s.withScope @ hub.ts:117
r @ index.ts:25
d @ index.ts:175
s @ helpers.ts:91
Show 7 more frames

(Redacted something that looked like it might have been a personal token. The 429 might be because when nothing happened, I tried clicking a few more times.  But the whole "Requests to Trello will not work" bit is a little worrying.)

Jireh Atlassian Team Oct 28, 2020

Hi, could you try

1. clearing cookies, sessions storage, and localStorage set by `github.trello.services`?

2. Seeing if this issue is reproduce-able on other browsers?

These steps should help narrow down the issue.

Clearing cookies/storage/localstorage definitely did the trick.  Or at least, the instrument.ts:129 errors were still in the console, but it accepted my authorization request and everything seems to be working again!

This issue started this week. I and my teammates experience the describe above behavior. The Power-Ups section is empty for 30 seconds and then all show-up but GitHub.

Today the issue is gone. I didn't try to fix anything, just refreshed Trello, and things popped up quickly as before, no 30-second timeout. I Will report back if this happens again. Thank you everyone who spent time looking at the issue.

0 votes
Jireh Atlassian Team Oct 28, 2020

Hi everyone,

I'm Jireh and I'm a developer here on Trello. I'm sorry to hear that you're running into issues with GitHub. We're working on trying to diagnose the issue. The screenshots and console logs are extremely helpful to us, so please continue to provide them when you can.

Just to give some context, all of the issues you described are the symptom of one issue, which is that the GItHub power-up is failing to initialize (which is proved by the console log). When you load a board, your browser also sends a request to all Power-Ups to initialize them. If they fail to respond in time, the Power-Up will not be "activated" on the board. None of the Power-Up's functionality will work.

Some questions for anyone experiencing the issue. All help is appreciated.

1. Does the "Error, timeout while initializing index iframe for..." error only appear for GitHub, or for other Power-Ups on your boards?

2. Does this issue happen all the time, or just sometimes? What if you created a completely new board, and added the GitHub Power-Up on that blank board? Would GitHub still continue to be broken?

These will help us narrow down the exact conditions that is causing the GItHub Power-Up to fail. Thanks in advance for your help.

1) It only happens for GitHub, I use the Slack power-up, and it loads fine.
2) For me, it happens all the time in Chrome and the MacOS app.

Also, for half of my team, it works in Chrome and the MacOS app without issue. For one person it doesn't work in any scenario. For me, it only works in Firefox.

1) Only for GitHub
2) It happens all the time

Something like this just started happening for me as well.  In my case:

It's not happening for everyone on my team; one team member reports that it happens in Chrome but not Edge, to which he added, "And my copy of Chrome is running a newer version. So I bet something between Chromium 83 and Chromium 86 broke it."

As far as I can tell, GitHub is the only powerup affected.

When I reload the page with the console open and filter to URLs containing "github", I get:

Hope this information helps y'all debug this.

I am seeing identical errors in the console,

1) Only GitHub

2) For me it fails in Chrome, Edge, on both MacOS and Windows 10

  • Only for GitHub
  • It happens all the time in all browser

I was able to fix it this way:

  1. Remove authorization of Trello as a third-party app in my github account. Even after removing authorization, I couldn't find a way to re-authorize github power-up inside Trello.
  2. Added github power-up to a new board. Then I was able to see the authorize button.
  3. After authorization, it started working on all the other boards.

I tried all of that yesterday. Disabling, clearning cache, diff browsers. Nothing was working. Today the issue disappeared on its own.

*Edit* The issue is resolved for me.

Not an answer, will answer when resolved.

 

I am experiencing exactly the same issue as detailed above. I have also raised a support ticket: TRELLO-15964 regarding this issue.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Trello

Taco Tuesday: Your favorite Trello blog takeaway

Hello friends! From the community that brought you Welcome Wednesday, Throwback Thursday and Friday Fun, welcome to Taco Tuesday, a weekly discussion about all things Trello. The best part? One Tac...

205 views 10 9
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you