Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to install Source Tree 3.3.6 Edited

Yes it's 2020 and as similarly reported here...

https://community.atlassian.com/t5/Sourcetree-questions/Install-Sourcetree-3-Windows-without-Bitbucket-Cloud-or/qaq-p/925281

and numerous times here...

https://community.atlassian.com/t5/Sourcetree-questions/Registration-Part-on-installation-stack-on-Registration/qaq-p/1275836

I'm unable to successfully install SourceTreeSetup-3.3.6...

Unwillingly I registered a Bitbucket account, linking it to my existing Jira account. When I run the installer, I click the bitbucket account. It displays a "Waiting for login to finish..." message and a indeterminate progress bar. A bitbucket page is launched in the browser asking me to grant a bunch of privileges to Sourcetree for Windows. I click the "Grant access" button. It transfers me to a localhost page which says "Authentication Successful... SourceTree has been successfully authenticated. You may now close this page." The installer removes the waiting message and the progress bar and returns me to the original step in the installation, with the Next button still grayed out. Leaving me no way to proceed with the install.

Clicking on the Bitbucket button again does nothing. If I click on the Bitbucket Server button then click back, then click the Bitbucket button again I can repeat the same failure all over again.

It's quite jaw dropping that a company like Jira could release such an obviously intrusive and yet totally non-functional installer for a product and still not fixed the issue over a year after receiving the first complaints about it.


My suggestion would be to remove the PUS (potentially unwanted service) from the SourceTree installer i.e. remove the requirement to have a bitbucket account

2 answers

Have te same problem

The solution is to install an earlier less broken version and then upgrade your way from there.

Like # people like this

I have the same problem, which version did you use to install, and where to get it ?

OK, after some research I found my way to solve this problem.
As I linked my Atlassian Account to my Google Account, I can NOT use the very old versions of the Installer (eg. 2.1.2.5) - google won't accept the browser used.
After trying a few versions, I found 2.6.10 to be a working version for me.
I could install and update to 3.1.2 , which is the current version at this time.

If anybody finds this and has the same or similar problems, you can get the old versions here:
https://www.sourcetreeapp.com/download-archives

Hope that helps.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

3,259 views 19 18
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you