It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Install Sourcetree 3 (Windows) without Bitbucket Cloud or Bitbucket Enterprise? Edited

My original 2.x install was kept up to date and ran the latest 3.x version.

Authentication issues with our corporate GitHub made me attempt a reinstall; except that now the installer insists I suddenly must create yet another account, one for a service I cannot use.

Is there a better way than digging around for an old installer?

8 answers

3 votes

Can someone from the Atlassian team at least acknowledge that this is a problem?

If they intend to open Internet Explorer (god knows why is this day and age), then this obviously doesn't work, as it opens Chrome for me.

 

What is the official stance of Atlassian on this? 

Do we seriously need to create a bitbucket (cloud) account, even if we don't intend to use it?

1 vote
Matt Falcon I'm New Here Monday

This.

2019-04-15 14_47_09-Welcome.png

Prevents me from using Sourcetree. Entirely. Prevents.

I don't want a Bitbucket Cloud account. "You can connect additional accounts such as Github [etc] once logged in". Emphasis mine.

This doesn't push me to use your Bitbucket account. It doesn't entice me or sell me on your platform - it pushes me away from Sourcetree instead.

Installing an older version as an official solution is to officially acknowledge that the current version has a major issue. So, will it be fixed? Or will the idiots at the top continue to dictate bad practices that destroy your brand and infuriate your users?

0 votes

Hi Louis!

The new account you're talking about in your message, is it to register Sourcetree during the installation steps? If you don't use Bitbucket Cloud nor Bitbucket Server, your other option is to register the installation using your Atlassian account. You're already using an Atlassian account to sign up to the online Community, so you won't need to create a new one, you can use the same credentials. Once the installation is completed you can connect your Github account as normal. 

Please let us know if that's where you were stuck. Otherwise, sending a screenshot will also help put us in the right context.

Let us know!

Ana

Hello Ana,

I expected the Atlassian account to be enough, but the installer gave only two options: Bitbucket and Bitbucket Server; clicking Bitbucket puts the installer in a state where it awaits authentication from a (Chrome) browser window. That page recognizes I have an Atlassian account and prompts me to create a Bitbucket Cloud username. Closing the page fails the authentication for the installer.

Regards,

Louis

Hi Louis, that's weird. Our Windows version of Sourcetree relies on Internet Explorer for authentication, so I'd expect it would open a IE window. Can you also make sure IE is updated to the latest version? There's been cases where having an older one caused issues.

If it prompts you again to create a Bitbucket Cloud account, could you take a screenshot and post it here?

Thanks!

Ana

Hi Ana and Louis,

I'm facing the exact same issue. Just downloaded SourceTree and tried to install. Unable to finish the first app-start since it requires a Bitbucket cloud account.

Any update on this one?

Thanks and kind regards,

Alexander

Hello Alexander,

Haven't had time to further deal with this. I simply retrieved the 2.6.10.0 installer from  https://www.sourcetreeapp.com/download-archives and haven't re-updated to 3.x since.

Sincerely,

Louis

Like 1 person likes this

Hi Louis,

yeah, I did the same - just download the previous version.

Thanks.

Best, Alexander

Any update on this?

Just got a complaint from a new user at our office about this.

0 votes
Glen Self I'm New Here Jan 22, 2019

I have the same issue.

Your system won't let me post a screen shot.

It is the box with a blue menu on the left

install is checked and registration is highlighted

can't go anywhere except bitbucket or bitbucketserver

Hi Glen,

I think the only solution for now is to download the previous version 2.6.10.0. Here's the link which Louis already posted above: https://www.sourcetreeapp.com/download-archives 

Best, Alexander

Like 1 person likes this
Glen Self I'm New Here Jan 22, 2019

Guess I'll just wait until they fix it. Don't have a lot of confidence in a product that won't even install. What else is broken?

0 votes

Why hasn't this been solved yet?

Why even rely on Internet Explorer????

The 3.x installer opens Chrome, lets me login via my Atlassian account, then insists I create a Bitbucket Cloud account I will never use. All the while the installer is waiting for some reason.

I too have just installed the previous 2.6 version, then updated from within that version to 3.0.17. That went perfectly.

This issue is also on mac for 3.1 version. Downgrade to 2.x.

0 votes

This issue is still there. Please fix it! I would never use an atlassian bitbucket cloud account. Its should be enough to register on your main page.

 

Thanks in advance.

0 votes

This issue hasn't been solved till today!? I upgraded my 2.6.10 Version to the latest 3.1 and now i stuck on a Registration screen asking for BitBucket.

Is this the new way of sourcetree? I really would like to know wheater this is the standard or not. I used sourcetree for years but right now i can't anymore, i can not skip the Registration screen.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Posted Jan 17, 2019 in Sourcetree

[dev team] Sourcetree for Windows 2019 Preview - Dark Theme

Hi folks, While the full post is over on our blog I'd like to share the dark theme we've got planned for 2019 here directly as well to keep the discussion going.  The ...

1,339 views 12 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you