Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,312
Community Members
 
Community Events
176
Community Groups

SourceTree crashes on startup

Edited

Upon opening SourceTree the application's splash screen shows up and then the application crashes with no error code listed. I've tried to uninstall and reinstall but neither work because of the same issue. I am on Windows 10. The SourceTree version I started on was 3.4.4. I tried installing the current version and it changed the folder to 3.4.7. However, there were no installation prompts.

This is the error in Event Viewer:

Faulting application name: SourceTree.exe, version: 3.4.7.0, time stamp: 0x619204e6
Faulting module name: KERNELBASE.dll, version: 10.0.19041.1503, time stamp: 0xb2acaea9
Exception code: 0xe0434352
Fault offset: 0x0000000000034f69
Faulting process id: 0x5cc0
Faulting application start time: 0x01d821cec68d2547
Faulting application path: C:\Users\kelly.arneson\AppData\Local\SourceTree\app-3.4.7\SourceTree.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: 35a1daa7-458f-4324-ac2f-53ec98d95fc7
Faulting package full name:
Faulting package-relative application ID:

1 answer

0 votes
Vipin Yadav Atlassian Team Feb 14, 2022

Hello!
Please try to remove the application using "Add and remove programs"  or go c:\Users\<User name>\AppData\Local\Atlassian\ and delete SourceTree application there and other folders. After that download app from https://www.sourcetreeapp.com and install.

Please let me know if it will not help. Also attach log file which can be found %localappdata%\Atlassian\Sourcetree\sourcetree.log

Thanks,

Thank you for your reply. I did try removing the application using "Add and remove programs" I got the splash screen and then in closed and does not appear to remove anything. I deleted the Atlassian folder in AppData\Local and when I try to install, I still only get the splash screen and nothing more. A new Atlassian folder is not created which means there is not log to be able to share.

Vipin Yadav Atlassian Team Feb 15, 2022

Hi @Kelly Arneson 

If Atlassian folder is not created then also please check the permissions/ access rights are given to Sourcetree or not. Sometimes we have seen same problem from other users and it was fixed when they give all the permissions. Because sometimes in corporates environment some applications do not have rights to read/write in these folders (C:/ drive folders). 

Thanks,

Hi, I have the same issue. Reinstalling doesn't work for me either. The Atlassian folder was not created, but the Sourcetree folder was created. I don't think the issue is due to permissions/access rights.

I did could fix it repairing the WMI registry following the steps of following link: Rebuilding the WMI Repository - Windows Forum - Spiceworks

I founded it in community product question: SourceTree crashes on launch (atlassian.com)

I hope it help you too.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events