Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,460,036
Community Members
 
Community Events
176
Community Groups

SourceTree crashes on launch

Edited

Application: SourceTree.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.Management.ManagementException at System.Management.ManagementException.ThrowWithExtendedInfo(System.Management.ManagementStatus) at System.Management.ManagementObjectCollection+ManagementObjectEnumerator.MoveNext() at SourceTree.Utils.WindowsOSHelper.GetWindowsVersion() at SourceTree.App..ctor() at SourceTree.App.Main()

What I tried with no luck:

  • Reinstall
  • Latest beta (2.1.7.0)
  • Cleaning AppData/Local/ 

2 answers

1 vote
minnsey Atlassian Team Jul 26, 2017

Hi
It is possible the WMI registry has become corrupted. Could you try the following for me?

  • Open up 'Computer Management'
  • Select 'Services and Applications' (left side panel)
  • Right click on 'WMI Control' > 'Properties'
  • Check and see if the description under "General" lists any error or warning

If there are errors. this link is easy to follow to try and correct it.

No issues there.

@minnseyFixing the WMI registry worked for me. Thanks!

@minnsey Fixing the WMI registry also worked for me. Thanks you very much!!!

Fixing the WMI repository worked for me. 

 

Followed first three steps from the below article.

https://community.spiceworks.com/how_to/21413-rebuilding-the-wmi-repository

0 votes
Ana Retamal Atlassian Team Jul 26, 2017

Hi Timur! Can you try a clean install following these instructions:

  1. Wipe SourceTree preferences
  2. Uninstall SourceTree.
  3. Backup then delete the directory below before proceeding with next step
    • Navigate to C:\Users\<UserName>\AppData\Local and delete SourceTree & SourceTree-Settings folder
    • Navigate to C:\Users\<UserName>\AppData\Local\Atlassian and delete all SourceTree Files/Folder.
  4. Download SourceTree and install it. 

If this doesn't work for you, please let us know which Windows version are you using.

Regards,

Ana

This helped with additional restart of PC before instaling SourceTree back.

Thank you!

Ana Retamal Atlassian Team Jul 27, 2017

Glad to hear that, Timur! :)

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events