Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

SourceTree Enterprise: "failed to check login for user"

I installed SourceTree Enterprise and attempted to login to my local Bitbucket Server installation. The login fails with the message "failed to check login for user [{username}]".

The log has the following entries:
ERROR [timestamp] [1] [SourceTree.Exceptions.RemoteHostException] [.ctor] - Insufficient authentication credentials
ERROR [timestamp] [1] [SourceTree.Exceptions.RemoteHostException] [.ctor] - Failed to check login for user [{username}]

The root URL ( https://{server}.{domain}/{context}/ ), username and password are the same ones I use when successfully logging into Bitbucket in Internet Explorer on the same PC.

My username does not include any special characters such as the '@' symbol.

I have tried the suggestions in the following:

What additional authentication credentials am I supposed to provide, and how?

Software versions:
- Windows 7 Enterprise
- Internet Explorer 11.0.51
- SourceTree Enterprise 2.5.5
- .Net Framework 4.7.1


3 answers

1 accepted

This bug report is now marked as resolved and should go into version 3.0.3!

Like Daniel Takahashi likes this

I have the same problem. This this Oct 17, 2019. Almost a year passed still no answer.

I had the same issue, searched and tried many suggestion to resolve but none worked for me.

My problem was simple, but not immediately obvious - my username contained a space, eg. "John Smith". I changed my username in bitbucket server to just "John" and then I could login successfully with source tree.

If Bitbucket allows you to create a username with a space, and also login to bitbucket with a space in the username, source tree also should.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events