Source Tree for Windows does not start

Hello,

after successfully using Source Tree for Windows ca. 2 weeks it suddenly doesn't start:

PLATFORM VERSION INFO
	Windows 			: 6.1.7601.65536 (Win32NT)
	Common Language Runtime 	: 4.0.30319.18034
	System.Deployment.dll 		: 4.0.30319.17929 built by: FX45RTMREL
	clr.dll 			: 4.0.30319.18034 built by: FX45RTMGDR
	dfdll.dll 			: 4.0.30319.17929 built by: FX45RTMREL
	dfshim.dll 			: 4.0.41209.0 (Main.041209-0000)

SOURCES
	Deployment url			: file:///C:/Users/MYACCOUNT/Desktop/SourceTree.appref-ms%7C

ERROR SUMMARY
	Below is a summary of the errors, details of these errors are listed later in the log.
	* Activation of C:\Users\MYACCOUNT\Desktop\SourceTree.appref-ms| resulted in exception. Following failure messages were detected:
		+ Value does not fall within the expected range.

COMPONENT STORE TRANSACTION FAILURE SUMMARY
	No transaction error was detected.

WARNINGS
	There were no warnings during this operation.

OPERATION PROGRESS STATUS
	* [08.04.2013 15:56:24] : Activation of C:\Users\MYACCOUNT\Desktop\SourceTree.appref-ms| has started.
	* [08.04.2013 15:56:24] : Performing necessary update check as specified by the deployment.

ERROR DETAILS
	Following errors were detected during this operation.
	* [08.04.2013 15:56:24] System.ArgumentException
		- Value does not fall within the expected range.
		- Source: System.Deployment
		- Stack trace:
			at System.Deployment.Application.NativeMethods.CorLaunchApplication(UInt32 hostType, String applicationFullName, Int32 manifestPathsCount, String[] manifestPaths, Int32 activationDataCount, String[] activationData, PROCESS_INFORMATION processInformation)
			at System.Deployment.Application.ComponentStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)
			at System.Deployment.Application.SubscriptionStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)
			at System.Deployment.Application.ApplicationActivator.Activate(DefinitionAppId appId, AssemblyManifest appManifest, String activationParameter, Boolean useActivationParameter)
			at System.Deployment.Application.ApplicationActivator.ProcessOrFollowShortcut(String shortcutFile, String& errorPageUrl, TempFile& deployFile)
			at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
			at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

COMPONENT STORE TRANSACTION DETAILS
	No transaction information is available.

Thanks in advance for helpful comments or a solution.

29 answers

1 accepted

Hmm, that's an odd one. Please go to Control Panel > Programs > Uninstall a program, click SourceTree and then Uninstall / Change. Please remove SourceTree from your system, then re-install from sourcetreeapp.com. Note that you may have to reinstate your global options if you changed them from the default but your bookmarks and repository settings will be retained.

Did work, thanks.

Hi Steve, I'm using SourceTree but sudenly I can`t open the program. I click on it but nothing happend. I have already unistalled the program and installed again but with the same result.

What can I do to solve this problem? I have Windows 8.1.

 

Thank you.

Same happening here from yesterday

What worked for me: "Start programm as administrator."

But why does sourcetree need admin-rights?

 

So, each time it happens Must I have to re install it? what a terrible software!!!!

A good software must not have that kind of trouble.

 

I have now used this solution of uninstalling and reinstalling three times in the last month. Has anyone found why this occurs?

 

This is happening to me today. Just can't launch the programme. Will try uninstalling it and installing it again, but along with it slowing right down and with the introduction of a few recent glitches, maybe it's time to find another option. Shame as it used to be really good. I hope they can get the development back on track and get it working properly again.

I cant start too. Uninstalled. Try to install

ERROR [2017-10-10 06:53:17,136] [1] [SourceTree.App] [SetStartupJIT] - Startup JIT encountered an error...
System.Configuration.ConfigurationErrorsException: ".", шестнадцатеричное значение 0x00, является недопустимым знаком., строка 15, позиция 1. (C:\Users\Сергей\AppData\Local\Atlassian\SourceTree.exe_Url_vugdgboj5l2cs54bjhbr22ckg0ujbphh\2.3.1.0\user.config line 15) ---> System.Xml.XmlException: ".", шестнадцатеричное значение 0x00, является недопустимым знаком., строка 15, позиция 1.
в System.Xml.XmlTextReaderImpl.Throw(Exception e)
в System.Xml.XmlTextReaderImpl.ParseText(Int32& startPos, Int32& endPos, Int32& outOrChars)
в System.Xml.XmlTextReaderImpl.ParseText()
в System.Xml.XmlTextReaderImpl.ParseElementContent()
в System.Xml.XmlTextReaderImpl.Skip()
в System.Configuration.XmlUtil.StrictSkipToNextElement(ExceptionAction action)
в System.Configuration.BaseConfigurationRecord.ScanSectionsRecursive(XmlUtil xmlUtil, String parentConfigKey, Boolean inLocation, String locationSubPath, OverrideModeSetting overrideMode, Boolean skipInChildApps)
в System.Configuration.BaseConfigurationRecord.ScanSectionsRecursive(XmlUtil xmlUtil, String parentConfigKey, Boolean inLocation, String locationSubPath, OverrideModeSetting overrideMode, Boolean skipInChildApps)
в System.Configuration.BaseConfigurationRecord.ScanSections(XmlUtil xmlUtil)
в System.Configuration.BaseConfigurationRecord.InitConfigFromFile()
--- Конец трассировки внутреннего стека исключений ---
в System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
в System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)
в System.Configuration.Configuration..ctor(String locationSubPath, Type typeConfigHost, Object[] hostInitConfigurationParams)
в System.Configuration.ClientConfigurationHost.OpenExeConfiguration(ConfigurationFileMap fileMap, Boolean isMachine, ConfigurationUserLevel userLevel, String exePath)
в System.Configuration.ConfigurationManager.OpenExeConfigurationImpl(ConfigurationFileMap fileMap, Boolean isMachine, ConfigurationUserLevel userLevel, String exePath, Boolean preLoad)
в SourceTree.App.SetStartupJIT()

After trying to install user_config.xml is:

user_config.png

I saved files accounts.json, bookmarks.xml, passwd

Uninstalled

Droped /Users/User_name/AppData/Local/Atlassian

Installed

Replaced files, see above

I seems to me, that SourceTree works

 

May be it will help to users

Thank you.

Only deleting of /Users/User_name/AppData/Local/Atlassian folder helped me to be able to reinstall SourceTree. For some reason, this folder got in a corrupted state or similar.

J O I'm New Here Feb 27, 2018

it was really helpfull. Thanks. Gracias!

Clearing out my C:\Users\%USERNAME%\AppData\Local\Atlassian\SourceTree\ directory did the trick for me!

This worked for me on Windows 10 x64 except I also had to clear the SoureTree[long hash] directory

You saved my hours!!!! MANY THANKS!!!

Thanks  Christian, this saved me some time as well. 

This helped me too! To reach there I just type %appdata% on run window and deleted every folder under SourceTree because of which mymapped repositories went off, but which was easy to restore. Thanks a lot!

yep, worked for me as well, and after the app was launched i copied everything back and got all my settings back as well

It worked for me... Thank you!

Hi,

I am using windows 7, where I am not able to find out User\AppData\Local|Atlassian

 

Could you please help me out of this.

 

Thanks,

Sri

Hooray! Source Tree launched!!!
ST.png

I had no this setup

Thanks you. it worked for me.

I had the same issue. It got solved by doing the following:

1) uninstall and reinstall

2) Delete the folder C:\Users\yourusername\AppData\Local\Atlassian\SourceTree.exe_Url_yjhzxxhcu2ommegrdorjf3q1oqllqxiq

 

Of course the folder will be under your username and the folder name will different but it should look similar.

Thank you Daniel, I have solved the problem doing exactly the same.

Thanks this worked for me too

Thank you! This worked for me but in addition, I also cleared what was in the "SourceTree" folder as well under the 'C:\Users\yourusername\AppData\Local\Atlassian\'. I just wanted to note that the thing that actually got it to work was Daniel's step 2.

Works for me too. Thanks.

Worked like a charm.Only deleting the directory solved the issue.Thanks.

Perfect - worked for me. thank you.

I cannot run Sourtree, wouldn't start, uninstalled, removed all folders, now I cannot install it? Windows 10? Annoying and really need to get on with work.

I had been using Sourcetree and then this week it stopped.  It would never launch.  I've uninstalled, removed all the files, and attempted to reinstall.  The installer flashes one small logo box and that is it.  It seems like it might fail.  The result is a desktop shortcut that does nothing.  I am running Windows 10 x64.

After struggling with this for a while, and trying several other suggestions I figured out what worked for me.  I re-installed  SourceTree but to a different install folder ( i.e. "C:\Program Files (x86)\Atlassian\SourceTree2" instead of the default "C:\Program Files (x86)\Atlassian\SourceTree" )

Maybe there was a rogue registry entry or something causing problems.

This was (finally) the solution that worked for me. After the update to 1.9.6.1 it started once but not any more after that. I tried all other suggestions:

  • clearing the TEMP folder
  • deleting the folders in user/appdata/Atlassian
  • uninstalling / installing again
  • uninstalling / installing again and removing all registery entries (IObit uninstaller), and the folders in appdata/Atlassian
  • Repairing the .NET 4.6 installation

ALL of these did not work, finally changing the installation location did the trick, so thanks for the suggestion.

 

I have the same problem. SourceTree won't start.

Tried all of the solutions above, except of re-installing .Net.

Removed C:\Users\users\AppData\Local\Atlassian\ folder and uninstalled SourceTree.

Now even the installer won't run.

I does show the initial sourceTree icon during the installation and then it quits. Start menu icon is created anyway, but when I press it nothing happens.

I am not getting any exceptions or other messages.

sourcetree.log contains this message:

ERROR [2017-10-09 09:59:41,061] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2017-10-09 09:59:41,199] [1] [SourceTree.App] [OnStartup] - Failed to start
System.NullReferenceException: Objektreferensen har inte angetts till en instans av ett objekt.
   vid SourceTree.Notifications.NotificationsManager.SetOwner(NotificationDialogWindow notificationWindow)
   vid SourceTree.Notifications.NotificationsManager.ShowNotificationDialog[T](NotificationDialogWindow notificationWindow, Tuple`2 customAction, VistaTaskDialogIcon icon)
   vid SourceTree.Notifications.NotificationsManager.ShowNotificationDialog[T](String title, String message, Tuple`2 customAction, String cancelLabel, String suppressionSetting, Action`1 suppressionChangedAction, Object contentControl, String contentCommandLabel, Action contentAction)
   vid SourceTree.Notifications.NotificationsManager.ShowNotificationDialogWithYesConfirmation(String title, String message, String details)
   vid SourceTree.Configuration.WpfSpellCheckerPreFlightCheck.Run()
   vid SourceTree.AppRoot.RunPreFlightChecks()
   vid SourceTree.AppRoot.OnStartup(StartupEventArgs e)
   vid SourceTree.App.OnStartup(StartupEventArgs e)
ERROR [2017-10-09 10:01:21,731] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2017-10-09 10:01:21,857] [1] [SourceTree.App] [OnStartup] - Failed to start
System.NullReferenceException: Objektreferensen har inte angetts till en instans av ett objekt.
   vid SourceTree.Notifications.NotificationsManager.SetOwner(NotificationDialogWindow notificationWindow)
   vid SourceTree.Notifications.NotificationsManager.ShowNotificationDialog[T](NotificationDialogWindow notificationWindow, Tuple`2 customAction, VistaTaskDialogIcon icon)
   vid SourceTree.Notifications.NotificationsManager.ShowNotificationDialog[T](String title, String message, Tuple`2 customAction, String cancelLabel, String suppressionSetting, Action`1 suppressionChangedAction, Object contentControl, String contentCommandLabel, Action contentAction)
   vid SourceTree.Notifications.NotificationsManager.ShowNotificationDialogWithYesConfirmation(String title, String message, String details)
   vid SourceTree.Configuration.WpfSpellCheckerPreFlightCheck.Run()
   vid SourceTree.AppRoot.RunPreFlightChecks()
   vid SourceTree.AppRoot.OnStartup(StartupEventArgs e)
   vid SourceTree.App.OnStartup(StartupEventArgs e)
ERROR [2017-10-09 10:02:35,673] [1] [SourceTree.App] [.ctor] - finish EnsureSquirrelExecutionStubIsCopied
ERROR [2017-10-09 10:02:35,798] [1] [SourceTree.App] [OnStartup] - Failed to start
System.NullReferenceException: Objektreferensen har inte angetts till en instans av ett objekt.
   vid SourceTree.Notifications.NotificationsManager.SetOwner(NotificationDialogWindow notificationWindow)
   vid SourceTree.Notifications.NotificationsManager.ShowNotificationDialog[T](NotificationDialogWindow notificationWindow, Tuple`2 customAction, VistaTaskDialogIcon icon)
   vid SourceTree.Notifications.NotificationsManager.ShowNotificationDialog[T](String title, String message, Tuple`2 customAction, String cancelLabel, String suppressionSetting, Action`1 suppressionChangedAction, Object contentControl, String contentCommandLabel, Action contentAction)
   vid SourceTree.Notifications.NotificationsManager.ShowNotificationDialogWithYesConfirmation(String title, String message, String details)
   vid SourceTree.Configuration.WpfSpellCheckerPreFlightCheck.Run()
   vid SourceTree.AppRoot.RunPreFlightChecks()
   vid SourceTree.AppRoot.OnStartup(StartupEventArgs e)
   vid SourceTree.App.OnStartup(StartupEventArgs e)

I'm having this exact same problem. Maybe we should start a separate issue for it?

Guys, link seems to work. Open


C:\Users\MyMane\AppData\Local\Atlassian\SourceTree.exe_Url_something\2.3.1.0

Open user.config with notepad++ etc and add this to settings.

 If you have multiple folders, remove all and run setup again.

<iframe tabindex="-1" aria-hidden="true" src="https://a1096093.cdn.optimizely.com/client_storage/a1096093.html" hidden=""></iframe>

<setting name="AutomaticallyCleanUpDictionaryFiles" serializeAs="String"> 
<value>True</value>
</setting>

Thanks, that worked for me!

However, in the current version, the config file resides at:

C:\Users\USER\AppData\Local\SourceTree\app-2.3.1\SourceTree.exe.config

Great. Tried many of the previous tips in this thread. But thanks to Dmitri Peredera my SourceTree runs again.

Thanks! Adding this setting solved for me (Win 10 16299.15, SourceTree 2.3.1.0)! +1

Hi Dimitri,

I have tried what you have suggested. But, no luck. 

Hi Dimitri
Thanks, that worked for me!!

Thank you very much! I am back to business.

Thank @Dmitri Peredera

setting  AutomaticallyCleanUpDictionaryFiles

work for me

Hi Dimitri
Thanks it worked for me :)

I have the same problem with the current version of sourcetree on windows 10.

 

It worked good for a while, but suddenly i am not able to start it. Also clearing the contents of the folder C:\Users\[username]\AppData\Local\Atlassian did not help.

 

i also tried to download the latest version and "repair". Didn't help anything.

 

What can i do now? I want to keep all the projects, that i have already setup in sourcetree.

This is one of those random ClickOnce installer / update errors that seems to occur sometimes when the ClickOnce database gets itself in a mess.

We have dropped ClickOnce because of these sorts of problems and are now using a standard MSI installer - all future updates will be distributed this way (you would have got a notification of this when the first update for this new system came through). I recommend that you re-install SourceTree from the new installer at http://sourcetreeapp.com/download/ which won't have this problem.

Sorry, but that doesn't work. Just a small splash screen and a short progress in the task bar and that's it.
Also the update process is not alright because it messes up the quick launch shortcut.

I had the same thing - splash screen, then nothing. 

Fixed it by going into Control Panel -> Language -> Change Date, Time, or Number Formats -> Administrative -> Change System Locale, and setting it to "English (United States)", then rebooting, and running the installer again.

Same here after upgrading to Windows 10 Pro 1709 "Redstone 3" (Build 16299.15 a.k.a. "Fall Creators Update"): splash screen, then nothing. Changing System Locale doesn't solve.

I finally managed to get it back to work. I had tried to delete all Atlassian folders as explained earlier with no luck.

Then looking further I found this page

https://stackoverflow.com/questions/36986079/source-tree-doesnt-launch-after-installation

which advised to findthe sourcetree-log and suddenly the folder C:\Users\<user>\AppData\Local\Atlassian that was not there just before reappeared.
I looked at the log and I had:

ERROR [2017-06-01 09:26:24,150] [1] [SourceTree.App] [SetStartupJIT] - Startup JIT encountered an error...
System.Configuration.ConfigurationErrorsException: Root element is missing. (C:\Users\<user>\AppData\Local\Atlassian\SourceTree.exe_Url_hejbjngtfoz0aqshqbv3dvaifcttjeit\2.0.20.1\user.config) ---> System.Xml.XmlException: Root element is missing.
at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res)
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Configuration.XmlUtil..ctor(Stream stream, String name, Boolean readToFirstElement, ConfigurationSchemaErrors schemaErrors)
at System.Configuration.BaseConfigurationRecord.InitConfigFromFile()
--- End of inner exception stack trace ---
at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal)
at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(ConfigurationSchemaErrors schemaErrors)
at System.Configuration.Configuration..ctor(String locationSubPath, Type typeConfigHost, Object[] hostInitConfigurationParams)
at System.Configuration.ClientConfigurationHost.OpenExeConfiguration(ConfigurationFileMap fileMap, Boolean isMachine, ConfigurationUserLevel userLevel, String exePath)
at System.Configuration.ConfigurationManager.OpenExeConfigurationImpl(ConfigurationFileMap fileMap, Boolean isMachine, ConfigurationUserLevel userLevel, String exePath, Boolean preLoad)
at SourceTree.App.SetStartupJIT()

Therfore I deleted C:\Users\<user>\AppData\Local\Atlassian (although I thought I had already done it before)
But after this the install was working !!

Hope it helps other people...

I fixed this by changing the shortcut target from

 

C:\Users\<user>\AppData\Local\SourceTree\Update.exe --processStart "SourceTree_ExecutionStub.exe" 

to

C:\Users\<user>\AppData\Local\SourceTree\Update.exe --processStart "SourceTree.exe"

  

Relevant log that caused me to do this:

 

2017-08-08 14:57:49> Program: Want to launch 'C:\Users\<user>\AppData\Local\SourceTree\app-2.1.7\SourceTree_ExecutationStub.exe'
2017-08-08 14:57:49> Program: File C:\Users\<user>\AppData\Local\SourceTree\app-2.1.7\SourceTree_ExecutationStub.exe doesn't exist in current release
2017-08-08 14:57:49> Unhandled exception: System.ArgumentException: Value does not fall within the expected range.
at Squirrel.Update.Program.ProcessStart(String exeName, String arguments, Boolean shouldWait)
at Squirrel.Update.Program.executeCommandLine(String[] args)
at Squirrel.Update.Program.main(String[] args) 

 

open directory

C:\Users\users\AppData\Local\Atlassian\SourceTree\git_extras

open git-credential-manager.exe

give credential 

now you can login to sourcetree when you install sourcetree.

After upgrading, I had the same problems.
But nothing helped. After some more searching, this solved it for me:
https://jira.atlassian.com/browse/SRCTREEWIN-7898

Thanks! Joshua Hau.  I have faced same issue and the above solution resolved mine. :)

 

fixed for me, but WTF???

Thanks! Worked for me!

It works for me too! Thank you!

FYI, I have just suffered this exact same error after having used SourceTree at home and work for the last month without issue. The only change I have made recently is to import the license file on home desktop, this was already set up on my work desktop.

I will follow your suggestion above.

PLATFORM VERSION INFO

Windows: 6.1.7601.65536 (Win32NT)

Common Language Runtime: 4.0.30319.18034

System.Deployment.dll: 4.0.30319.17929 built by: FX45RTMREL

clr.dll: 4.0.30319.18034 built by: FX45RTMGDR

dfdll.dll: 4.0.30319.17929 built by: FX45RTMREL

dfshim.dll: 4.0.41209.0 (Main.041209-0000)

SOURCES

Deployment url: file:///C:/Users/MYACCOUNT/AppData/Roaming/Microsoft/Internet%20Explorer/Quick%20Launch/User%20Pinned/TaskBar/SourceTree.appref-ms%7C

ERROR SUMMARY

Below is a summary of the errors, details of these errors are listed later in the log.

* Activation of C:\Users\MYACCOUNT\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar\SourceTree.appref-ms| resulted in exception. Following failure messages were detected:

+ Value does not fall within the expected range.

COMPONENT STORE TRANSACTION FAILURE SUMMARY

No transaction error was detected.

WARNINGS

There were no warnings during this operation.

OPERATION PROGRESS STATUS

* [17/05/2013 09:04:21] : Activation of C:\Users\MYACCOUNT\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar\SourceTree.appref-ms| has started.

* [17/05/2013 09:04:21] : Performing necessary update check as specified by the deployment.

ERROR DETAILS

Following errors were detected during this operation.

* [17/05/2013 09:04:21] System.ArgumentException

- Value does not fall within the expected range.

- Source: System.Deployment

- Stack trace:

at System.Deployment.Application.NativeMethods.CorLaunchApplication(UInt32 hostType, String applicationFullName, Int32 manifestPathsCount, String[] manifestPaths, Int32 activationDataCount, String[] activationData, PROCESS_INFORMATION processInformation)

at System.Deployment.Application.ComponentStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)

at System.Deployment.Application.SubscriptionStore.ActivateApplication(DefinitionAppId appId, String activationParameter, Boolean useActivationParameter)

at System.Deployment.Application.ApplicationActivator.Activate(DefinitionAppId appId, AssemblyManifest appManifest, String activationParameter, Boolean useActivationParameter)

at System.Deployment.Application.ApplicationActivator.ProcessOrFollowShortcut(String shortcutFile, String& errorPageUrl, TempFile& deployFile)

at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)

at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

COMPONENT STORE TRANSACTION DETAILS

No transaction information is available.

Same Source Tree not starting up, after restart same. (from the last update)


Operating System - Microsoft Windows 8 Pro 64-bit

This thread and the log is something that could happen with the old ClickOnce installer - if you have a version later than 0.9.4 this could not be the issue you're having. Please can you check sourcetree.log which is in %USER%\AppData\Local\Atlassian\SourceTree - if there's a mention in there about an error loading the configuration, then please delete or move the contents of %USER%\AppData\Local\Atlassian\SourceTree.exe_<longhash> (there should be a number of subdirectories named after versions). This will lose your settings but not your bookmarks. I've seen this problem with a couple of other people after they applied a .Net update on Windows 8, but I haven't been able to reproduce it and it doesn't seem to happen for most people.

Some others have suggested it's a temp files issue. So I Ran CCleaner and that solved it for me.

I am having this problem with Windows 7 Professional

I have tried all the above and it still doesn't work.

I uninstalled .net 4.5 and reinstalled .net 4.5

Then it started but was unstable so I uninstalled and reinstalled source tree...

I suspect the dependency installer on sourcetree isn't working correctly or that version doesn't work as source tree installed .net when I ran it's installer. Also another .net app that I tried before the reinstall wouldn't work.

HI

I installed the sourcetree that install successfully.

 

when open source tree then it popup massage : http://prntscr.com/9t7cho

i all ready install .net framwork.

 

please suggest me what issue.

 

Thanks in Advance

This morning, I had the same issue as everyone else. It is a very strange issue. On windows 10, I followed everyone's suggestions from deleted temp files, to uninstalling, repair, modify, reinstall etc, but nothing worked until I deleted the funky folder name in the AppData folder. That actually worked.

The problem might have to do with the bookmarks maybe? Here  is what I found in my error logs:

ERROR [2016-05-23 11:46:37,122] [PriorityScheduler: ] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterBookmarkEventHandlers called with null list
ERROR [2016-05-23 11:50:46,676] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterBookmarkEventHandlers called with null list
ERROR [2016-05-24 13:02:57,296] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-05-24 13:02:57,559] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-05-24 13:24:33,626] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-05-24 13:24:34,114] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-05-24 14:17:55,880] [1] [SourceTree.ViewModel.Hosted.HostingHandler] [GetScmHost] - Unable to List Repositories as the host ins not an SCM, [SourceTree.Host.Atlassianaccount.AtlassianAccountHost]
ERROR [2016-05-25 16:32:59,518] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-05-25 16:33:00,147] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-05-26 11:43:27,186] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-05-26 11:43:27,832] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-05-27 15:11:34,554] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-05-27 15:11:35,724] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-06-08 10:15:51,586] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-06-08 10:15:52,391] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-06-14 16:12:21,081] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-06-14 16:12:22,409] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-06-15 15:28:11,471] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-06-15 15:28:12,173] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-06-16 11:43:22,629] [PriorityScheduler: ] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo
ERROR [2016-06-16 11:45:53,644] [1] [SourceTree.Bookmarks.BookmarkManager] [RegisterBookmarkEventHandlers] - RegisterAsRepositoryUpdatedEventHandler called with null repo

For me it crashed after uninstalling git and installing a version suggested by application (windows 10 64bits). Solution: uninstalled everything (using iobit uninstaller), restarted windows, installed last git and then reinstalled Source Tree. Now it is working good.

Hope it helps somehow.

c ya

I still can't install on Windows 7!

+1 for windows 7

Same for me all the described workarounds do not solve my installation problems.

Yes, I also still didn't find a solution. I just gave up and moved to the Github app.

It might have something to do with the Date and Time, check if you've got the correct time and date.

 

This is a duplicate post of above that wasn't accepted by the forum (I've got an error saying that post is malformatted).

This issue is so time consuming and counter-productive.  I cannot count the number of time I have uninstalled and installed, cleared temp files, manipulated the .config file just so I can work.  I am wasting a lot of time just using the application and it is causing me to rethink the use of the client.  Have there been any rock solid solutions to resolve this...I have tried each and every answer provided in this post, as well as others, and continue to have the same problems every couple of days.

I am now at the point of uninstalling, deleting the app folders, clearing my temp/cache via CCleaner and windows tools, and the installer just closes on me, sheesh.

I am Also face this problem 

kinldy suggest me how i can do 

0 vote

error.pngthis is blank, what should i do

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 11, 2018 in Sourcetree

Tip from the team: debugging Sourcetree

Supported Platforms macOS Windows If you're reading this and it's not just educational… we know you're unhappy right now and apologize for that   We're dedicated to improving yo...

732 views 10 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you