Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Device not configured error.

I got the latest version of sourcetree yesterday. (April 4th 2018) I am unable to push my code changes to remote . I see the below error. How ever I have my password set up in sourcetree for my bitbucket account.

Please help. 

git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree push -v --tags --set-upstream origin refs/heads/feature/branchName:refs/heads/feature/branchName

Pushing to

fatal: could not read Password for '': Device not configured

Completed with errors, see above

21 answers

1 accepted

3 votes
Answer accepted

Downgrading to version 2.7 got me back and working until the issue can be sorted out. Check out the  Download Archive.

For me only 2.7 worked  - 2.7.4 was no good

This answer is not acceptable anymore. We are in 2020 and we should not have to downgrade to 2.7 as being in 4.0+.

Please upvote for visibility:

Like # people like this

My fix, which appears to be working on 2x Windows machines and 1x MacBook Pro, is to setup SSH and remove all password related things (such as keychain in MacOS). This has worked for me for a couple of months now.

Same issue in february 2019 !

Is there a chance to have an update that fix that pb ?

(3.1.3 v)


Same problem here with 3.1.1 (213) when I want to finish a feature.

BTW: How did you get 3.1.3? Update tells me I'm on the newest Version...

Deleted user Mar 11, 2019

Same problem here with 3.1.1 on a MAC, I also have the same problem on a windows 10.

same problem 3.1.2 on MacOS

same problem with 3.2.1 on MacOS Mojave

Is there anybody on atlassian ?

no answer !!!

Same issue with 3.2.1 on MacOs Mojave 

I'm having same issue with 3.2.1 on macOS Mojave.

I'm having the same issue (with 3.1.2 (216)). It seems to only happen when I've pushed the feature branch to the remote. I did found a workaround, though. Just set your HEAD to develop and use 'Merge' instead.

We are now in 2020 and I still have to downgrade to 2.X version in order to fix this.

Atlassian come on...??

Cmon! I'm in 2020 with version 4.0.1 (234) on macos 10.15.7 and still having same issue. Click on "Convert to ssh" just make "error-bump-sound" without any errors.

This answer is not acceptable anymore. We are in 2020 and we should not have to downgrade to 2.7 as being in 4.0+.

Please upvote for visibility:

I've used to be having the same issue and fixed it by right-clicking the repo in the main window and selecting 'Convert to SSH' -> so was my Github account connected through, using SSH. Restarting the app is also encouraged after doing so.

It works!! Thank you so much

Worked for me. Thank you Dorian!

Thank you so much 🎉

Worked for me too!

FIX IT (09/2020)

All the the answers here are wrong... You shouldn't NEVER do something like that:

All you have to do is:

- Go to Sourcetree -> Preferences -> Git
- You will have the section "Git Version" with 2 options: Reset to ebedded Git and Use System Git

Sourcetree use the Ebedded git for default.
Click on "Use System Git" and.... Fixed!


Follow me on:

"Use System Git" works for me. sourcetree 4.1.6, macos 10.15.7

I tested many of the solutions that are explained here, but finally the only that really worked for me was this (for Mac users only):

Thank you!

I updated to 4.0.2 and presumed the issue would be fixed, but it wasn't.

Ran the terminal commands and boom! Instant fix.

I did the following steps to get my Mac OS Sourcetree working with a GitHub Private Repo:

  1. Run the console commands as indicated in the Gist
  2. Go to preferences, add account > Github, Basic (not oAuth!! << important), Username, Password, SSH
  3. Restart the application


Now creating, finishing features, pushing changes etc. work

@luckyclan @Virl I downgraded to 2.7.2 and I can now use the finish feature. I guess I will just stick to 2.7.2

I just updated to version 2.7.5 (176) and its happening again.

I would really like to trust SourceTree not to interrupt my work day, but I'm getting pretty tired if having to back out the version


@Manju restarting Mac did not help me. 

@Ryan Sherman thanks, downgrading to version 2.7 fixed all the problems. 

@bitkid @Soumyadeep Ganguly You guys also might want to try downgrading sourcetree to version 2.7 

This worked for me.

I am not sure what is going on but I made sure everything was set to basic / https

the oauth / ssh VS basic / https WAR continues

@Sreelakshmi DodderiThanks, upgrade to 3.0 resolved this issue.

same problem here, just suddenly started happening. can't push or fetch

any update here? I am also facing the same problem in Macbook. Now am at a stage where i cant push anything

Using Visual Studio Mac with Source Tree 3.1.2  My machine already has ssh keys, etc., for other projects on BitBucket

I had a local repo for a project that was mature enough to put in the cloud. So I created new bitbucket repo.  I could not get the instructions for Visual Studio Mac to add remote repo to work, so I opened Source Tree and opened the local repo. 

Then I went to Menu -> Repo Settings and then Remotes tab.  I added the URL of the newly created Repo.   But, here is the catch: 

The URL of the page you create will be something like:

That is not correct, but SourceTree will accept that URL. And then fail (with the error in this issue) when you try to push to it..

What you actually want is:

I encountered this issue when trying to use the "finish" action on a release branch.
For some reason, the same action works for a feature branch.

I tried some of the answers above.

I tried changing my account settings to SSH. There's a button there that says "connect your account". This opens a mini browser that simply does nothing but directing you to bitbucket's login.
Only other option for you beside surfing the web is clicking cancel, which obviously not connects the account to SourceTree.
Could only connect via basic method, but this didn't change anything.

I tried some other solutions from the threads provided by other people in this thread and nothing works.

Only solution worked for me was the last thing I wanted to do, and is downgrading to 2.7.2.
And to be honest? This is the exact same version as 2.7.6 but without bugs. There's  nothing new  that worth that headache so just downgrade to 2.7.2.

There is a separate thread, and somebody published working workaround:

Try change repository link format from "" to ""

Yes, it is not safe, but it is working!


Another thread is here:

Bug is still not fixed.

But there is a workaround: go to Sourcetree>Preferences>Accounts, select account, tap Edit and change protocol from HTTPS to SSH. You have to generate SSH key and add it in bitbucket profile settings to make it work.

The interesting thing is that everything works fine on other computer in our office, no need to change to SSH there. It uses exactly the same repository settings, but different user profile.

Issue is still present in 2.7.6 (177) — git flow is broken because of it.


What the hell Atlassian?

Hi do you guys test fresh installs of sourcetree from scratch?&nbsp;
I installed on clients mac and got the same error everyone is getting above.&nbsp;
We uninstalled and installed version 2.7 and everything was fine. The latest version available is broken
0 votes
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Apr 09, 2018

We identified the issue here and hot fixed it over the weekend. Please update the build to 2.7 (167) and you should be good with this version. Sincere apologies for the inconvenience and appreciate the patience. 

Sourcetree Mac Developer

Hi Manju,

With build 2.7 (159) I got this error

Something went wrong. one or more parameters required to renew token is nil. 

With build 2.7 (165) I got this error...

Device not configured

With build 2.7 (167) I get this error...

The remote service said: 'The operation couldn’t be completed. (SDNetDomain error 7.)'

I tried the archive build to 2.7 (152) and got...

Something went wrong. one or more parameters required to renew token is nil. 


So command line it is!



Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Apr 13, 2018

Hi @Som Shahapurkar

Can you confirm the remote host you were trying to connect and whether the account was added to Sourcetree?

Sourcetree Mac Developer

Hi @Manju,

Thank you for your prompt response.

Seems like when the account was added to Sourcetree, it fails.

I deleted the account and used 'Clone in SourceTree' from bitbucket web, now it works fine.



It is not fixed, it is still present in 2.7.6 (177) on Mac.

0 votes
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Apr 06, 2018

Hi @Sreelakshmi Dodderi

There seems to be some oddity with keychain and macOS that causes this issue. I faced the same a couple weeks back and just had to restart to my Mac to get it fixed. Give it a try and let me know If it works for you. If it doesn't, please remove the account and add it again. You can enable a debug menu from Preference window -> Advanced tab and set debug logging and enable auth logs to help us get all the logs in case of failures. 

Sourcetree Mac Developer 

I have tried everything you mentioned and can't get it to work again. I have the same exact issues after upgrading yesterday. I have disabled 2FA on GitHub, reset by personal access token, remove the account and added it again, remove my github keychains, reset my machine, tried basic, oAuth with SSH and HTTPS and nothing has worked. Please help I am starting to lose my mind!

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events