Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Fatal: could not read Password for 'https://username@bitbucket.org': Device not configured

Deleted user April 6, 2018

I updated to SourceTree v 2.7.2. this morning and my first push I received this error:

Pushing to https://username@bitbucket.org/repo/path.git

fatal: could not read Password for 'https://username@bitbucket.org': Device not configured

This had never been an issue prior to the update, so I'm thinking the two are connected.

I've tried re-logging in (choosing basic and OAuth with HTTPS as the protocol), restarting sourcetree and restarting my computer but have had no luck.

 

Help is appreciated!

34 answers

1 accepted

6 votes
Answer accepted
bgannin
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
April 7, 2018

We've identified the fix and will roll out a new build later today. Our apologies for the hiccup.

Deleted user April 10, 2018

Awesome, thank you!

Like # people like this
tonholis June 16, 2018

Hi @bgannin,

Same issue here. I'm using the version 2.7.6(177) on a Mac. I'm trying to finish a feature from git-flow menu and I get this error:

fatal: could not read Password for 'https://username@bitbucket.org': Device not configured

 

I tried to re-login to Bitbucket but no luck

I tried to restart the mac but no luck

 

Should I do a downgrade?

Like tarasvitruk likes this
bgannin
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
June 18, 2018

@Manju might have a suggestion on this front.

Manju
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
June 18, 2018

@tonholis Are there other actions that result in this error too? Or is it just git-flow? Can you please let us know the account config for your Bitbucket account in Sourcetree? OAuth vs Basic? Or if you are using App Password? Please include a screenshot of the account from Sourcetree's preference. 

Manju
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
June 19, 2018

@tonholisPlease use SSH for now. We are investigating this issue. It happens only for git flow and https auth. 

Like Alex Ermolenko likes this
tonholis June 20, 2018

Hi @Manju,

I didn't test other actions because I was really focusing to finish a feature (via git-flow). The was authenticated via OAuth.

But after selecting System-Git it worked.

Thanks anyways.

Антон Кондратюк June 25, 2018

@Manju i have same problem
To use ssh bitbucket need to enable pipeline, but it's paid ((

 

Does any another way to enable git flow in source tree?

Manju
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
June 25, 2018

Using git-flow or ssh does not have anything to do with pipelines. You should be able to use them with Bitbucket without having to enable pipelines on your repo and for free. 

Zach July 11, 2018

Your solution worked for me @tonholis, thanks so much!

Like VasySav likes this
andrew_campher October 10, 2018

Well go ahead and Build another update cause getting error on 3.0.6

josef_grunig January 9, 2019

Using 3.01 for Mac and have this issue on gitflow commands.  Any hints?

Piotr Chojnowski January 10, 2019

Same here: mac version 3.0.5 build 205.  fatal: could not read Password for 'https://username@bitbucket.org': Device not configured

@Manju

@bgannin

bgannin
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
January 10, 2019

Please vote and comment on appropriate ticket(s) in our public bug tracker. Community is for questions.

Seb P April 3, 2019

Hello @bgannin,

Same here too: mac version 3.0.5 build 205.  fatal: could not read Password for 'https://username@bitbucket.org': Device not configured

When will this bug get fixed? It seems that it was mentioned here in April 2018 and we're now in April 2019...

Adding your password to your URL seems to work but surely cannot be the adequate solution to this issue. What solutions do you recommend?

In the meantime, I've tried finding the ticket in your public bug tracker to vote and comment it, but couldn't find it.

Like # people like this
eldes May 15, 2019

@bgannin, thanks for the suggestion to add the password in the URL.
This worked for me in an job emergency.

But I agree with you: this isn't the adequate solution to this issue. 

Like brentatseagreen likes this
Karol Kowalewicz June 28, 2019

Hello @Seb P 

Correct link is git-flow issue

Other solution is switch to ssh.

12 votes
BUROVIC September 11, 2018

Try change repository link format from "https://username@bitbucket.org" to "https://username:password@bitbucket.org"

It helped for me

duanemitchell September 11, 2018

This worked for me. Thanks.

gayankasun September 17, 2018

its worked for me :D

BaoTranQuoc September 25, 2018

Many thanks you guy. This worked perfect for me :D

luckyclan October 9, 2018

It works! It seems they want our passwords...

Rodrigo Acevedo October 10, 2018

It works!!! Thank´s 

andrew_campher October 10, 2018

Thats Super insecure!!!!

Like # people like this
Sudheesh M S October 21, 2018

👍

aallred February 13, 2019

This worked for me as well!

kondratx April 24, 2019

This worked for me. Thank you!

sorellanafaro April 25, 2019

insecure but it works! :D

ttmdaniel May 2, 2019

his worked for me. Thanks.

Renato Santos May 11, 2020

Work for me to, Thanks.

Geoffroy Baylaender June 12, 2020

Worked for me, too - not really safe :D 

Leotrim Lota September 22, 2021

For security reason you can create App password for specific purpose, you can find more details in the following link: https://support.atlassian.com/bitbucket-cloud/docs/app-passwords/

nxtcristian September 22, 2021

@Leotrim Lota The password is still visible in the link, and anyone could simply copy it and use it no matter which app it is. App passwords are not actually aware of the app that uses them.
Actually, thinking about it, an app password might be even worse because you loose the two-step verification of your account's login. So, on the one hand, your account's password allows access to your account - on the other hand, an app password allows any app to make changes in a repository.

So, approaching 2022, after almost 4 years, the same issue that leads to a security issue, is still there.
Hey @atlassian, what have you been working on lately?

Like # people like this
Bielkina Viktoriia March 22, 2022

its worked for me :D

Thanks! <3

goofyfooter October 11, 2023

I tried adding my BitBucket password. That didn't work so I tried my "App Password" and that worked! 

6 votes
PeterDev September 18, 2020

FIX IT (09/2020)

All the the answers here are wrong... You shouldn't NEVER do something like that:

https://username:PASSWORD@Bitbucket.org


SOLUTION
All you have to do is:

- Go to Sourcetree -> Preferences -> Git
- You will have the section "Git Version" with 2 options: Reset to ebedded Git and Use System Git

Sourcetree use the Ebedded git for default.
Click on "Use System Git" and.... Fixed!

---------------

Follow me on:
GIthub
Twitter


luckyclan September 30, 2020

Thanks. It works!

luckyclan March 22, 2022

Update: it worked on one computer, but doesn't work on few others... It seems the only 100% working solution is "https://username:PASSWORD..."

6 votes
Gabs September 1, 2018

Same problem here! and it's now September 2018

dbleckly September 7, 2018

same...

Rodrigo Acevedo October 10, 2018

same...

5 votes
Bruce Rudolph January 6, 2020

I have just gotten this error for the first time. I am running the latest version, 4.0 (232) on a Mac. Tried to finish a release.

This bug needs to be resolved.

Wesley Christelis July 10, 2020

I also just experienced this now 

4 votes
bart March 11, 2019

I'm still having this issue. version 3.1.1 

it's March 2019 - How is this still a thing? lmao

I'm also on mac os x 10.14.3 

astrid_varga April 2, 2019

Same here...

Sourcetree 3.1
MacOsX 10.14.4

@Atlassian please fix this 

Like nxtcristian likes this
nxtcristian July 10, 2020

July 10th, 2020, Source v4.0.1 (234)

Still the same

@Atlassian still working on this?

2 votes
Yohann November 13, 2019

Same problem today with Sourcetree 4.0

duanemitchell November 13, 2019

That's bad news. I got it working but have spent hours and hours trying to figure it out. I did switch to an SSH connection but had problems with that too. I went back to a regular connection. It's been working so far but not surprised to hear your report of another failure.

I've been testing the competitive application Fork. It provides more complete error messages and is helpful to sort issues out. 

ptsiogas December 5, 2019

The issue still exists. Version 4.0 (232). It's really annoying.

duanemitchell December 27, 2019

Well here it is just a little over one month from my post above where it was all working and now it's not working again.

I've been in software development for over 20 years and once in a while a software product comes along that my peers and I would consider to be "worse than useless". This is such a product. If it were obviously useless you wouldn't waste your time but this is worse than useless because you spend so much time and get nothing for it.

It's often more important as to who you are partnering with in software development as well as the software product they've developed. This is such a case. You would think they would have pride in their product and would contact one of the developers reporting the problem to resolve it but no. They don't care and it's been over a year. 

2 votes
luckyclan April 5, 2019

This bug was introduced exactly one year ago! Still not fixed. We have to use URL with password in Repository Settings, which is very unsafe. HAPPY BIRTHDAY!!!

Is anybody in Atlassian working on that?

@bgannin , @Manju ?

2 votes
duanemitchell October 11, 2018

Just updated to v3.0 and now this issue is back on my desktop Mac. I never had the problem on my Windows machine. Not sure about my laptop.

Manju
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
October 11, 2018

Is this for a git-flow action?

mchambaud October 23, 2018

Same issue, using git-flow action

jllorenteIAR October 29, 2018

I got same issue 29-10-2018, using git-flow action.

Cant even login in OAuth method...

2 votes
duanemitchell September 11, 2018

I've been having this issue ONLY when trying to finish a feature. Just finished some testing and the problem still existed. Then I tried the solution suggested by @BUROVIC above. Which is:

Try change repository link format from "https://username@bitbucket.org" to "https://username:password@bitbucket.org"

However I get this warning:

password_warning.jpg

To find this setting open the repository and go to Repository->Repository Settings->Remotes tab.

duanemitchell September 11, 2018

But this worked and I'm not so comfortable doing this.

In the past I've made my commits, moved over to my Windows machine, pulled the changes, and then done the Feature Finish.

Again, this only happened to me when finishing a feature.

Manju
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
September 11, 2018

If this is specific to git flow actions, I would recommend you to move this to a separate thread or submit a ticket on our public issue tracker for us to look into. 

Thanks,
Manjunath
Sourcetree Mac Developer   

2 votes
Virl August 22, 2018

Issue is still present in 2.7.6 (177) — git flow is broken because of it.

 

Atlassian, please fix it already!

Javier Mora Casas August 23, 2018

I've the same problem in last version  of sourcetree for mac, any solution? 

ke4vtw August 31, 2018

This has been a problem for five months now, and it's still biting me! Atlassian, where are you? We shouldn't have to use SSH just to do this basic operation!

wangdu1005 September 19, 2018

It's six months now....Sep 20

1 vote
Olivier Wenger July 18, 2019

Same issue on 3.2.1 !

henryincentfit July 22, 2019

Same in 3.2.1 on OSX

1 vote
Mongezi Nombewu May 13, 2019

Issue is still ongoing without resolution on Mac

1 vote
mwegener February 5, 2019

Same problem with Sourcetree 3.0 (200). Occurs when finishing a hotfix e.g.

Manju
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
February 7, 2019

This is a known issue with some of the git flow related actions. The team is looking into it and will address it in an upcoming release. Appreciate your kind cooperation and patience in this regard. 

Wiingaard March 7, 2019

Same problem with Sourcetree 3.0.1 (205). Occurs when finishing a release via Git Flow.

I use ssh and two factor authentication, but the remote url was set as a HTTPS format. I changed it into ssh-format like this git@bitbucket.org:<account_name>/<repo_name>.git, which solved my issue..

1 vote
andrew_campher October 10, 2018

Great, just upgraded to V 3.0.6 and get this error... how do I now work????

Joris Giesen October 29, 2018

I only get this error when finishing a git flow feature (ver: 3.0)!

you could use the following command in your terminal:

# git flow feature finish branch_name

jllorenteIAR October 29, 2018

I downgrade to version 2.7.2, it works for me

Like # people like this
1 vote
duanemitchell June 5, 2018

This happens to me too often. Trying to finish a feature. Getting this error. Just updated to v2.7.4. It was working before the update.

This seems to be a cycle. Works, update, broken, fixed.

duanemitchell June 5, 2018

I move over to my Windows 10 machine, pull the updates, then do the finish on the feature and it works fine. Running v2.6.3 of SourceTree on Win10.

Of course, then I have to go back to my Mac and pull all the changes.

0 votes
rontalman August 10, 2021

Over 3 years now. I'm sure it'll be fixed aaaany day now.

0 votes
Vinícius Carvalho April 28, 2020

2 years now. Happy bugday

0 votes
keitoro February 25, 2020

It is weird to see such an old bug still present in the latest version of sourcetree. I use the password in url solution to this work. But this should really be fixed pronto. 

0 votes
duanemitchell January 26, 2020

I'm a Mac user and I'm thinking that maybe it's how my credentials are, or are not, getting accessed in my KeyChain. It's possible I've got that wrong or corrupted somehow. I've never had this problem on my Windows machine. What's odd is I can commit using Sourcetree but I can't finish a Release.

Anyway, it's been a couple of years, I have way too many problems, spent way too many hours, have not seen any support, and there's been no help so I switched both my git client software and my source hosting.

Rather than Sourcetree I now use Fork:

https://git-fork.com 

And I now host my code on GitHub rather than Atlassian:

https://github.com 

Both are different but I like them so far.

luckyclan January 27, 2020

Thanks. Are these services free for commercial use?

duanemitchell January 27, 2020

Fork is a free and open source project. GitHub is like Atlassian in that the type of account you need will determine whether it's free or if you pay. I'm a single developer and have a free account.

0 votes
luckyclan January 26, 2020

As bug is still there, and nobody knows if Attlassian team is working on that, can anybody recommend a service similar to bitbucket / sourcetree?

0 votes
robertzeng January 25, 2020

the problem still happened, I just jenkins to deploy code on slave

/remotes/origin/*" returned status code 128:
0 votes
chris james December 16, 2019

Sourcetree is JUNK!!! always have issues EVERYTIME  

0 votes
duanemitchell October 4, 2019

Nothing has changed. Don't know why they don't want to get with someone to fix this.

After asking around with other developers it was advised to me to abandon Sourcetree as it is bad software. The suggested solution is to use Fork, another cross platform app. I'm going to that. This has cost me way, way too much in lost time.

terrificminds February 13, 2020

.

0 votes
Sean Payne October 4, 2019

I'm still having the same issue as well ever since I changed my laptop password (AD-backed).

0 votes
Jonas Altin October 4, 2019

I am still seeing this bug and I am on Sourcetree verison 3.2.1.

Was this issue never fixed or what is the status? Would be great if someone from Atlassian could respond.

Jonas Altin October 7, 2019

I got around the bug by switching to ssh instead.

Like Yohann likes this
duanemitchell October 7, 2019

@Jonas Altin

Are you on a Mac or Windows machine? If you are on a Mac please explain how to do this. Thanks.

Jonas Altin October 8, 2019

I'm on a mac.

 

This link should explain how you can do it:

 https://confluence.atlassian.com/bitbucket/set-up-an-ssh-key-728138079.html#SetupanSSHkey-ssh4SetupSSHwithSourcetreeonmacOS (the section that you need to look at is 'Set up SSH with Sourcetree on macOS').

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events