Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,745
Community Members
 
Community Events
176
Community Groups

Unable to finish release with sourcetree 2.7.6

I'm having issues while trying to finish a release with sourcetree 2.7.6 on macOs High Sierra (10.35.5). Getting this error message:

 

fatal: could not read Password for 'https://[accountName]@bitbucket.[domain.com]': Device not configured

Fatal: Could not fetch release/1.0.3 from origin.

 

Anyone any experience in resolving this issue? Version 2.7.3 seems to have the same problem. Pulling/pushing/... is working correctly.

 

Thanks in advance,

Koen

19 answers

This worked for me!! Thanks!

It worked! thank you 

This fixed the problem on my Mac.

Didn't work for me.

It worked! This fixed the problem in my Mac too.

Excellent, worked for me in less than a minute !!

this solution saved the day! Thanks!

Atlassian: please fix this. 
Version 3.2.1 (225) and still broken gitflow.

This has been an issue for over a year.

v. 3.0.1 (205) Device not configured with Git Flow when finishing feature or release. please fix. (MacOs 10.14.1)

+1

Atlassian .. please fix this.

Like jeanherman likes this

Atlassian developers are high on weed i guess from over a year. It is not at all acceptable from such big platform. 

They don't even reply on the queries and concerns. Highly disappointed. *Red flag* for this tool.  

Atlassian: please fix this. 
Version 3.2.1 (225) and still broken gitflow.

This has been an issue for over a year.

still facing 19th sep 2019

Atlassian: please fix this. 
Version 3.2 (224) and still broken gitflow

Issue is still present in 2.7.6 (177) — git flow is broken because of it.

 

What the hell Atlassian??

Still broken in 4.0(232) !!

Still broken in 3.2.1

Atlassian: please fix this ... 

This is still broken in 3.2

Problem only happens when the release / feature / hotfix branch is tracked / pushed on origin. Local branched with gitflow do work 

This does not seems to be solved in Sourcetree 3.0.1.

I'm using OAuth with SSH and it is NOT working for me. Still getting:

fatal: could not read Password for 'https://XXXXXXXXX@bitbucket.org': Device not configured

Fatal: Could not fetch feature/1.15-ticket-work from origin.

Switching my account to use SSH instead of HTTP auth fixed the issue for me.

I confirm this workaround is working!

Didn't work for me

Even though I found this annoying initially, once I worked out that git-flow is actually just a bash script, and that I could find it in the SourceTree app area (on my mac:  /Applications/SourceTree.app/Contents/Resources/git_local/gitflow/git-flow) - then I have just started using the command line on my repos a lot more. I still love the way a GUI like SourceTree shows me quickly exactly what changes have been made (as opposed to just the files). And if course being able to see a visual representation of the commit trees is great too, but overall I'm glad to be getting a lot better at using git in the terminal.

It's the same here and I'm pretty sure its related to Sourcetree (2.7.6 177) itself. From command line everythings works as expected. Even doing the steps of "Finish release" manually works.

I'm having the same problem in 2.7.6 177 too.

Hi, 

Since the last release, we experience the same problem when trying to finish a feature (using Git Flow > Finish Current):

fatal: could not read Username for 'https://gitlab.com': Device not configured

Fatal: Could not fetch feature/xxx from origin.

 

Sourcetree 2.7.6 / macOs High Sierra

0 votes
Ana Retamal Atlassian Team Jun 14, 2018

Hi Koen! To which service are you connecting? Have you connected your account already following the steps at Connect your account?

For troubleshooting purposes, have you performed the same operation from the command line? What is the result?

 

Cheers!

Ana

Thanks for your reply Ana.

We are connecting to an on premise bitbucket server. Will try to perform the same operation from command line and post the result here.

Thanks,

Koen

Hi Ana,

I was able to finish the release using command line. However, I would expect it to work from Sourcetree.

Cheers,

Koen

Hi Koen,

I have had the exact same issue as you. Trying to finish a release on macOS High Sierra after updating to 2.7.6 SourceTree and no luck.

I've spent so much time updating the BitBucket server and resetting passwords but no luck.

This has happened before too so I should have remembered.

The command line worked for me too, and now I can use SourceTree again.

Thanks!

Just a follow-up. SourceTree worked after reverting back to 2.6.3 with no issues at all.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events