• Community
  • Questions
  • Firefox: attempting to login to my.atlassian.com produces endless page reload

Firefox: attempting to login to my.atlassian.com produces endless page reload

4 things about me (some of which might not matter):

* longtime Bitbucket user
* I change passwords on important accounts (inc BB, now therefore Atlassian) with period ~= 90 days
* I webbrowse with Firefox, and am currently still on Firefox version=56 (i.e., pre-Quantum) waiting for an extension to upgrade
* I run OS=Linux distro=Debian version=8.9

To change pw, I browsed to https://my.atlassian.com and attempted to login using what I strongly believe to be my correct credentials (including ID=email). I then got redirected to

https://id.atlassian.com/login?application=mac&continue=https://my.atlassian.com&token=<alphanum string length=280/>

[loop top]

which attempted to redirect again, which produced the Firefox warning

> Firefox prevented this page from automatically redirecting to another page.

I hit button=Allow, which immediately reloaded the page, but returned me to top of loop.

[loop end]

After ~20 trips through loop, I websearched on term='Atlassian login reload', which returned (et al) some helpful-looking material from domain=atlassian.com. I took what seemed to be the most useful advice, which was to

1. dump cookies
2. dump cache
3. reload browser

I did this, then rebrowsed to https://my.atlassian.com , but observed no change: same infinite redirect/reload loop.

What to do? Meanwhile, will retry on another box with Quantum aka Firefox version >= 57.

2 answers

0 vote

Hi Tom,

Sorry to hear that there is a problem with logging into one of our sites.  I am interested to know if this only effects Firefox.  Is it possible to login to the site from this machine using another browse such as Chrome?

I suspect there might be another problem here though if that doesn't work.

Try going directly to https://id.atlassian.com and see if you can login directly to that site first.  If you can, I would suspect this page might take you to your profile page.   If you can login directly there, I would be interested to see if you can then use the same browser tab/session to then navigate directly to https://my.atlassian.com

and see if that works.

If you're still getting this stuck in an endless login loop, please let me know the the username/email address you are using to try to login to our site and I will launch an internal investigation to see if there is perhaps something wrong with your specific account that might be causing this problem.



Hi Andy, I have the same problem with looping if I try to switch apps from sidebar to HOME application. 

1. Open sidebar

2. Click to "HOME"

3. Confluence and JIRA software clouds instances react the same behaviour - application will start with some loop (https://id.atlassian.com/login?continue=https) and I cannot stop it or return to JIRA or confluence. 



Hi John,

Is this problem happening for your in Firefox only?  I am curious to see if perhaps we can learn more about your environment to understand the scope of this problem better.

Also, does this effect other users in your environment?  Different browsers?   I would also be interested to learn about your specific Cloud URL.  I would like to try to reproduce this problem so we can better understand what might be causing this.  

So far I have not been able to recreate this problem yet.

Hi Andy, I tested with new JIRA cloud instance and the behaviour is the same, but only with Chrome! I checked in IE11 and it works correctly. 

Problem with HOME and looping exists in Chrome. 



Please could you reproduce this problem. 

Thank you. 

Hi @John Xolobo

So far, I have not been able to reproduce this problem.  Could you let me know more about your environment?  Are you also using a Linux OS, like Tom initially reported on this thread?

Could you let me know what specific versions of Firefox and Chrome you are using?

Have you tried to use the Private browsing mode or Incognito mode in either of these browsers?   I am curious to see if you can recreate this problem in these private browser modes to see if this is possibly related to a cookie/cache or possibly some other extension in the browser itself.

Suggest an answer

Log in or Join to answer
Community showcase
Jason Wong
Published Tuesday in Agility Beta

Welcome to agility

Every team in the world is unique, and so   Atlassian believes   that each and every team's best way of working  needs to  be molded to their unique circumstances  – ...

436 views 6 16
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot