Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot logon to Atlassian website using Firefox 59.*

Edited

Hello,

I cannot login to Atlassian website (bitbucket, wiki, jira) using Firefox 59.*  I am not sure it is problem with Version of FF but just for the record ...  The webserver says:

Something has gone wrong

Check that your browser allows third-party cookies and then
try again using the button below (without refreshing the page):

But I allowed third-party cookies to be accepted. Can anyone hint me how can I investigate it ?

15 answers

Update: It's Dec 12, and I still can't use Firefox 60.1.0esr on OS X to authenticate to either of our JIRA or Confluence cloud instances with my Google account credentials. I've verified that all of my browser settings match what Atlassian recommends. I've removed all *atlassian* domain cookies. I have disabled all security mechanisms. And nothing works.

I can successfully use Chrome on OS X to authenticate to JIRA/Confluence cloud with my Google account credentials. And this works even with all of the same security plugins and settings I disabled in Firefox active in Chrome.

My patience with JIRA and Confluence is coming to an end. Firefox is not a fringe browser, and your cloud apps should support it. Ignoring or hand-waving the problem away is not a valid solution. Forcing me to open Chrome just to access your cloud apps is absolutely absurd.
Please fix this problem.Regards,-Rob

I just solved this issue for myself: Firefox was stripping the referer (yes, that's how it's spelled) header. Make sure nothing is changing that (all the network.http.referer.* about:config entries are defaults) and that no addons are spoofing it. In my case it was uMatrix, simply turning off referer spoofing for *.atlassian.com fixed the issue.

Firefox will spoof the referer when in private browsing mode by default (whenever tracking protection is turned on). This will break Atlassian's web sites. Because disabling this spoofing allows easier tracking (contrary to the purpose of tracking protection) I suggest making a second profile (about:profiles) just for Atlassian with these settings disabled, and leaving them on elsewhere. This is annoying, but if Atlassian is going to misuse the HTTP headers we just have to work around it.

Amazing. Thankyou, I had changed one of the about:config settings to block referer sending. Now it works.

Thank you for the hint!

Indeed, my issues started after I enabled "Spoof referer header" in uMatrix plugin.

Apparently, it is sufficient to temporarily allow referer for login and can be disabled afterwards.

In case anyone else has this. Add:

referrer-spoof: atlassian.com false

to uMatrix -> Dashboard -> MyRules

Update: Lately also had to add

referrer-spoof: atlassian.net false

Like # people like this

Thank you this solved for me as well! In my case, network.http.referer.XOriginPolicy was set to 2 (Rather than the default 0).

Like # people like this

Adding the following to uMatrix "My rules" running in FF ESR 78.8.0 fixed the login problem:

referrer-spoof: atlassian.com false
referrer-spoof: atlassian.net false

I don't know why Atlassian needs to do whatever it is that requires this change, but I do know that their sites are the only ones I have encountered that break because of it.

fyi I'm a uMatrix user as well (on FF Nightly), and even after following the suggestions on this (thank you for those!) it still wasn't working until I disabled and then re-enabled the extension. A restart could've also had the same effect.

Companies that continue to attempt to force tracking will hopefully be put out of business for what I consider shady business practices. If I don't want to be tracked and labeled on the internet I shouldn't be forced to do so. It's a good thing I have pull within the company to switch services. I'm hoping others do the same.

Apparently, Atlassian is trying to fingerprint browser. And I have configured the browser to resist fingerprinting scripts and hence the issue. Once I have disabled the config privacy.resistFingerprinting, I am able to access the same. I really wish Atlassian stops tracking!

P.S: I have written this as a comment earlier. Since many people are facing this issue, I thought adding it as answer would help!

I have wasted good chunks of time searching for a solution regarding this problem. I can't believe anyone would try to track/fingerprint paid users. This is absurd.

I'm in the same camp.   Firefox not letting my log in with Firefox 81 on OSX.    Chrome will bring up login page but I don't give Chrome my credentials for my work stuff.  I keep Firefox for work and Chrome for personal use.

0 votes

I had this problem.

Changing  privacy.resistFingerprinting to false in about:config resolved the problem!

IMO using the REFERRER header for such basic logic as a login process is no good practice.
You're locking out companies and people caring about privacy and security.

My arguments are basically stated here: https://stackoverflow.com/questions/8319862/can-i-rely-on-referer-http-header

Thanks for fixing this.

Atlassian should fix this ASAP

Hi There,

Had the same issue.

Can you try something, for me it works just after a did this.

Try connecting to another internet connectivity else that your usual one and try login.

See if it load and if it loads properly, reconnect to your usual internet and try.

Hope this help you.

Best Regards
Junaid

i current have same issue on firefox. Can't use jira on firefox. If not for my company, i would have dumped it. it is crazy that you guys can not contact firefox to resolve this issue.

Hi There,

Had the same issue,

Can you try something, for me it works just after a did this.

Try connecting to another internet connectivity else that your usual one and try login.

See if it load and if it loads properly, reconnect to your usual internet and try.

Hope this help you.

Best Regards
Junaid

Same issue, up to date firefox, cleared all cookies (all of them, not just atlassian), switched off all the blocking I can find (ublock and the built-in stuff), fingerprint resistance is off and nothing works.


This is really frustrating, I want to move away from google, but Safari has problems with some other sites I use for work, and Firefox on MacOS can't seem to use atlassian services.

Update: This has been solved , I had changed a setting so that referrer sending was blocked. Changing that back in about:config fixed the problem, and I can now use Jira in FF quite happily, even with tracking protection and ublock origin enabled.

I have disabled Privacy Badger for the site and things started to work(had to disable it for id.atlassian.net and then for our own subdomain under atlassian.net as well).

It's a shame that Atlassian's stuff break down if tracking scripts are blocked, but at least there's a solid workaround. 

Like # people like this

I have Firefox network.http.sendRefererHeader set to 2 (default) but still cannot log in.

Disabling Privacy Badger or just unblocking the tracking device from atl-paas.net works for me! Thank you!

Have the same problem with actual Firefox version 64. Allowing cookies, scripts etc. nothing helps:

Bitbucket-Login: just a short sandglas then nothing and still front page with login buton

On Jira and confluence page of the hosted atlassian product: secure/dashboard is loaded. The login button (lower left) has no function.

When i go to my profil page i get the message: "An error occoured" on all pages exept Email and Security.

Same issue - I allow third-party cookies, have cleared all existing cookies. 

 

Firefox 64.0 on Mac OS X.

Ana Retamal Atlassian Team Jan 09, 2019

Hi Rob,

 

Have you tried unblocking scripts from third-party domains in your browser? A next step would be to check the configuration of the browser and allow the download and execution of javascript from 3-rd party domains.

We've also done some tests in our end and found that the problem with Firefox Quantum and Bitbucket is related to its setting "privacy.resistFingerprinting" set to true. Disabling it should provide you with the login prompt. We are currently checking with our devs why this is necessary.
Cheers!
Ana
Like Junaid Balladin likes this

Hi Ana,

Different Rob responding here. Just saw your message to Rob Agle

Will try your suggestions as soon as I have some free time to experiment with FF.

Thanks,

-Rob

Like Junaid Balladin likes this

Hi @Ana Retamal ,

We're in October 2020. I'm facing same issue on Firefox. Were you able to work with DEV on the issue and sort out (abusive) requirement on browser fingerprinting?

Regards

Px2

0 votes
Ana Retamal Atlassian Team Apr 03, 2018

Hi Przemyslaw! I tried reproducing the issue you described and I was able to log in to my Cloud accounts using Firefox 59.0.2.

Can you make sure that third-party cookies are allowed in your browser?  Can you also try a different one to discard the idea that there's a problem with your credentials?

Let us know!

Ana

I can login using Chrome so there is no problem with my credentials. I am pretty sure it is something with my Firefox but to be honest I disabled most of my add-ons and the problem didn't disappear ...

Like Rob Agle likes this
Ana Retamal Atlassian Team Apr 04, 2018

Hi Przemyslaw, if the problem is occurring with your Firefox installation, I'm afraid there's not much we can do from Atlassian to assist you. Just to help you identify where the issue is, can you try the incognito mode and see if you can log in? Also, can you confirm that third-party cookies are allowed in your browser? 

Best regards!
Ana

having same issue also here

but for me not able to open jira on any browser.

error message is "check that your browser allows third-party cookies and then try again using the button below (without refreshing the page)"

 

Please help

Like Rob Agle likes this

Same here. Did you find a solution?

Like Junaid Balladin likes this

I am encountering the same issue on Firefox 61.0.1/Ubuntu 16.04. Although I get only "Something has gone wrong". 

I have cleared all cookies/cached data, tried in private window. But doesn't work. It did work couple of days back. And it works on chrome!! 

Following is source code of the response. Firefox isn't able to render it and simply shows "Something has gone wrong". 

<!doctype html>Log in with Atlassian account

Atlassian

JavaScript load error

We tried to load scripts but something went wrong.

Please make sure that your network settings allow you to download scripts from the following domain:

https://aid-frontend.prod.atl-paas.net/atlassian-id/front-end/2.6.32

Apparently, Atlassian is trying to fingerprint browser. And I have configured the browser to resist fingerprinting scripts and hence the issue. Once I have disabled the config privacy.resistFingerprinting, I am able to access the same. I really wish Atlassian stops tracking!

 

Like # people like this

I am unable to use my Google account to authenticate to any Atlassian cloud apps/sites with Firefox 60.1.0esr on OS X. The same Google account works fine with Chrome 69.0.3497.100 on OS X. And, I don't have this problem with any other sites I access with Firefox. It's just Atlassian sites.

It seems obvious that there is some sort of problem with accessing Atlassian resources via Firefox, so it would be great if their support people would acknowledge that there's an issue, and work with people to resolve it.

Thanks,

-Rob

Like Junaid Balladin likes this

I'm having the same problem, login using Chrome works fine, but using Firefox fails. This only occurs on the Bitbucket website, not on other websites such as Gitlab or Github. I'm using macOS 10.13.6. I was hoping the problem went away so I started using Chrome for Bitbucket, but this has been going on for at least a month for me, so I figured I'd be best to report this.

Like Junaid Balladin likes this

I also have the same problem and can not even open the login page on the main Bitbucket site. It just clicks and nothing happens and when I try with all other possible links to login page or account page it also goes to a blank page with the words "loading page" I can't even access bitbucket.org if I manually type it in the main browser address area it does not go there. If I do a Google search for bitbucket the listings come up and if I click on any of the Bitbucket links to the main site it does not respond and just flashes. So something is blocking it somehow. Some kind of tracking is being done on the main site and Firefox is not allowing this evil to happen. I have looked in the Firefox options and turned off all I could and all my pop up and ad blockers too. Third-party cookies are allowed.

What the hell Atlassian!? Have you gone totally evil now? Do I have to go back to Github?

Win10 64bit

Firefox

Like # people like this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

New improvements to user management in Bitbucket Cloud 👥

Hey Community! We’re willing to wager that quite a few of you not only use Bitbucket, but administer it too. Our team is excited to share that we’ll be releasing improvements throughout this month of...

3,741 views 10 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you