Opsgenie Android app leaving Do Not Disturb on constantly?

Tim Page April 8, 2020

Hi,

Since installing the Opsgenie app (and granting the permission to override Do Not Disturb, when prompted), I'm finding my phone is constantly in DND mode - overriding my normal schedule. 

A colleague sees the same on their phone, but other colleagues on a different Opsgenie account/schedule don't recognise the problem.

I have had 2-3 alerts trigger, but I'm not on call at the moment and there are no longer any active alerts.

As it stands, I'd have to stop the app from overriding DND, which would risk missing alerts overnight.

Is this a known problem? Are there any setting controlling how Opsgenie overrides DND which I have configured incorrectly?

Android > Settings > DND :
On/Opsgenie
Turn on automatically: 1 rule: (set to nighttime hours)
"Do Not Disturb was automatically turned on by an app (Opsgenie)"

Opsgenie vesion 3.3.4
Android version 9
Moto G8 Plus

Thanks in advance for your advice!
Tim Page
Technical Director
Well Played Games

3 answers

John M
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
May 25, 2023

Hi All,

I've just published an article on this topic here which should resolve this issue:

https://community.atlassian.com/t5/Opsgenie-articles/How-to-prevent-Opsgenie-Android-app-from-leaving-DND-on/ba-p/2370338#M360

Phil Brown May 28, 2023

Should the app setup on Android also be modified to no longer prompt?

I haven't attempted a re-install yet but last time I did it still asked for DND permission.

In fact, I see somebody has left a similar comment on the article.

0 votes
Patrick Graham April 26, 2023

I'm experiencing the issue described here as well. I thought it would behave well working around my phones dnd schedule and pushing notifications through so I had given opsgenie all the permissions to override dnd. I suspect this issue isn't as wide spread because not as many people have a dnd schedule than conflicts with the opsgenie on call schedule and went through the trouble of granting permissions to opsgenie? 

Anyway, here is my plan to work around it: disable opsgenie access to dnd and update my phones dnd schedule to accommodate my on call schedule. 

0 votes
Brennan Kiely
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
April 9, 2020

Hi Tim,

Thank you for reaching out. This is an issue we've seen before and is due to a limitation with the Android platform. If you are using scheduled DND mode, apps can't see what the schedule is. They can just see whether or not DND is on, so Opsgenie turns off DND mode for the notifications and then turns it back on after. 

We've found that if you're using scheduled DND times, it works better to set the app to override DND on your phone itself instead of within the Opsgenie app. You can do this on your phone under Settings > Notifications > Opsgenie. You'll want to select a notification category and then toggle 'Ignore Do not disturb' at the bottom.

Thanks,

Brennan Kiely

Stephen Nancekivell March 29, 2021

FWIW, I've had this as well. Hope it can be improved. Getting notifications the whole point of this app.

Like shanek likes this
Michael Gorelik December 25, 2021

Still broken

Android11. S10. Work profile.

 

Brennan it is not possible to do what you suggesting. App is not found.

 

It also not possible to do simple dnd override unless you install opsgenie into home profile.

 

PLEASE FIX THE APP.

it really useless as this 90% we need

Brennan Kiely
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
January 3, 2022

Not being able to set DnD overrides on the work profile is a limitation of Android. The app will need to be installed on your personal profile if you need to override DnD on your device.

Phil Brown July 13, 2022

Why is OpsGenie re-enabling "Do Not Disturb" but in a non-scheduled configuration?

Please disable this feature, it simply does not work. Leave "Do Not Disturb" switched off. The alternative (enabling a perpetual "Do Not Disturb" that must be manually disabled) is much worse.

Like # people like this
Jon Miller October 14, 2022

Is there still no resolution to this? OpsGenie turned my Do not Disturb on without my knowledge and I missed multiple important calls and notifications. These suggestions and the ones provided here do not make sense to me. I have to allow OG to interrupt DnD if I want it to not randomly turn it on? I would rather OG have no ability to override my DnD settings at all. If I want OG to interrupt DnD, I would configure that through my phone's settings like I do every other app.

Lane Rosa March 20, 2023

I am having the same problem as others in this thread. I'm missing not only my Opsgenie pages but all other notifications because Opsgenie enables DND and doesn't turn it off when it is supposed to be paging me. I do not use DND at all, much less DND scheduling. I'm surprised there has been no resolution to this after well over 5 months of experiencing this issue. 

Like # people like this
Isaac Avery April 11, 2023

Would love to hear an actual resolution for this 3 year ongoing problem.

Previously ops genie has enabled DnD at completely random times during the day.

However, most recently I've had ops genie enable DnD WHILE I WAS ON CALL.....

 

Please fix your broken app Atlassian, this has gone on for FAR too long.

 

Side note: The original answer doesn't even make sense as it is impossible to give ops genie control over DnD within the ops genie app itself, the option simply doesn't exist.

Furthermore, I've done exactly what was suggested in the answer by giving ops genie permission to bypass DnD from my phone settings, and the problem is still ongoing.

Like # people like this

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events