Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,362,001
Community Members
 
Community Events
168
Community Groups

Why is Opsgenie touching my Do Not Distrub setting. Please Stop

When using OpsGenie I have noticed that my phone's Do Not Disturb settings are getting over ridden. This is causing me to miss other important notifications which are resulting in my boss calling my wife's phone to wake me up at 4:00(EDT) in the morning because I did not respond to a notification from a different app.

My Do Not Disturb settings are set for a reason. Please correct your software to NOT override my settings.

2 answers

@Samir 

We usually recommend option 2, doing it through the phone settings.

 

How can you say you recommend #2 if app does #1 by default.

 

On top #1 is broken on Android 11 in work profile. I have at least 2 people in my org with same problem

0 votes
Samir Atlassian Team Mar 30, 2021

Hi @Brian Grier - is this on iOS? If so - did you enable "Critical Alerts" for the Opsgenie mobile app?

 

You can check this by going to your phone Settings -> Notifications -> Opsgenie, and toggle off "Allow Critical Alerts". This is a feature that, when enabled, will override Silent/DND settings. The reasoning is because some people need Opsgenie notifications to wake them up, so this feature allows the notifications to be played at full volume.

 

You have the option to turn it off by toggling that switch.

 

Thanks,

Samir

No this is on Android 11.

The version of Android should not be an issue, Your software SHOULD NOT be changing my DND setting. It should also not be changing my ring volume to 0.

Just fix the app to NOT modify any DND settings. They are set for a reason. You application muting other applications is just wrong.

Like # people like this

One more thing.
I was aware enough when I added Opsgenie to my phone I granted it permissions to notify me while DND is active, which is WORK HOURS.

It is that simple. You have tried to make it so simple an idiot can use it, But instead you broke things.

Does it make sense to turn Do-Not-Disturb ON while setting the ring volume to ZERO so your app can alert me when it needs to? I mean Do-Not-Disturb is already off, and I really would like to know when my wife, or boss at 4:00 in the morning, is calling me.. 


Samir Atlassian Team Mar 30, 2021

Hi @Brian Grier Thank you for clarifying.

The ability for the Opsgenie app to overwrite Do Not Disturb is a feature we offer since a lot of users want to receive Opsgenie notifications even when DND is enabled. For example, to be woken up in the middle of the night for critical alerts.

So we wouldn't be able to completely remove the feature of Opsgenie being able to manage the phone DND settings, as this is a feature a lot of people use.

There are 2 ways to manage DND settings with apps...

1) There is an option within the Opsgenie app itself to "Always play Opsgenie notification sounds at full volume even if the phone is in silent mode". This feature is discussed here: https://docs.opsgenie.com/docs/android-app-enabling-disabling-notification-overwrite-volumes. When you launch the Opsgenie app for the first time, there's a popup that asks if you want to let opsgenie control your DND settings.

If you do it this way, then if DND is on and an Opsgenie notification comes in, the OG app will turn DND off so you receive the notification, and then turn it back on.

You can disable that option if you don't want the Opsgenie app to be able to control your DND settings

 

2) Alternatively, you can manage your phone's DND settings by going to Settings -> Apps & Notifications -> Do Not Disturb, then there's an "Apps" section to display which apps can "ignore" DND. So if you do it this way, then even when DND is turned on, OG notifications will still go through.

We usually recommend option 2, doing it through the phone settings. Especially if you have a "Schedule Do Not Disturb" setup, because Android doesn't allow apps to see the schedule, so if Opsgenie turns DND off to notify, then turns it back on, it will be turned on indefinitely, instead of being set back to the schedule.

 

It's probably worth uninstalling the app, and re-installing so you can start fresh with the permissions settings.

 

Hope this helps.

Thanks,

Samir

Like # people like this

I'll try reinstalling, but my main concern is that your software turned ON Do-Not-Disturb while setting the ring volume to ZERO.


If that persists we will have to re-evaluate your solution.

I have nothing by trouble from opsgenie app on my s10.

 

It does do turn on dnd thing permanently. 

 

It does find opsgenie installed in workprofile to even allow option 1.

Screenshot_20211224-105522_Settings.jpg

 

It sees app for option 2 but unable to be added. Every other app I tried was fine but opsgenie. Ops genie is not found

Screenshot_20211224-101911_Settings.jpg

 

If I install Ops genie in home profile I am able to slide by option 1 as it now appears and seem to enable but I am to square one with useless opsgenie app turning dnd most of the time.

 

You GOTTA fix your app. It does not do its main function!

To clarify for @Samir the issue is not that Opsgenie disables DND to reach the user.

The problem is that Opsgenie afterwards will set DND to on and volume to zero regardless of the users previous settings.

 

I only sometimes have DND set to on, but want to ensure OpsGenie can reach me, so I allow opsgenie to do so. Then I find I start missing non-opsgenie calls and messages because OpsGenie has silenced my phone.

Taking DND off or breaking through it is fine. Setting volume to high is fine.

Enabling DND or setting volume to 0 without the user saying so  is a no-no.

Like # people like this

@Samir I don't think you're understanding the problem.

Allowing OpsGenie to interrupt "Do Not Disturb" is not the issue here.

What's happening is that OpsGenie is turning on "Do Not Disturb" mode. It should not be doing this at all.

After dealing with an OpsGenie alert, I have to remember to switch off "Do Not Disturb" otherwise I miss regular notifications, messages, calls, etc.

Like # people like this

has this been fixed?  I'm having the exact same issue.  I have an Android phone and your product is switching my phone into "Do Not Disturb" mode.  I am also missing lots of important calls and texts because of this.  Make it stop. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

Online AMA this week: Your project management questions answered by Jira Design Lead James Rotanson

We know that great teams require amazing project management chops. It's no surprise that great teams who use Jira have strong project managers, effective workflows, and secrets that bring planning ...

214 views 1 6
Read article

Atlassian Community Events