javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated - Timesheet Plugin

Good morning,

 

we're running JIRA 4.3.4 and migrated the VM to a new environment. Old environment had have an httpd 2.2 as reverse proxy in the frontend using mod_proxy_ajp and mod_ssl. The new one has an apache 2.4.9 with mod_proxy_ajp and mod_ssl.

But now, the timesheet-Plugin failes due to the following error (in the browser):

An internal server error occurred when requesting resource https://jira.<domain>.net/rest/timesheet-gadget/1.0/timesheet.json.

 

The JIRA log says:

2015-04-07 09:46:12,580 TP-Processor3 ERROR rohozneanus 586x10636x2 17c390m 78.97.93.3 /plugins/servlet/gadgets/makeRequest [renderer.internal.http.HttpClientFetcher] Unable to retrieve response
javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated
...
...

 

The ssl certificate is still the same and was not changed during the migration. But there was a change in mod_ssl with version 2.4.8 of the httpd and SSLCertificateChainFile has become obsolete. See: http://httpd.apache.org/docs/current/mod/mod_ssl.html#sslcertificatechainfile

We're running this setup for a lot of domains and the SSL encryption works fine. No employees or customers reported any errors due to a warning of their clients. But it looks like JIRA does not like bundled certificates. To be honest, I'm not sure if it's a Java 6 or JIRA related issue but any help is welcome. Anyone else running a similiar working setup?

Please let me know when I forgot something important.

 

1 answer

1 vote

Hi Marcel,

Basically it seems like something is messed with your certificate. Have you tried to re-import the certificate in your instance?

These pages should be able to help you out:

https://confluence.atlassian.com/display/JIRA/Connecting+to+SSL+services

https://confluence.atlassian.com/display/JIRA/Running+JIRA+over+SSL+or+HTTPS

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published yesterday in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

31 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you