Xporter "Send Report" post function used to work perfectly, no longer sends email.

Montana Fox February 24, 2021

We are using Xporter 5.4.4 with Jira Server 7.2.7.

Until a few weeks ago, we had success with a few workflows which used the Xporter "Send Report" post function. Suddenly NONE of them are working. I can manually create PDFs with Xporter from the issue screen, but not during a transition post function.

The only things we have done between the last time it worked and now are:

• Upgraded our app server SSL cert from http to https, which changed the Jira base URL.

• Implemented MiniOrange SSO so users could be logged in automatically, which changed their usernames from short (FLast) to full email (First.Last@company.email).

Neither of these things seem like they should be causing a problem, as the post functions do not appear to be relying on a specific base URL or a specific username.

This is the error I found in the log:

/secure/WorkflowUIDispatcher.jspa [c.x.jiraxporter.workflow.SendReportFunction$SendReportRunnable] Error performing send report post function
at com.xpandit.jiraxporter.workflow.SendReportFunction$SendReportRunnable.run(SendReportFunction.java:333)
at java.lang.Thread.run(Thread.java:745)

2 answers

0 votes
Montana Fox February 25, 2021

Still experiencing failure with the "Send Report" post function. However, I tried using the "Create Document" post function instead, and then another post function to send an email, and that works.

Rogério Paiva - Xray Xporter
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 26, 2021

Hi @Montana Fox 

It is best to contact the Xporter Support (http://xportersupport.xpand-it.com/) so that we can request additional information and investigate further.

Kind regards,
Rogério Paiva [Xporter Support Team]

0 votes
Prakash Kumar February 25, 2021

Hey @Montana Fox ,


This is Prakash here from miniOrange.

From the statement, I  concluded that you're using our SAML SSO plugin. 

It is not a problem with the miniOrange SSO plugin as we do not intercept any of the REST calls.

Also, the shared error message is not from the SSO app.

Still, you can also raise a support request to us for the issue debugging and the quick support from us while using the miniOrange SSO app.



Montana Fox February 25, 2021

Thanks for the reply, Prakash. I do not believe there is any problem with the miniOrange SAML SSO plugin.

I only mentioned it because it was a change to our system, and because I'd heard of bugs with Xporter which had occurred when usernames had changed from one value to another. But again, I do not believe that should be a problem in this case, because our Xporter post function is not specifically using any usernames.

Like Prakash Kumar likes this

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events