Why does Jira installation constantly crash?

I tried installing JIRA now for the 20th or something time and it won't work for me.

All I get is a java.lang.outOfMemoryError: unable to create new native thread.

I do know that there is documentation on this error available online but none of the fixes worked for me.

Setting the JRE memory limit to 2GB? Didn't work. Increase the number of allowed threads via ulimit? Didn't work. Installing via automated setup by Atlassian? Didn't work.

It can't really have anything to do with my memory since JIRA tells me this:

```

2015-03-22 17:06:10,915 localhost-startStop-1 INFO      [atlassian.jira.startup.LauncherContextListener] Memory Usage:

---------------------------------------------------------------------------------

  Heap memory     :  Used:  297 MiB.  Committed:  555 MiB.  Max: 1353 MiB

  Non-heap memory :  Used:  180 MiB.  Committed:  195 MiB.  Max: 1264 MiB

---------------------------------------------------------------------------------

  TOTAL           :  Used:  477 MiB.  Committed:  750 MiB.  Max: 2617 MiB

---------------------------------------------------------------------------------

 ```

Did anyone encounter the same problem?

 

(I would really like to use JIRA for our development team but since it took me approximately 4 hours so far and I couln't even work out what exaktly the problem is, I'm reconsidering now.)

2 answers

This widget could not be displayed.

It is struggling for memory, although that might be something going wrong and just chewing up everything it has, rather than you not giving it enough.

Just because it tells you it's using X amount of memory at startup doesn't mean that won't change - a busy system can easily consume a LOT more memory - it's not a static flat line set at startup.

The problem is a dodgy configuration somewhere, but it's impossible to tell from one line of error.  Start by explaining your setup: How you installed it, OS, version of Java and JIRA, what plugins you've enabled, and what the memory settings are (specifically, look in setenv.sh or setenv.bat depending on your OS).

Thanks for your answer! The memory log I posted was logged by JIRA at the end of the attempted installation. I'm running the plain JIRA installation setup (64bit, for JIRA and Agile) on my vServer. 2 vCores, 2 GB RAM guaranteed (up to 4GB), running on Ubuntu 12.04.5 LTS with 64bit. I already increased the amount of memory the JRE can consume to ~1.4MB (in my setenv.sh). The memory configuration: JVM_MINIMUM_MEMORY="600m" JVM_MAXIMUM_MEMORY="1400m" I also changed "-Datlassian.plugins.enable.wait=300" in the setenv.sh.

Setting the JVM_MINIMUM_MEMORY to a high value causes each instance to immediately allocate that much memory. Try just setting the JVM_MAXIMUM_MEMORY and let the system figure out JVM_MINIMUM_MEMORY.

This widget could not be displayed.

I've seen Java apps report "unable to create new native thread" when the process table is full. Can you post the result of 'ps -ef | wc -l' and also 'ulimit -a' ?

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

137 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you